Glossary

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Symbols

.cab file

Cabinet file. A single cabinet file that stores multiple compressed files. These files are commonly used in software installation and to reduce the file size and the associated download time for Web content.

.cer file format

A file format that is used for the storage of public key certificates.

See also: certificate; public key

.inf

The file name extension for files that contain device information or scripts to control hardware operations.

See also: device

.NET Passport

A service that is part of Microsoft .NET Framework. .NET Passport includes a passport authentication protocol, and it provides the ability to map passport IDs to Active Directory accounts.

See also: Active Directory; authentication; passport authentication; service

.pfx file format

A file format that is used for the storage of public key certificates and their associated private keys.

See also: certificate; private key; public key

3DES

See definition for: Triple DES (3DES)

802.1X authentication

An Institute of Electrical and Electronic Engineers (IEEE) standard for port-based network access control that provides authenticated network access to Ethernet networks and wireless 802.11 local area networks (LANs).

See also: access control; authentication; local area network (LAN); port; port based network access control

A

AAAA (quad-A) resource record

A resource record used to map a DNS domain name to a host Internet Protocol version 6 (IPv6) address on the network.

See also: domain name; Domain Name System (DNS); IP address; resource record (RR)

AAL

See definition for: ATM adaptation layer (AAL)

ABR

See definition for: area border router (ABR)

access control

A security mechanism that determines which operations a user, group, service, or computer is authorized to perform on a computer or on a particular object, such as a file, printer, registry subkey, or directory service object.

See also: group; object; permission; registry; service

access control entry (ACE)

An entry in an object's discretionary access control list (DACL) that grants permissions to a user or group. An ACE is also an entry in an object's system access control list (SACL) that specifies the security events to be audited for a user or group.

See also: access control; access control list (ACL); discretionary access control list (DACL); object; permission; security descriptor; system access control list (SACL)

access control list (ACL)

A list of security protections that apply to an entire object, a set of the object's properties, or an individual property of an object. There are two types of access control lists: discretionary and system.

See also: access control entry (ACE); discretionary access control list (DACL); object; security descriptor; system access control list (SACL)

access number

A phone number that subscribers can dial to reach online services.

access token

A data structure that contains the security identifier (SID) for a security principal, SIDs for the groups that the security principal belongs to, and a list of the security principal's privileges (also called user rights) on the local computer.

See also: privilege; security ID (SID); security principal

account lockout

A Windows security feature that locks a user account if a number of failed logon attempts occur within a specified amount of time, based on security policy lockout settings. Locked accounts cannot log on.

See also: policy; user account

account logon event category

In auditing, a group of events that are logged when a user logs on to a computer that uses another computer to validate the user account. Events in this event category are logged on the computer that validates the user account.

See also: auditing; event; user account

account management event category

In auditing, a group of events that are logged when user or group account information is modified.

See also: auditing; event; group account; user account

ACE

See definition for: access control entry (ACE)

ACK (acknowledgment)

A message transmitted to indicate that data has been received correctly. The Transmission Control Protocol (TCP) requires that the recipient acknowledge successful receipt of data. Such acknowledgments (ACKs) generate additional network traffic, decreasing the rate at which data passes but increasing reliability. To reduce the impact on performance, most hosts send an acknowledgment for every other segment or when a specified time interval has passed.

See also: host

acknowledgment message

For Message Queuing, a message class that indicates that a message arrived or was retrieved by the target application (a positive acknowledgment), or that an error occurred before the original message could be retrieved (a negative acknowledgment). These messages are sent to administration queues on the source computer.

See also: administration queue; Message Queuing

ACL

See definition for: access control list (ACL)

ACPI

See definition for: Advanced Configuration and Power Interface (ACPI)

active

Describes the window or icon that you are currently using or that is currently selected. The operating system always applies the next keystroke or command you choose to the active window. Windows or icons on the desktop that are not selected are inactive.

Active Accessibility

An application programming interface (API) built into a variety of Windows operating systems, including Windows 2000, Windows XP, and products in the Windows Server 2003 family. Active Accessibility allows an accessibility aid (or other Active Accessibility client) to collect meaningful information from an application's user interface and convey that information to the user. For example, Microsoft Active Accessibility allows a screen reader to convey to the user that an application is displaying a pop-up message asking whether to save or discard file changes. Because Active Accessibility reduces the need for application-specific code, it reduces overall maintenance costs and allows software developers to innovate in their user interface without sacrificing compatibility with accessibility aids.

See also: application programming interface (API)

active caching

A feature in Microsoft Internet Security and Acceleration (ISA) Server that retrieves files for Web pages that are accessed frequently.

See also: caching

active content

Dynamic content, such as a stock ticker, a weather map, or news, that is usually updated from the World Wide Web or a channel.

See also: channel

Active Directory

The Windows-based directory service. Active Directory stores information about objects on a network and makes this information available to users and network administrators. Active Directory gives network users access to permitted resources anywhere on the network using a single logon process. It provides network administrators with an intuitive, hierarchical view of the network and a single point of administration for all network objects.

See also: directory partition; directory service; domain; forest; object; replication

Active Directory Installation Wizard

The tool that is used to install and remove Active Directory.

See also: Active Directory

Active Directory replication

The synchronization of Active Directory partition replicas between domain controllers. Replication automatically copies the changes that originate on a writable directory partition replica to all other domain controllers that hold the same directory partition replica. More specifically, a destination domain controller pulls these changes from the source domain controller.

See also: Active Directory; domain controller; global catalog; replica; replication

Active Directory Service Interfaces (ADSI)

A directory service model and a set of Component Object Model (COM) interfaces. ADSI enables Windows applications and Active Directory clients to access several network directory services, including Active Directory. ADSI is supplied as a software development kit (SDK).

See also: Active Directory; Component Object Model (COM); directory service

Active Directory Users and Computers

An administrative tool used by an administrator to perform day-to-day Active Directory administration tasks. The tasks that can be performed with this tool include creating, deleting, modifying, moving, and setting permissions on objects stored in the directory. Examples of objects in Active Directory are organizational units, users, contacts, groups, computers, printers, and shared file objects.

See also: Active Directory; object; permission

Active Directory-integrated zone

A primary Domain Name System (DNS) zone that is stored in Active Directory so that it can use multimaster replication and Active Directory security features.

See also: Active Directory; Domain Name System (DNS); multimaster replication; primary zone

active partition

A partition from which an x86-based computer starts up. The active partition must be a primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the system volume.

See also: basic disk; primary partition; system partition; system volume; x86

active volume

The volume from which the computer starts up. The active volume must be a simple volume on a dynamic disk. You cannot mark an existing dynamic volume as the active volume, but you can upgrade a basic disk containing the active partition to a dynamic disk. After the disk is upgraded to dynamic, the partition becomes a simple volume that is active.

See also: active partition; basic disk; dynamic disk; dynamic volume; simple volume

ActiveX

A set of technologies that allows software components to interact with one another in a networked environment, regardless of the language in which the components were created.

See also: ActiveX component

ActiveX component

A reusable software component that can be used to incorporate ActiveX technology.

See also: ActiveX

address

A unique identifier that identifies a network node to other nodes on the network. Also known as the net address or MAC address.

See also: media access control (MAC) address; node

address (A) resource record

A resource record (RR) used to map a DNS domain name to a host Internet Protocol version 4 (IPv4) address on the network.

See also: domain name; Domain Name System (DNS); IP address; resource record (RR)

address class

A predefined grouping of Internet addresses that defines a network of a certain size. The range of numbers that can be assigned for the first octet in the IP address is based on the address class. Class-based IP addressing has been superceded by Classless Interdomain Routing (CIDR).

See also: Class A IP address; Class B IP address; Class C IP address; Classless Interdomain Routing (CIDR)

address pool

The addresses within a DHCP scope range of addresses that are available for leased distribution to clients.

See also: address; Dynamic Host Configuration Protocol (DHCP); lease; scope

Address Resolution Protocol (ARP)

In TCP/IP, a protocol that uses broadcast traffic on the local network to resolve a logically assigned Internet Protocol version 4 (IPv4) address to its physical hardware or media access control (MAC) layer address.

In asynchronous transfer mode (ATM), ARP is used two different ways. For classical IPv4 over ATM (CLIP), ARP is used to resolve addresses to ATM hardware addresses. For ATM LAN emulation (LANE), ARP is used to resolve Ethernet/802.3 or Token Ring addresses to ATM hardware addresses.

See also: asynchronous transfer mode (ATM); classical IP over ATM (CLIP); Internet Protocol (IP); IP address; LAN emulation (LANE); media access control (MAC) address; Message Authentication Code (MAC); packet; Transmission Control Protocol/Internet Protocol (TCP/IP)

Address Windowing Extensions (AWE) API

A set of application programming interfaces (APIs) developed by Microsoft that allows software developers to create applications that use up to 64 GB of physical nonpaged memory in a 32-bit virtual address space on 32-bit platforms. This technology allows for windowed views to this physical memory from within the application's virtual address space.

See also: application programming interface (API); virtual address

adjacency

A relationship formed between selected neighboring Open Shortest Path First (OSPF) routers for the purpose of exchanging routing information. When the link state databases of two neighboring routers are synchronized, the routers are said to be adjacent. Not every pair of neighboring routers becomes adjacent.

See also: link state database; Open Shortest Path First (OSPF); router

administration queue

For Message Queuing, a queue that stores acknowledgment messages.

See also: acknowledgment message; Message Queuing; queue

administrative alerts

Alerts that relate to server and resource use. They notify users about problems in areas such as security and access, user sessions, server shutdown due to power loss (when an uninterruptible power supply (UPS) is available), directory replication, and printing. When a computer generates an administrative alert, a message is sent to a predefined list of users and computers.

See also: Alerter service; uninterruptible power supply (UPS)

administrative credentials

Logon information that is used to identify a member of an administrative group. Groups that use administrative credentials include Administrators, Domain Admins, and DNS Admins. Most system-wide or domain-wide tasks require administrative credentials.

See also: Administrators group; group

administrator

In the Windows Server 2003 family, a person who is responsible for setting up and managing local computers, stand-alone servers, member servers, or domain controllers. An administrator sets up user and group accounts, assigns passwords and permissions, and helps users with networking problems. Administrators can be members of the Administrators group on local computers or servers. A person who is a member of the Administrators group on a local computer or server has full access to that computer or server and can assign access control rights to users as necessary.

Administrators can also be members of the Domain Admins group on domain controllers and have full control over user and computer accounts residing in that domain.

See also: access control; computer account; domain; domain controller; group account; member server; network administrator; stand-alone server; user account

administrator account

On a local computer, the first account that is created when you install an operating system on a new workstation, stand-alone server, or member server. By default, this account has the highest level of administrative access to the local computer, and it is a member of the Administrators group.

In an Active Directory domain, the first account that is created when you set up a new domain by using the Active Directory Installation Wizard. By default, this account has the highest level of administrative access in a domain, and it is a member of the Administrators, Domain Admins, Domain Users, Enterprise Admins, Group Policy Creator Owners, and Schema Admins groups.

See also: Active Directory; Administrators group; local computer; member server; stand-alone server; user account

Administrators group

On a local computer, a group whose members have the highest level of administrative access to the local computer. Examples of administrative tasks that can be performed by members of this group include installing programs; accessing all files on the computer; auditing access control; and creating, modifying, and deleting local user accounts.

In an Active Directory domain, a group whose members have the highest level of administrative access in the domain. Examples of administrative tasks that can be performed by members of this group include setting domain policy; assigning and resetting domain user account passwords; setting up and managing domain controllers; and creating, modifying, and deleting domain user accounts.

See also: access control; Active Directory; auditing; domain; domain controller; group; local computer; object; user account

ADSI

See definition for: Active Directory Service Interfaces (ADSI)

Advanced Configuration and Power Interface (ACPI)

An open industry specification that defines power management on a wide range of mobile, desktop, and server computers and peripherals. ACPI is the foundation for the OnNow industry initiative that allows system manufacturers to deliver computers that start at the touch of a keyboard. ACPI design is essential to take full advantage of power management and Plug and Play.

See also: Plug and Play

affinity

For Network Load Balancing, the method used to associate client requests to cluster hosts. When no affinity is specified, all network requests are load balanced across the cluster without respect to their source. Affinity is implemented by directing all client requests from the same IP address to the same cluster host.

See also: client request; IP address; Network Load Balancing

agent

An application that runs on a Simple Network Management Protocol (SNMP) managed device. The agent application is the object of management activities. A computer running SNMP agent software is also sometimes referred to as an agent.

See also: Simple Network Management Protocol (SNMP)

Alerter service

A service used by the server and other services to notify selected users and computers of administrative alerts that occur on a computer. The Alerter service requires the Messenger service.

See also: administrative alerts; Messenger service; service

algorithm

In cryptography, a mathematical process that is used in cryptographic operations such as the encryption and digital signing of data. An algorithm is commonly used with a cryptographic key to enhance security.

See also: encryption; public key encryption; symmetric encryption

allocation unit

The smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on allocation units. The smaller the allocation unit size, the more efficiently a disk stores information. If you do not specify an allocation unit size when formatting the disk, Windows picks default sizes based on the size of the volume. These default sizes are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. Also called a cluster.

See also: file system; volume

American Standard Code for Information Interchange (ASCII)

A standard single-byte character encoding scheme used for text-based data. ASCII uses designated 7-bit or 8-bit number combinations to represent either 128 or 256 possible characters. Standard ASCII uses 7 bits to represent all uppercase and lowercase letters, the numbers 0 through 9, punctuation marks, and special control characters used in U.S. English. Most current x86-based systems support the use of extended (or "high") ASCII. Extended ASCII allows the eighth bit of each character to identify an additional 128 special symbol characters, foreign-language letters, and graphic symbols.

See also: Unicode

Anonymous access

An authentication mechanism by which users who are able to connect to an Internet site without credentials are assigned to the IUSR_ComputerName account and granted the access rights that are assigned to that account.

See also: access control; Anonymous authentication; authentication

Anonymous authentication

An authentication mechanism that does not require user accounts and passwords. Anonymous authentication grants remote users the identity IUSR_ComputerName. Anonymous authentication is used on the Internet to grant visitors restricted access to predefined public resources.

See also: Anonymous access; authentication; password; user account

answer file

A text file used to automate Setup or other installation processes. Using this text file, you can provide custom answers to Setup-related questions. Typically, you must point the Setup program to use the answer file at the same time Setup is started. Answer files can only be used on applications and operating systems that support them.

See also: Setup

API

See definition for: application programming interface (API)

APIPA

See definition for: Automatic Private IP Addressing (APIPA)

AppleShare

Client software that is shipped with all Macintosh computers and with Apple Computer server software. Macintosh computers can use their AppleShare client software to connect to computers running Services for Macintosh.

See also: client; server

AppleTalk Control Protocol (ATCP)

A network control protocol defined within Point-to-Point Protocol (PPP). ATCP allows clients to connect to a Windows server by running PPP over AppleTalk. ATCP negotiates the AppleTalk parameters to use during the PPP session.

See also: Network Control Protocol; Point-to-Point Protocol (PPP)

AppleTalk Filing Protocol

The presentation-layer protocol that manages access to remote files in an AppleTalk network.

See also: protocol

AppleTalk Phase 2

The extended AppleTalk Internet model designed by Apple Computer that supports multiple zones within a network and extended addressing capacity.

See also: zone

AppleTalk Protocol

The set of network protocols on which AppleTalk network architecture is based. The AppleTalk Protocol is installed with Services for Macintosh to help users access resources on a network.

See also: protocol; resource

AppleTalk Transport

The layer of AppleTalk Phase 2 protocols that delivers data to its destination on the network.

See also: AppleTalk Phase 2

application assignment

A process that uses Software Installation (an extension of Group Policy) to assign programs to groups of users. The programs appear on the users' desktop when they log on.

See also: Group Policy

application directory partition

An Active Directory directory partition that stores application-specific data that can be dynamic (subject to Time to Live restrictions). Application directory partitions can store any type of object except security principals and are not replicated to the global catalog. The replication scope of an application directory partition can be configured to include any set of domain controllers in the forest.

See also: Active Directory; directory partition; Time to Live (TTL)

application memory tuning

A feature of Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition. Application memory tuning can be enabled on computers with between 2 gigabytes (GB) and 4 GB of physical RAM, and it allows applications running on these computers to address 3 GB of virtual memory instead of the 2 GB normally allocated to each application process. Also known as 4-gigabyte tuning (4GT).

See also: virtual memory

application programming interface (API)

A set of routines that an application uses to request and carry out lower-level services performed by a computer's operating system. These routines usually carry out maintenance tasks such as managing files and displaying information.

area border router (ABR)

A router that is attached to multiple areas. ABRs maintain separate topological databases for each area.

See also: topological database

ARP

See definition for: Address Resolution Protocol (ARP)

AS

See definition for: autonomous system (AS)

ASBR

See definition for: autonomous system boundary router (ASBR)

ASCII (American Standard Code for Information Interchange)

See definition for: American Standard Code for Information Interchange (ASCII)

ASR

See definition for: Automated System Recovery (ASR)

asynchronous communication

A form of data transmission in which information is sent and received at irregular intervals, one character at a time. Because data is received at irregular intervals, the receiving modem must be signaled to let it know when the data bits of a character begin and end. This is done by means of start and stop bits.

See also: modem (modulator/demodulator)

asynchronous transfer mode (ATM)

A high-speed, connection-oriented protocol used to transport many different types of network traffic. ATM packages data in a 53-byte, fixed-length cell that can be switched quickly between logical connections on a network.

See also: protocol

ATCP

See definition for: AppleTalk Control Protocol (ATCP)

ATM

See definition for: asynchronous transfer mode (ATM)

ATM adaptation layer (AAL)

The layer of the asynchronous transfer mode (ATM) protocol stack that parses data into the payload portion of the ATM cell for transport across an ATM network.

See also: asynchronous transfer mode (ATM)

attribute

For files, information that indicates whether a file is read-only, hidden, ready for archiving (backing up), compressed, or encrypted, and whether the file contents should be indexed for fast file searching.

In Active Directory, a property of an object. For each object class, the schema defines which attributes an instance of the class must have and which additional attributes it might have.

See also: Active Directory; class; object; object class; schema

audit entry

Data that is recorded in the event log when specified system, application, and security-related events take place. Audit entries provide valuable data about system operations that can be used to identify system use and to diagnose system behavior.

See also: auditing; event

audit logging

Enhanced logging capabilities that monitor and manage the growth and size of log files used by DHCP on an ongoing daily basis.

See also: Dynamic Host Configuration Protocol (DHCP)

audit policy

Policy that determines the security events to be reported to the network administrator.

See also: policy; security

auditing

The process that tracks the activities of users by recording selected types of events in the security log of a server or a workstation.

See also: security log

authentication

The process for verifying that an entity or object is who or what it claims to be. Examples include confirming the source and integrity of information, such as verifying a digital signature or verifying the identity of a user or computer.

See also: cryptography; Kerberos V5 authentication protocol; nonrepudiation; NTLM authentication protocol; smart card; trust relationship

Authentication Header (AH)

A header that provides authentication, integrity, and anti-replay for the entire packet (the Internet Protocol (IP) header and the data payload carried in the packet).

See also: authentication; Internet Protocol (IP); packet

authentication protocol

The protocol by which an entity on a network proves its identity to a remote entity. Typically, identity is proved with the use of a secret key, such as a password, or with a stronger key, such as the key on a smart card. Some authentication protocols also implement mechanisms to share keys between client and server to provide message integrity or privacy.

See also: authentication; identity; Kerberos V5 authentication protocol; key; NTLM authentication protocol; protocol; smart card

authoritative

Describes a DNS server that hosts a primary or secondary copy of a DNS zone.

See also: authoritative restore; DNS server; Domain Name System (DNS); resource record (RR); zone

authoritative restore

In Backup, a type of restore operation performed on an Active Directory domain controller in which the objects in the restored directory are treated as authoritative, replacing (through replication) all existing copies of those objects.

See also: Active Directory; domain controller; nonauthoritative restore; object; replication

authorization

The process that determines what a user is permitted to do on a computer system or network.

See also: authentication

authorization store

A database that stores Authorization Manager policy.

auto-static updates

The process of adding static routes to the routing table automatically. When you configure an interface to use auto-static update mode, the router sends a request to other routers and inherits routes. The routes are saved in the routing table as auto-static routes and are kept even if the router is restarted or the interface goes down. Auto-static updates are supported in Routing Information Protocol (RIP) for Internet Protocol (IP) and in RIP for Internetwork Packet Exchange (IPX), but they are not available for use with Open Shortest Path First (OSPF).

See also: Open Shortest Path First (OSPF); routing; Routing Information Protocol over IPX (RIPX); static routes

automated library

A tape or disk library with an automatic mechanism, such as a robotic arm, that loads and unloads media into a drive or drives without manual intervention from the user. Automated libraries are sometimes known as autoloaders, changers, jukeboxes, media changers, and robotic libraries.

Automated System Recovery (ASR)

A feature that helps you recover a system that will not start. To use Automated System Recovery, you must first use the Automated System Recovery Preparation Wizard (part of Backup). This wizard backs up the partition used by the operating system, but it does not back up other partitions, such as program or data partitions. Those partitions must be backed up using Backup or other standard routines.

See also: partition

automatic file replication

The replication of files and directories between computers as performed automatically by the File Replication service (FRS). In a domain distributed file system, FRS provides automatic file and directory replication between targets. The user configures automatic replication through the DFS administration tool. Files in a stand-alone distributed file system must be replicated between targets manually or by using other utilities.

See also: Distributed File System (DFS); domain DFS; File Replication service (FRS); replication

Automatic Private IP Addressing (APIPA)

A TCP/IP feature in Windows XP and products in the Windows Server 2003 family that automatically configures a unique IP address from the range 169.254.0.1 through 169.254.255.254 and a subnet mask of 255.255.0.0 when the TCP/IP protocol is configured for dynamic addressing and a DHCP server is not available. The APIPA range of IP addresses is reserved by the Internet Assigned Numbers Authority (IANA), and IP addresses within this range are not used on the Internet.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); IP address; Transmission Control Protocol/Internet Protocol (TCP/IP)

autonomous system (AS)

A group of routers exchanging routing information by using a common routing protocol.

See also: autonomous system boundary router (ASBR); router

autonomous system boundary router (ASBR)

A router that exchanges routing information with routers that belong to other autonomous systems. The ASBR then advertises external routes throughout the autonomous system. ASBRs can be internal or area border routers, and they might or might not be connected to the backbone.

See also: area border router (ABR); autonomous system (AS); backbone; router

availability

A level of service provided by applications, services, or systems. Highly available systems have minimal downtime, whether planned or unplanned. Availability is often expressed as the percentage of time that a service or system is available, for example, 99.9 percent for a service that is down for 8.75 hours a year.

available bit rate (ABR)

An asynchronous transfer mode (ATM) service type that supports available-bit-rate traffic, minimum guaranteed transmission rate, and peak data rates. ABR also allows bandwidth allocation depending on availability, and it uses flow control to communicate bandwidth availability to the end node.

See also: asynchronous transfer mode (ATM); bandwidth; node

AXFR

See definition for: full zone transfer (AXFR)

B

B-channel

A single channel of an Integrated Services Digital Network (ISDN) line that is used to carry either voice or data information. ISDN Basic Rate Interface (BRI) has 2 B-channels. ISDN Primary Rate Interface (PRI) in North America has 23 B-channels. ISDN Primary Rate Interface (PRI) in Europe has 23 B-channels. Also called bearer channel.

See also: Integrated Services Digital Network (ISDN)

B-ISDN

See definition for: broadband integrated services digital network (B-ISDN)

backbone

In Open Shortest Path First (OSPF), an area common to all other OSPF areas that is used as the transit area for inter-area traffic and for distributing routing information between areas. The backbone must be contiguous.

See also: Open Shortest Path First (OSPF)

backbone router

In Open Shortest Path First (OSPF), a router that is connected to the backbone area. This includes routers that are connected to more than one area (area border routers (ABRs)). However, backbone routers do not have to be ABRs. Routers that have all networks connected to the backbone are internal routers.

See also: area border router (ABR); backbone; Open Shortest Path First (OSPF); router

background program

A program that runs while the user is working on another task. The computer's microprocessor assigns fewer resources to background programs than foreground programs.

See also: foreground program

backup

A duplicate copy of a program, a disk, or data, made either for archiving purposes or for safeguarding valuable files from loss in case the active copy is damaged or destroyed. Some application programs automatically make backup copies of data files, maintaining both the current version and the preceding version.

backup domain controller (BDC)

A domain controller running Windows NT Server 4.0 or earlier that receives a read-only copy of the directory database for the domain. The directory database contains all account and security policy information for the domain.

See also: Active Directory; mixed mode; primary domain controller (PDC)

backup media pool

A logical collection of data-storage media that has been reserved for use by Microsoft Windows Backup. Backup uses Removable Storage to control access to specific media within a library.

See also: library; media pool; Removable Storage

Backup Operators group

A type of local or global group that contains the user rights you need to back up and restore files and folders. Members of the Backup Operators group can back up and restore files and folders regardless of ownership, permissions, encryption, or auditing settings.

See also: auditing; global group; local group; user rights

backup set

A collection of files, folders, and other data that has been backed up and stored in a file or on one or more tapes.

See also: backup set catalog; on-disk catalog; on-media catalog

backup set catalog

A summary of the files and folders that have been saved in a backup set.

See also: backup set

backup types

A type that determines which data is backed up and how it is backed up. There are five backup types: copy, daily, differential, incremental, and normal.

See also: copy backup; daily backup; differential backup; incremental backup; normal backup

bandwidth

The data transfer capacity of a transmission medium.

In digital communications, the transfer capacity expressed in bits per second (bps) or megabits per second (Mbps). For example, Ethernet accommodates a bandwidth of 10,000,000 bps or 10 Mbps.

In analog communications, the difference between the highest and lowest frequencies in a specific range. For example, an analog telephone line accommodates a bandwidth of 3,000 hertz (Hz), the difference between the lowest (300 Hz) and highest (3,300 Hz) frequencies that it can carry.

See also: bits per second (bps)

Bandwidth Allocation Protocol (BAP)

A Point-to-Point Protocol (PPP) control protocol that is used on a multiprocessing connection to dynamically add and remove links.

See also: Point-to-Point Protocol (PPP)

BAP

See definition for: Bandwidth Allocation Protocol (BAP)

base priority

A precedence ranking that determines the order in which the threads of a process are scheduled for the processor. Use Task Manager to view and change base priorities.

For Message Queuing, a property that specifies the queue's priority in a public queue. You can set the base priority from -32,768 to 32,767; the default priority is 0. Private queues do not support base priority. Message Queuing routes and delivers messages first by base priority, then by message priority.

See also: Message Queuing; private queue; public queue

Basic authentication

An authentication mechanism that is supported by most browsers, including Internet Explorer. Basic authentication encodes user name and password data before transmitting it over the network. Note that encoding is not the same as encryption. Also known as plaintext authentication.

See also: Anonymous authentication; authentication; Digest authentication; encryption; password; user name

basic disk

A physical disk that can be accessed by MS-DOS and all Windows-based operating systems. Basic disks can contain up to four primary partitions, or three primary partitions and an extended partition with multiple logical drives. If you want to create partitions that span multiple disks, you must first convert the basic disk to a dynamic disk by using Disk Management or the Diskpart.exe command-line tool.

See also: dynamic disk; extended partition; logical drive; MS-DOS (Microsoft Disk Operating System); primary partition

basic input/output system (BIOS)

On x86-based computers, the set of essential software routines that test hardware at startup, start the operating system, and support the transfer of data among hardware devices. The BIOS is stored in read-only memory (ROM) so that it can be executed when you turn on the computer. Although critical to performance, the BIOS is usually invisible to computer users.

See also: Extensible Firmware Interface (EFI); read-only memory (ROM); x86

basic storage

A storage method in MS-DOS and Windows for primary partitions, extended partitions, and logical drives.

See also: dynamic storage; extended partition; logical drive

basic volume

A primary partition or logical drive that resides on a basic disk.

See also: basic disk; logical drive; primary partition

batch program

An ASCII (unformatted text) file that contains one or more operating system commands. A batch program's file name has a .cmd or .bat extension. When you type the file name at the command prompt, or when the batch program is run from another program, its commands are processed sequentially. Also called batch files.

See also: American Standard Code for Information Interchange (ASCII); logon script

baud rate

The speed at which a modem communicates. Baud rate refers to the number of times the condition of the line changes. This is equal to bits per second only if each signal corresponds to one bit of transmitted data.

Modems must operate at the same baud rate in order to communicate with each other. If the baud rate of one modem is set higher than that of the other, the faster modem usually alters its baud rate to match that of the slower modem.

See also: bits per second (bps); modem (modulator/demodulator)

BDC

See definition for: backup domain controller (BDC)

Berkeley Internet Name Domain (BIND)

An implementation of Domain Name System (DNS) written and ported to most available versions of the UNIX operating system. The Internet Software Consortium maintains the BIND software.

See also: BIND boot file; Domain Name System (DNS)

BGP

See definition for: Border Gateway Protocol (BGP)

binary

A base-2 number system in which values are expressed as combinations of two digits, 0 and 1.

BIND

See definition for: Berkeley Internet Name Domain (BIND)

BIND boot file

A configuration file used by DNS servers running under versions of the Berkeley Internet Name Domain (BIND) software implementation. The BIND boot file is a text file, Named.boot, where individual lines in the file list boot directives used to start a service when the DNS server is started. By default, Microsoft DNS servers use DNS service parameters stored in the registry, but they allow the use of a BIND boot file as an alternative for reading boot configuration settings.

See also: Berkeley Internet Name Domain (BIND); DNS server; registry boot

bindery

A database in Novell NetWare 3.x that contains organizational and security information about users and groups.

binding

A process by which software components and layers are linked together. When a network component is installed, the binding relationships and dependencies for the components are established. Binding allows components to communicate with each other.

BIOS

See definition for: basic input/output system (BIOS)

bit (binary digit)

The smallest unit of information handled by a computer. One bit expresses a 1 or a 0 in a binary numeral, or a true or false logical condition. A group of 8 bits makes up a byte, which can represent many types of information, such as a letter of the alphabet, a decimal digit, or other character. Also known as a binary digit.

See also: binary

bits per second (bps)

The number of bits transmitted every second, used as a measure of the speed at which a device, such as a modem, can transfer data.

See also: modem (modulator/demodulator)

blank password

A password that does not contain any characters. Also called a null password.

See also: password policy; strong password; weak password

block inheritance

In Group Policy, the method of preventing a child container from inheriting the policy settings from all parent containers. Block inheritance does not apply to Group Policy object (GPO) links that are enforced.

See also: Enforce; Group Policy Management console (GPMC); Group Policy object link; inheritance; precedence

boot

The process of starting or resetting a computer. When first turned on (cold boot) or reset (warm boot), the computer runs the software that loads and starts the computer's operating system, which prepares it for use.

boot files

The system files needed to start Windows. The boot files include Ntldr and Ntdetect.com.

See also: partition boot sector

Boot Information Negotiation Layer service (BINLSVC)

A service that runs on a Remote Installation Services (RIS) server that acts on client boot requests. The display name of BINLSVC is Remote Installation.

See also: Remote Installation Services (RIS)

Boot Logging

A process in which a computer that is starting (booting) creates a log file that records the loading of each device and service. The log file is called Ntbtlog.txt, and it is saved in the systemroot directory.

See also: systemroot

boot partition

The partition that contains the Windows operating system and its support files. The boot partition can be, but does not have to be, the same as the system partition.

See also: partition; Primary disk; system partition

boot volume

The volume that contains the Windows operating system and its support files. The boot volume can be, but does not have to be, the same as the system volume.

See also: system volume; volume

bootable CD

A CD-ROM that can be used to start a computer. An automated installation uses a bootable CD to start a computer.

BOOTP

See definition for: bootstrap protocol (BOOTP)

BOOTP extensions

A set of optional information types defined originally in RFC 1497 for use with BOOTP service and later supported by DHCP. In DHCP, these extensions form the legacy core set of client parameters available and supported by most standard DHCP and BOOTP servers.

See also: bootstrap protocol (BOOTP); Dynamic Host Configuration Protocol (DHCP); Request for Comments (RFC)

bootstrap protocol (BOOTP)

A protocol used primarily on TCP/IP networks to configure diskless workstations. RFCs 951 and 1542 define this protocol. DHCP is a later boot configuration protocol that uses this protocol. The Microsoft DHCP service provides limited support for BOOTP service.

See also: Dynamic Host Configuration Protocol (DHCP); Request for Comments (RFC); Transmission Control Protocol/Internet Protocol (TCP/IP)

Border Gateway Protocol (BGP)

A routing protocol designed for use between autonomous systems. BGP is especially useful for detecting routing loops.

See also: autonomous system (AS); routing; routing protocol

bps

See definition for: bits per second (bps)

bridgehead server

In Active Directory replication, a single server in a site that is designated to perform site-to-site replication for a specific domain and transport.

In a messaging system, a server that receives and forwards e-mail traffic at each end of a connection agreement, similar to the task a gateway performs.

See also: Active Directory; Active Directory replication; gateway; replication; site

broadband integrated services digital network (B-ISDN)

An International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T) communication standard for high-speed networking that provides new services, including voice, video, and data on the same network.

See also: International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T)

broadcast

The transmission of packets by an Internet Protocol version 4 (IPv4) host to all computers on the subnet.

See also: broadcast address; Internet Protocol (IP); packet; subnet

broadcast address

An Internet Protocol version 4 (IPv4) address that is destined for all hosts on a particular network segment.

See also: broadcast; host; Internet Protocol (IP); IP address

broadcast and unknown server (BUS)

A multicast service on an emulated local area network (ELAN) that forwards broadcast, multicast, and initial unicast data traffic sent by a LAN emulation client (LEC).

See also: emulated local area network (ELAN); LAN emulation client (LEC); service

broadcast message

A network message sent from a single computer that is distributed to all other devices on the same segment of the network as the sending computer.

broadcast network

A network that supports more than two attached routers and has the ability to address a single physical message to all of the attached routers (broadcast). Ethernet is an example of a broadcast network.

See also: router

browsing

The process of creating and maintaining an up-to-date list of computers and resources on a network or part of a network by one or more designated computers running the Computer Browser service.

See also: Computer Browser service

bucket brigade attack

See definition for: man-in-the-middle attack

buffer

A region of random access memory (RAM) reserved for use with data that is temporarily held while waiting to be transferred between two locations, such as between an application's data area and an input/output device.

See also: random access memory (RAM)

built-in groups

The default security groups installed with the operating system. Built-in groups have been granted useful collections of rights and built-in abilities.

In most cases, built-in groups provide all the capabilities needed by a particular user. For example, members of the built-in Backup Operators group can back up and restore files and folders. To provide a needed set of capabilities to a user account, assign it to the appropriate built-in group.

See also: group

bus

A communication line used for data transfer among the components of a computer system. A bus essentially allows different parts of the system to share data. For example, a bus connects the disk-drive controller, memory, and input/output ports to the microprocessor.

See also: expansion slot; universal serial bus (USB)

C

CA

See definition for: certification authority (CA)

cache

A special memory subsystem in which frequently used data values are duplicated for quick access.

See also: cache file; file system cache

cache file

A file used by DNS servers and clients to store responses to DNS queries. For Windows DNS servers, the cache file is named Cache.dns by default.

See also: authoritative; cache; DNS client; DNS server; Domain Name System (DNS)

caching

The process of temporarily storing recently accessed information in a special memory subsystem for quicker access.

See also: cache; caching resolver

caching resolver

A program that extracts information from DNS servers in response to client requests.

See also: cache; cache file; caching; DNS server

caching-only server

A DNS sever that does not host any DNS zones but that performs name resolution and stores the results in its cache.

See also: caching; DNS server; DNS zone; name resolution

Callback Control Protocol (CBCP)

The Network Control Protocol that negotiates the use of callback over PPP links.

See also: Point-to-Point Protocol (PPP)

callback number

The number that a remote access server uses to call back a user. This number can be preset by the administrator or specified by the user at the time of each call, depending on how the administrator configures the user's callback options. The callback number should be the number of the phone line to which the user's modem is connected.

See also: preset-to callback; remote access server; set-by-caller callback

callback security

A form of network security in which a remote access server calls a user back at a preset number after the user has made an initial connection and has been authenticated.

See also: preset-to callback; remote access server

called subscriber ID (CSID) string

A string that specifies the called subscriber ID transmitted by the receiving fax machine when receiving an inbound fax. This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the transmitter subscriber ID.

See also: string; transmitting station ID (TSID) string

canonical (CNAME) resource record

A resource record used to map an alternate alias name to a primary canonical DNS domain name used in the zone.

See also: resource record (RR)

canonical name

An object's distinguished name presented with the root first and without the Lightweight Directory Access Protocol (LDAP) attribute tags (such as: CN=, DC=). The segments of the name are delimited with forward slashes (/). For example,

CN=MyDocuments,OU=MyOU,DC=Microsoft,DC=Com

is presented as

microsoft.com/MyOU/MyDocuments

in canonical form.

See also: distinguished name; Lightweight Directory Access Protocol (LDAP)

capture

To assign a port to a printer. Documents that you print are sent to the printer through the captured port.

For Network Monitor, the process by which frames are copied.

See also: frame

capture password

A password that allows the user to capture statistics from the network and to display captured data.

See also: display password; password

capture trigger

A set of conditions that, when met, stop the capture or execute a program or command file to perform another type of action related to the capture.

CardBus

A 32-bit PC Card.

cartridge font

A font contained in a plug-in cartridge and used to add fonts to laser, ink-jet, or high-end dot-matrix printers. Cartridge fonts are distinguished both from internal fonts, which are contained in read-only memory (ROM) in the printer and are always available, and from downloadable (soft) fonts, which reside on disk and which can be sent to the printer as needed.

See also: downloadable fonts; font; font cartridge; read-only memory (ROM)

cascading hubs

A network configuration in which hubs are connected to other hubs.

See also: hub

catalog

For Indexing Service, a collection of all index information and stored properties for a particular group of file system directories. By default, Indexing Service indexes the System and Web catalogs on your hard drive.

See also: Indexing Service; property

CBCP

See definition for: Callback Control Protocol (CBCP)

CBR

See definition for: constant bit rate (CBR)

CCP

See definition for: Compression Control Protocol (CCP)

CDFS

See definition for: Compact Disc File System (CDFS)

certificate

A digital document that is commonly used for authentication and to secure information on open networks. A certificate securely binds a public key to the entity that holds the corresponding private key. Certificates are digitally signed by the issuing certification authority (CA), and they can be issued for a user, a computer, or a service.

See also: certification authority (CA); private key; public key

certificate revocation list (CRL)

A document maintained and published by a certification authority that lists certificates that have been revoked.

See also: certificate; certification authority (CA)

Certificate Services

A software service that issues certificates for a particular certification authority (CA). It provides customizable services for issuing and managing certificates for the enterprise. Certificates can be used to provide authentication support, including secure e-mail, Web-based authentication, and smart-card authentication.

See also: authentication; certificate; certification authority (CA); Internet Authentication Service (IAS); service

certificate store

A permanent storage where certificates, certificate revocation lists, and certificate trust lists are stored.

See also: certificate; certificate revocation list (CRL); certificate trust list (CTL)

certificate template

A Windows construct that specifies the format and content of certificates based on their intended usage. When requesting a certificate from a Windows enterprise certification authority (CA), certificate requestors can select from a variety of certificate types that are based on certificate templates.

See also: certificate; certification authority (CA)

certificate trust list (CTL)

A signed list of root certification authority certificates that an administrator considers reputable for designated purposes, such as client authentication or secure e-mail.

See also: certificate; certification authority (CA); root certificate

certification authority (CA)

An entity responsible for establishing and vouching for the authenticity of public keys belonging to subjects (usually users or computers) or other certification authorities. Activities of a certification authority can include binding public keys to distinguished names through signed certificates, managing certificate serial numbers, and certificate revocation.

See also: certificate; public key; root certification authority

certification hierarchy

A model of trust for certificates in which certification paths are created by means of the establishment of parent-child relationships between certification authorities.

See also: certification authority (CA); certification path

certification path

An unbroken chain of trust, consisting of certificates from trusted certification authorities, from a specific certificate to the root certification authority in a certification hierarchy.

See also: certificate; certification authority (CA); certification hierarchy; public key

Challenge Handshake Authentication Protocol (CHAP)

A challenge-response authentication protocol for Point-to-Point Protocol (PPP) connections described in RFC 1994. It uses the industry-standard MD5 hashing algorithm to hash the combination of a challenge string issued by the authenticating server and the user's password in the response.

See also: MD5; message digest; Point-to-Point Protocol (PPP)

change journal

A feature that tracks changes to NTFS volumes, including additions, deletions, and modifications. The change journal exists on the volume as a sparse file.

See also: NTFS file system; sparse file; volume

channel

A path or link through which noncontrol information passes between two devices. A single Basic Rate Interface (BRI) connection, for example, has one physical connection but two channels for exchanging information between devices. This is often called a bearer channel, implying a channel that carries information.

On the Internet, a Web site designed to deliver content from the Internet to your computer, similar to subscribing to a favorite Web site.

See also: active content; B-channel; D-channel

character mode

A display mode in which the monitor can display letters, numbers, and other text characters, but no graphical images or character formatting (italics, superscript, and so on).

See also: graphics mode

child domain

For DNS and Active Directory, a domain located in the namespace tree directly beneath another domain (the parent domain). For example, example.microsoft.com would be a child domain of the parent domain microsoft.com. Also known as a subdomain.

See also: Active Directory; domain; Domain Name System (DNS); parent domain

child object

An object that resides in another object. A child object implies relation. For example, a file is a child object that resides in a folder, which is the parent object.

See also: object; parent object

Chooser

The Macintosh desk accessory with which users select the network server and printers they want to use.

Chooser Pack

A collection of files, some of which contain PostScript information. When a Macintosh computer sends a print job to a PostScript printer, the printer uses a Chooser Pack to interpret PostScript commands in the print job.

See also: PostScript; PostScript printer

cipher

The method of forming a hidden message. The cipher is used to transform a readable message called plaintext (also sometimes called cleartext) into an unreadable, scrambled, or hidden message called ciphertext. Only someone with a secret decoding key can convert the ciphertext back into its original plaintext.

See also: plaintext

circuit switching

A technology in which a connection is established by closing a switch, for example, by dialing a telephone. This creates a circuit in which all the information transmitted over the connection follows the same route to the destination. The circuit is dedicated to the connection until it is closed.

class

A category of objects that share a common set of characteristics. Each object in the directory is an instance of one or more classes in the schema.

See also: object; schema

Class A IP address

A unicast IP address that ranges from 1.0.0.1 through 127.255.255.254. The first octet indicates the network, and the last three octets indicate the host on the network. Class-based IP addressing has been superceded by Classless Interdomain Routing (CIDR).

See also: Class B IP address; Class C IP address; Classless Interdomain Routing (CIDR); IP address

Class B IP address

A unicast IP address that ranges from 128.0.0.1 through 191.255.255.254. The first two octets indicate the network, and the last two octets indicate the host on the network. Class-based IP addressing has been superceded by Classless Interdomain Routing (CIDR).

See also: Class A IP address; Class C IP address; Classless Interdomain Routing (CIDR); IP address

Class C affinity

Specifies that Network Load Balancing direct multiple requests from the same TCP/IP Class C address range to the same cluster host.

See also: affinity; Network Load Balancing; single affinity

Class C IP address

A unicast IP address that ranges from 192.0.0.1 to 223.255.255.254. The first three octets indicate the network, and the last octet indicates the host on the network. Network Load Balancing provides optional session support for Class C IP addresses (in addition to support for single IP addresses) to accommodate clients that make use of multiple proxy servers at the client site. Class-based IP addressing has been superceded by Classless Interdomain Routing (CIDR).

See also: Class A IP address; Class B IP address; Classless Interdomain Routing (CIDR); IP address; Network Load Balancing; proxy server

classical IP over ATM (CLIP)

A proposed Internet standard, described in RFC 2225, that allows Internet Protocol (IP) communication directly on the asynchronous transfer mode (ATM) layer, bypassing an additional protocol (such as Ethernet or Token Ring) in the protocol stack.

See also: asynchronous transfer mode (ATM); Internet Protocol (IP)

Classless Interdomain Routing (CIDR)

An IP address and routing management method that allocates IP addresses in a way that reduces the number of routes stored on any individual router, while also increasing the number of available IP addresses. CIDR replaces class-based IP address allocation.

See also: IP address; router

clear

To turn off an option by removing the X or check mark from a check box. You clear a check box by clicking it, or by selecting it and then pressing the SPACEBAR.

cleartext

See definition for: plaintext

cleartext passwords

Passwords that are not scrambled, thus making them more susceptible to network sniffers.

See also: password; plaintext

client

Any computer or program connecting to, or requesting the services of, another computer or program. Client can also refer to the software that enables the computer or program to establish the connection.

For a local area network (LAN) or the Internet, a computer that uses shared network resources provided by another computer (called a server).

See also: server

client access

The ability of client computers to connect to a server or resource, for example, a file on a server or a cluster resource.

See also: client; cluster; resource; server

client application

A Windows-based application that can display and store linked or embedded objects. For distributed applications, the application that imitates a request to a server application.

See also: server application

client authentication

A method of authentication by which the client in a client-server communication proves its identity to the server.

See also: authentication; client; identity; server

client request

A service request from a client computer to a server computer or a cluster of server computers.

See also: client; server

Client Service for NetWare

A service included that allows clients to make direct connections to resources on computers running NetWare 2.x, 3.x, 4.x, or 5.x server software by using the Internetwork Packet Exchange (IPX) protocol only. This service is included with Windows XP Professional and the Windows Server 2003 family.

See also: Internetwork Packet Exchange (IPX); service

CLIP

See definition for: classical IP over ATM (CLIP)

ClipBook Server

A system service that supports ClipBook Viewer, which allows pages to be seen by remote ClipBooks.

cluster

In data storage, the smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. Also called an allocation unit.

In computer networking, a group of independent computers that work together to provide a common set of services and present a single-system image to clients. The use of a cluster enhances the availability of the services and the scalability and manageability of the operating system that provides the services.

See also: availability; client; file system; scalability; volume

cluster adapter

The adapter that, when using multiple network adapters in each host of a Network Load Balancing cluster, handles the network traffic for cluster operations (the traffic for all hosts in the cluster). This adapter is programmed with the host's cluster IP address.

See also: cluster; dedicated adapter; host; IP address; Network Load Balancing

Cluster Administrator

An application that configures a cluster and its nodes, groups, and resources. Cluster Administrator can run on any member of the trusted domain regardless of whether the computer is a cluster node.

See also: cluster; Cluster.exe; node; server cluster

Cluster Administrator extension

A software component that implements the Cluster Administrator extension application programming interface (API) for allowing Cluster Administrator to configure a new resource type.

See also: application programming interface (API); cluster; Cluster Administrator

Cluster API

A collection of functions that are implemented by the cluster software and used by a cluster-aware client or server application, a cluster management application, or a Resource DLL. The Cluster API is used to manage the cluster, cluster objects, and the cluster database.

See also: cluster; Resource DLL; server cluster

cluster full Internet name

A full Internet name for the Network Load Balancing cluster (for example, cluster.microsoft.com). This name is used for the cluster as a whole and should be the same for all hosts in the cluster.

See also: affinity; Network Load Balancing; single affinity

cluster IP address

The Network Load Balancing cluster's IP address in standard Internet dotted notation (for example, w.x.y.z). The address is a virtual IP address used to address the cluster as a whole, and it should be the IP address that maps to the full Internet name that you specify for the cluster. In a Network Load Balancing cluster, this address must be set identically for all hosts in the cluster.

See also: Network Load Balancing; Network Load Balancing cluster

cluster log

An optionally enabled trace record of Cluster service events on a node. Not synonymous with quorum log.

See also: cluster; node; quorum log

cluster network address

The network (media access control) address for the network adapter that is to be used for handling client-to-cluster traffic in a Network Load Balancing cluster.

See also: Network Load Balancing; Network Load Balancing cluster

Cluster service

The essential software component that controls all aspects of server cluster operation and manages the cluster database. Each node in a server cluster runs one instance of the Cluster service.

See also: cluster; node; server cluster

cluster storage

Storage where one or more attached disks hold data used either by server applications running on the cluster or by applications for managing the cluster. Each disk on the cluster storage is owned by only one node of the cluster. The ownership of disks moves from one node to another when the disk group fails over or moves to the other node.

See also: cluster; failover; node

cluster-aware application

An application that can run on a cluster node and that can be managed as a cluster resource. Cluster-aware applications use the Cluster API to receive status and notification information from the server cluster.

See also: cluster; Cluster API; cluster-unaware application; server cluster

cluster-unaware application

An application that can run on a cluster node and be managed as a cluster resource but that does not support the Cluster API.

See also: cluster; Cluster API; cluster-aware application; node

Cluster.exe

An alternative to using Cluster Administrator to administer clusters from the command prompt. You can also call Cluster.exe from command scripts to automate many cluster administration tasks.

See also: cluster; Cluster Administrator

CMYK color space

Multidimensional color space consisting of the cyan, magenta, yellow, and black intensities that make up a given color. Commercial color printing devices generally use this system of four-color process inks.

See also: color management; color space

cn (Common-Name)

The descriptive relative distinguished name for the schema object.

See also: distinguished name; schema

code page

A means of providing support for character sets and keyboard layouts for different countries or regions. A code page is a table that relates the binary character codes used by a program to keys on the keyboard or to characters on the display.

codec

Hardware that can convert audio or video signals between analog and digital forms (coder/decoder), hardware or software that can compress and uncompress audio or video data (compression/decompression), or the combination of coder/decoder and compression/decompression. Generally, a codec compresses uncompressed digital data so that the data uses less memory.

color gamut

The particular range of colors that a device is able to produce. A device such as a scanner, monitor, or printer can produce a unique range of colors, which is determined by the characteristics of the device itself.

See also: color profile; rendering intent

color management

Process of producing accurate, consistent color among a variety of input and output devices. A color management system (CMS) maps colors between devices such as scanners, monitors, and printers; transforms colors from one color space to another (for example, RGB to CMYK); and provides accurate on-screen or print previews.

See also: CMYK color space; RGB color space

color profile

A profile that contains the data needed for translating the values of a color gamut. This data includes information about color, hue, saturation, and brightness.

See also: color gamut; hue; saturation

color space

A set of three values that defines how a color can be represented on computer devices such as monitors, scanners, and printers. For example, in the LAB color space, the terms luminance or whiteness (L), redness-greenness (A), and yellowness-blueness (B) are used; in the HVC system, the terms are hue (H), value (V), and chroma (C). Color space refers to the three-dimensional space that is defined by the respective values, such as L, A, and B.

See also: CMYK color space; color space; RGB color space

COM

See definition for: Component Object Model (COM)

COM Internet Services Proxy

Software that supports distributed applications that use Hypertext Transfer Protocol (HTTP) to communicate through Internet Information Services (IIS).

See also: Hypertext Transfer Protocol (HTTP); Internet Information Services (IIS)

command prompt window

A window displayed on the desktop used to interface with the MS-DOS operating system. MS-DOS commands are typed at an entry point identified by a blinking cursor.

See also: MS-DOS (Microsoft Disk Operating System)

common groups

Groups that appear in the program list on the Start menu for all users who log on to the computer. Only administrators can create or change common groups.

See also: group

communication port

A port on a computer that allows asynchronous communication of one byte at a time. Also called a serial port.

See also: asynchronous communication; serial port

communication settings

Operating parameters, such as bits per second (bps) and modem type, that apply to serial ports on a computer.

See also: bits per second (bps); modem (modulator/demodulator); serial port

community name

A name that identifies groups of Simple Network Management Protocol (SNMP) hosts. This name is placed in SNMP messages that are sent between SNMP-managed devices such as servers running Windows Server 2003 and SNMP management stations. Typically, all hosts belong to Public, which is the standard name for a common community of all SNMP hosts.

See also: host; Simple Network Management Protocol (SNMP); trap

Compact Disc File System (CDFS)

A 32-bit protected-mode file system that controls access to the contents of CD-ROM drives.

Component Object Model (COM)

An object-based programming model designed to promote software interoperability; it allows two or more applications or components to easily cooperate with one another, even if they were written by different vendors, at different times, in different programming languages, or if they are running on different computers running different operating systems. OLE technology and ActiveX are both built on top of COM.

See also: ActiveX; OLE

Compression Control Protocol (CCP)

A protocol used in the negotiation process in a Point-to-Point Protocol (PPP) connection. CCP is one type of Network Control Protocol. Network Control Protocols are used to establish and configure different network protocol parameters for Internet Protocol (IP), Internetwork Packet Exchange (IPX), and NetBIOS Extended User Interface (NetBEUI).

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); NetBIOS Extended User Interface (NetBEUI); Network Control Protocol; Point-to-Point Protocol (PPP)

computer account

An account that is stored in Active Directory and that uniquely identifies a computer in a domain. A computer account uses the same name as the computer joining the domain.

See also: Active Directory; domain

Computer Browser service

A service that maintains an up-to-date list of computers that share resources on your network and that supplies the list to programs that request it. The Computer Browser service is used to view a list of available network resources.

See also: resource; service

Computer Management

A component you can use to view and control many aspects of the computer configuration. Computer Management combines several administration utilities into a single console tree, providing easy access to a local or remote computer's administrative properties and tools.

See also: console tree

computer name

A unique name of up to 15 uppercase characters that identifies a computer to the network. The name cannot be the same as any other computer or domain name in the network.

See also: domain name

computer quota

For Message Queuing, the storage size limit for messages on a computer, based on the total size of the messages. When a computer quota is reached, Message Queuing can no longer send messages to that computer until one or more messages are removed from queues. Message Queuing enforces the computer quota before it enforces the queue quota on a computer.

See also: Message Queuing; queue quota

computer-telephony integration (CTI)

The practice of using a computer to control one or more telephone and communications functions.

conflict detection

For DHCP, an optional server-side mechanism for detecting if a scope IP address is in use on the network. When enabled, the DHCP server will ping an address first before offering that address to clients, and then it will briefly await a response. If the pinged address responds, a conflict is registered and that address is not offered to clients obtaining a lease from the server.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); lease; ping; scope

connect

To assign a drive letter, port, or computer name to a shared resource so that you can use it.

See also: shared resource

connected user

A user who has access to a computer or a resource across the network.

See also: resource

connected, authenticating user

A user's status when a telephone connection has been established but authentication has not yet taken place. The user may be trying to prove security clearance, or the system may be idle. If this condition occurs, followed by the Waiting for Call phase, then the user was unable to provide a correct user name or password. If this phase is repeated, followed by the Waiting for Call phase, an unauthorized attempt to access the network may be under way.

See also: authentication; Waiting for Call

connection object

An Active Directory object that represents a replication connection from one domain controller to another. The connection object is a child of the replication destinations NTDS Settings object and identifies the replication source server, contains a replication schedule, and specifies a replication transport. Connection objects are created automatically by the Knowledge Consistency Checker (KCC), but they can also be created manually. Automatically generated connections must not be modified by the user unless they are first converted into manual connections.

See also: Active Directory; Knowledge Consistency Checker (KCC); replication

connection request policy

A set of conditions and profile settings that network administrators use to specify how Internet Authentication Service (IAS) servers handle incoming authentication and accounting request messages.

See also: authentication; Internet Authentication Service (IAS); remote access policy

connection-oriented

A type of network protocol that requires an end-to-end virtual connection between the sender and receiver before communicating across the network.

See also: protocol

connectionless

A network protocol in which a sender broadcasts traffic on the network to an intended receiver without first establishing a connection to the receiver.

See also: protocol

connector application

For Message Queuing, an application that enables Message Queuing computers to communicate with computers that use other messaging systems.

See also: connector queue; foreign computer; Message Queuing

connector queue

For Message Queuing, a queue created on servers running a connector application. You can use the connector application to exchange messages with computers that are running other message-queuing products.

See also: connector application; foreign computer; Message Queuing

console

A framework for hosting administrative tools, such as Microsoft Management Console (MMC). A console is defined by the items in its console tree, which might include folders or other containers, World Wide Web pages, and other administrative items. A console has windows that can provide views of the console tree and the administrative properties, services, and events that are acted on by the items in the console tree.

See also: console tree; details pane; Microsoft Management Console (MMC)

console tree

The left pane in Microsoft Management Console (MMC) that displays the items contained in the console. The items in the console tree and their hierarchical organization determine the capabilities of a console.

See also: details pane; Microsoft Management Console (MMC)

constant bit rate (CBR)

An asynchronous transfer mode (ATM) service type that supports constant bandwidth allocation. This service type is used for voice and video transmissions that require little or no cell loss and rigorous timing controls during transmission.

See also: asynchronous transfer mode (ATM); bandwidth

constrained delegation

The ability to specify that a service or computer account can perform Kerberos delegation to a limited set of services.

See also: delegation; Kerberos V5 authentication protocol; service

container object

An object that can logically contain other objects. For example, a folder is a container object.

See also: noncontainer object; object

convergence

The process of stabilizing a system after changes occur in the network. For routing, if a route becomes unavailable, routers send update messages throughout the network, reestablishing information about preferred routes.

For Network Load Balancing, a process by which hosts exchange messages to determine a new, consistent state of the cluster and to elect the default host. During convergence, a new load distribution is determined for hosts that share the handling of network traffic for specific Transmission Control Protocol (TCP) or User Datagram Protocol (UDP) ports.

See also: cluster; default host; host; Network Load Balancing; routing; User Datagram Protocol (UDP)

copy backup

A backup that copies all selected files but does not mark each file as having been backed up (in other words, the archive attribute is not cleared). Copying is useful if you want to back up files between normal and incremental backups because copying does not affect these other backup operations.

See also: daily backup; differential backup; incremental backup; normal backup

copy set

A duplicate of the media master that Remote Storage copies to a different tape or disk. Copy sets are typically used for backup purposes.

See also: media master; Remote Storage

count to infinity

A loop that happens when a link in a network goes down and routers on the network update their routing tables with incorrect hop counts. For example, a loop can develop if the link to Router C goes down. Router B then advertises that the link is down and that it has no route to C. Because Router A has a route to C with a metric of 2, it responds to Router B and sends its link to C. Router B then updates its table to include a link with metric 3, and the routers continue to announce and update their links to C until they reach the number 16. This is a count to infinity.

See also: router

CPU Time

In Task Manager, the total processor time, in seconds, used by a process since it started.

See also: Task Manager

CPU Usage

In Task Manager, the percentage of time that a process used the CPU since the last update. This percentage is displayed in Task Manager on the Processes tab, under the CPU column heading.

See also: Task Manager

crash consistency

A feature of shadow copy backups that ensures all files are backed up, regardless of their state.

See also: volume shadow copy

Crash Dump Type

Specifies the file format Dr. Watson will use to store the information. The Full format contains the entire memory space of the program, as well as the program image itself, the handle table, and other information that will be useful to the debugger. The Mini format may include the full memory and handle table, or it may simply contain information about a single thread. The Windows NT 4.0-compatible Full format provides you with the opportunity to use older tools to analyze the dump file. Crash Dump Type is only available when you have selected the Create Crash Dump File check box.

CRC errors

Errors caused by the failure of a cyclic redundancy check. A CRC error indicates that one or more characters in the data packet received were found garbled on arrival.

credentials

A set of information that includes identification and proof of identification that is used to gain access to local and network resources. Examples of credentials are user names and passwords, smart cards, and certificates.

See also: certificate; password; smart card

CRL

See definition for: certificate revocation list (CRL)

CRL distribution point

An optional extension in an X.509 v3 certificate that identifies how information is obtained. Also, a directory entry or other distribution source for certificate revocation lists.

See also: certificate; certificate revocation list (CRL); X.509 v3 certificate

cross-reference object

An object in which Active Directory stores information about directory partitions and external directory services. An example of an external directory service is another LDAP-compliant directory.

See also: Active Directory; directory partition; Lightweight Directory Access Protocol (LDAP)

CryptoAPI

An application programming interface (API) that is provided as part of Microsoft Windows. CryptoAPI provides a set of functions that allows applications to encrypt or digitally sign data in a flexible manner while providing protection for the user's sensitive private key data. Actual cryptographic operations are performed by independent modules known as cryptographic service providers (CSPs).

See also: application programming interface (API); cryptographic service provider (CSP); private key

cryptographic checksum

A mathematical value that is a result of a calculation involving a cryptographic algorithm and a cryptographic key. Also known as an integrity check value (ICV) or a message integrity code (MIC).

See also: cryptography

cryptographic service provider (CSP)

The code that performs authentication, encoding, and encryption services that Windows-based applications access through CryptoAPI. A CSP is responsible for creating keys, destroying them, and using them to perform a variety of cryptographic operations. Each CSP provides a different implementation of the CryptoAPI. Some provide stronger cryptographic algorithms, while others use hardware components, such as smart cards.

See also: authentication; CryptoAPI; encryption; service; smart card

cryptography

The processes, art, and science of keeping messages and data secure. Cryptography is used to enable and ensure confidentiality, data integrity, authentication (entity and data origin), and nonrepudiation.

See also: authentication; nonrepudiation

CSP

See definition for: cryptographic service provider (CSP)

CTI

See definition for: computer-telephony integration (CTI)

CTL

See definition for: certificate trust list (CTL)

custom file type

Typically, files with extensions that have been created for special kinds of files. Custom file types are not tracked by the system registry.

See also: registry

D

D-channel

A separate channel of an Integrated Services Digital Network (ISDN) line that is used for ISDN signaling. For ISDN Basic Rate Interface (BRI), the D-channel is 16 kilobits per second (Kbps). For ISDN Primary Rate Interface (PRI), the D-channel is 64 Kbps. Also called data channel.

See also: Integrated Services Digital Network (ISDN); switch type

DACL

See definition for: discretionary access control list (DACL)

daily backup

A backup that copies all selected files that have been modified the day the daily backup is performed. The backed-up files are not marked as having been backed up (in other words, the archive attribute is not cleared).

See also: copy backup; differential backup; incremental backup; normal backup

Data Communications Equipment (DCE)

One of two types of hardware that are connected by an RS-232-C serial connection, the other being a Data Terminal Equipment (DTE) device. A DCE is an intermediary device that often transforms input from a DTE before sending it to a recipient. A modem, for example, is a DCE that modulates data from a microcomputer (DTE) and sends it along a telephone connection.

See also: Data Terminal Equipment (DTE); RS-232-C standard

Data Encryption Standard (DES)

An encryption algorithm that uses a 56-bit key and maps a 64-bit input block to a 64-bit output block. The key appears to be a 64-bit key, but one bit in each of the eight bytes is used for odd parity, resulting in 56 bits of usable key.

See also: key

data fork

One of two forks (resource fork and data fork) that make up each Macintosh file. The data fork holds most of the file's information and is shared between Macintosh and personal computer clients.

See also: resource fork

data integrity

A property of secure communications that allows a computer to verify that data has not been modified in transit from its source. For example, Internet Protocol security (IPSec)-protected data contains a cryptographic checksum that incorporates a secret key that is known only to the IPSec peers that are communicating. An intermediate node can modify the data, but without knowledge of the secret key, the node cannot recompute a correct cryptographic checksum.

See also: cryptographic checksum; Internet Protocol security (IPSec)

Data Link Control (DLC)

An address that uniquely identifies a node on a network. Every network adapter has a DLC address or DLC identifier (DLCI). Some network protocols, such as Ethernet and Token Ring, use DLC addresses exclusively. Other protocols, such as TCP/IP, use a logical address at the OSI Network layer to identify nodes.

However, all network addresses must eventually be translated to DLC addresses. In TCP/IP networks, this translation is performed by the Address Resolution Protocol (ARP).

See also: Address Resolution Protocol (ARP); node; Open Systems Interconnection (OSI) reference model

data origin authentication

A property of secure communications that allows a computer to verify that data originated from a valid source. For example, IPSec-protected data contains a cryptographic checksum that incorporates a secret key that is known only to the IPSec peers that are communicating. An invalid source can send data, but without knowledge of the secret key, the source cannot compute a correct cryptographic checksum.

See also: cryptographic checksum; cryptography; encryption; Internet Protocol security (IPSec); key

Data Terminal Equipment (DTE)

In the RS-232-C hardware standard, any device, such as a remote access server or client, that has the ability to transmit information in digital form over a cable or a communications line.

See also: Data Communications Equipment (DCE); remote access server; RS-232-C standard

data-overrun error

A state in which the sending computer is transmitting characters faster than the receiving computer can accommodate them. If this problem persists, reduce the bits-per-second (bps) rate.

See also: bits per second (bps)

datagram

One packet, or unit, of information that includes relevant delivery information, such as the destination address, that is sent through a packet-switching network.

See also: packet

Dcdiag

A Windows Support Tool that analyzes the state of domain controllers in a forest or enterprise and provides detailed information about how to identify abnormal behavior in a system. Domain controllers are identified and tested according to directives entered by the user at the command line. Also known as Domain Controller Diagnostic Tool.

Dcdiag executes tests in the following functional areas of the system:

  • Connectivity
  • Replications
  • Topology integrity
  • Check Naming Context (NC) head security descriptors
  • Check net logon rights
  • Locator get domain controller
  • Intersite health
  • Check roles
  • Trust verification

See also: command prompt window; domain controller

DCE

See definition for: Data Communications Equipment (DCE)

DCOM

See definition for: Distributed Component Object Model (DCOM)

DDE

See definition for: dynamic data exchange (DDE)

dead-letter queue

For Message Queuing, a queue that stores nontransactional messages that are undeliverable or expired. These queues store failed messages on the computer on which the message expired. Messages in these queues are written to disk and are therefore recoverable.

See also: Message Queuing; queue; transactional dead-letter queue; transactional message

debugger

A program designed to aid in detecting, locating, and correcting errors in another program by allowing the programmer to step through the program, examine the data, and monitor conditions such as the values of variables.

See also: variable

dedicated adapter

The network adapter that, when using multiple network adapters in each host of a Network Load Balancing cluster, handles network traffic not related to cluster operations (the traffic for individual hosts on the network). This adapter is programmed with the host's dedicated IP address.

See also: cluster adapter; IP address; Network Load Balancing

dedicated connection

A communications channel that connects two or more geographic locations. Dedicated connections are private or leased lines, rather than public lines.

See also: channel

dedicated IP address

The IP address of a Network Load Balancing host used for network traffic that is not associated with the Network Load Balancing cluster (for example, Telnet access to a specific host within the cluster). This IP address is used to individually address each host in the cluster and therefore should be unique for each host.

See also: host; IP address; Network Load Balancing; Network Load Balancing cluster

default button

In some dialog boxes, the command button that is selected or highlighted when the dialog box is initially displayed. The default button has a bold border, indicating that it will be chosen automatically if you press ENTER. You can override a default button by clicking Cancel or another command button.

default host

The host with the highest host priority for which a drainstop command is not in progress. After convergence, the default host handles all of the network traffic for Transmission Control Protocol (TCP) and User Datagram Protocol (UDP) ports that are not otherwise covered by port rules.

See also: convergence; drainstop; host; host priority; port rule; User Datagram Protocol (UDP)

default network

In the Macintosh environment, the physical network on which the processes of a server reside as nodes and on which the server appears to users. The default network of the server must be one to which that server is attached. Only servers on AppleTalk Phase 2 internets have default networks.

See also: AppleTalk Phase 2; internet; node

default printer

The printer to which a computer sends documents if you select the Print command without first specifying which printer you want to use with a program. You can have only one default printer; it should be the printer you use most often.

See also: printer

default security level

For software restriction policies, the default setting that defines whether software in a Group Policy object (GPO) is allowed to run. Exceptions can be made to the default security level by means of software restriction policies rules.

See also: Group Policy object (GPO); software restriction policies; software restriction policies rule

default tree and context

The position of a User object in the file system of a Novell Directory Services (NDS) tree on a Novell NetWare network. The default tree and context is the default logon location in an NDS tree for a Microsoft Windows computer that is running Client Service for NetWare.

See also: Client Service for NetWare; Novell Directory Services (NDS); object

default user

The profile that serves as a basis for all user profiles. Every user profile begins as a copy of the default user profile.

See also: user profile

default zone

The zone to which all Macintosh clients on the network are assigned by default.

See also: zone

defragmentation

The process of rewriting parts of a file to contiguous sectors on a hard disk to increase the speed of access and retrieval.

In Active Directory, defragmentation rearranges how the data is written in the directory database file to compact it.

See also: Active Directory; fragmentation

delegated authentication

A method of authentication by which a trusted server (or service) is enabled to act as the client when it connects to third-tier application resources.

See also: authentication; client; server; service

delegation

An assignment of administrative responsibility to a user, computer, group, or organization.

For Active Directory, an assignment of responsibility that allows users without administrative credentials to complete specific administrative tasks or to manage specific directory objects. Responsibility is assigned through membership in a security group, the Delegation of Control Wizard, or Group Policy settings.

For DNS, an assignment of responsibility for a DNS zone. Delegation occurs when a name server (NS) resource record in a parent zone lists the DNS server that is authoritative for a child zone.

See also: Active Directory; administrative credentials; DNS server; Domain Name System (DNS); Group Policy; security group; zone

delta CRL

A document that lists certificates that have been revoked after the last full certificate revocation list (CRL) has been published. Delta CRLs are maintained and published by a certification authority (CA), and they are normally much smaller than a full CRL.

See also: certificate; certificate revocation list (CRL); certification authority (CA)

demand-dial connection

A connection, typically using a circuit-switched wide area network link, that is initiated when data needs to be forwarded. The demand-dial connection is typically terminated when there is no traffic.

See also: wide area network (WAN)

demand-dial routing

Routing that makes dial-up connections to connect networks based on need. For example, a branch office with a modem that dials and establishes a connection only when there is network traffic from one office to another.

See also: dial-up connection; modem (modulator/demodulator)

demilitarized zone (DMZ)

See definition for: perimeter network

denial-of-service attack

An attack in which an attacker exploits a weakness or a design limitation of a network service to overload or halt the service, so that the service is not available for use. This type of attack is typically started to prevent other users from using a network service such as a Web server or a file server.

See also: service; Web server

dependency

A relationship of reliance between two resources that makes it necessary for them to run in the same group on the same node. For example, an application is dependent on the disks that contain its data resources.

See also: node; resource

dependency tree

A diagram for visualizing the dependency relationships between resources.

See also: dependency; resource

dependent client

For Message Queuing, a computer that requires synchronous access to a Message Queuing server to perform all standard message queuing operations, such as sending and receiving messages and creating queues.

See also: independent client; Message Queuing server

DES

See definition for: Data Encryption Standard (DES)

descendent key

All the subkeys that appear when a key in the registry is expanded. A descendent key is the same as a subkey.

See also: key; subkey

desktop

The on-screen work area on which windows, icons, menus, and dialog boxes appear.

desktop pattern

A design that appears across your desktop. You can create your own pattern or select a pattern provided by Windows.

See also: desktop

destination document

The document into which a package or a linked or embedded object is being inserted. For an embedded object, this is sometimes also called the container document.

See also: embedded object

details pane

The right pane in Microsoft Management Console (MMC) that displays details for the selected item in the console tree. The details can be a list of items or they can be administrative properties, services, and events that are acted on by a snap-in.

See also: console tree; Microsoft Management Console (MMC); service; snap-in

device

Any piece of equipment that can be attached to a network or computer, for example, a computer, printer, joystick, adapter, or modem card, or any other peripheral equipment. Devices normally require a device driver to function with Windows.

For Windows licensing, electronic equipment such as computers, workstations, terminals, and handheld computers that can access or use the services of Windows operating systems, including file sharing, print sharing, remote access, and authentication.

See also: device driver

device conflict

A conflict that occurs when the same system resources have been allocated to two or more devices. System resources include interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses.

See also: direct memory access (DMA); input/output (I/O) port; interrupt request (IRQ) lines; memory address; resource

device driver

A program that enables a specific device, such as a modem, network adapter, or printer, to communicate with the operating system. Although a device might be installed on your system, Windows cannot use the device until you have installed and configured the appropriate driver. Device drivers load automatically (for all enabled devices) when a computer is started, and thereafter they run invisibly.

See also: device; signed driver; unsigned driver; Windows Catalog

device fonts

See definition for: printer fonts

Device Manager

An administrative tool that you can use to manage the devices on your computer. Using Device Manager, you can view and change device properties, update device drivers, configure device settings, and uninstall devices.

See also: device; uninstall

DFS

See definition for: Distributed File System (DFS)

DFS link

An element in the Distributed File System (DFS) namespace that lies below the root and maps to one or more targets, each of which corresponds to a shared folder or another DFS root.

See also: DFS root; Distributed File System (DFS); domain DFS

DFS namespace

A namespace consisting of a root and many links and targets. The namespace starts with a root that maps to one or more root targets. Below the root are links that map to their own targets. The Distributed File System (DFS) namespace provides the user with a logical view of distributed network shares.

See also: Distributed File System (DFS); root

DFS path

The combination of a Distributed File System (DFS) root and a DFS link. An example of a DFS path is \\server\dfs\a\b\c\link, where \\server\dfs is the DFS root, and \a\b\c\ is the DFS link.

See also: DFS link; DFS root; Distributed File System (DFS)

DFS root

The starting point of the Distributed File System (DFS) namespace. The root is often used to refer to the namespace as a whole. A root maps to one or more root targets, each of which corresponds to a shared folder on a server.

See also: DFS link; DFS namespace; Distributed File System (DFS)

DFS topology

The overall logical hierarchy of the Distributed File System (DFS), including elements such as roots, links, shared folders, and replica sets, as depicted in the DFS administrative console. This is not to be confused with the DFS namespace, which is the logical view of shared resources seen by users.

See also: DFS link; DFS namespace; DFS root; Distributed File System (DFS); domain DFS

DHCP

See definition for: Dynamic Host Configuration Protocol (DHCP)

DHCP acknowledgment message (DHCPACK)

A message sent by the DHCP server to a client to acknowledge and complete a client's request for leased configuration. This message will contain a committed IP address for the client to use for a stated period of time along with other optional client parameters. The DHCP acknowledgment message name is DHCPACK.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP)

DHCP class identifier

A special reserved option type used by DHCP clients to optionally identify membership in a specific DHCP option class, either a vendor or user class. For vendor class identification, hardware vendors can choose to predefine specific identifier values; for example, to identify a client's hardware configuration. For user class identification, values can be defined administratively to identify a logical group of DHCP clients, such as all clients in a particular building and floor location.

See also: DHCP client; DHCP option; Dynamic Host Configuration Protocol (DHCP)

DHCP client

Any network-enabled device that supports the ability to communicate with a DHCP server for the purpose of obtaining dynamic leased IP configuration and related optional parameters information.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); lease

DHCP client alternate configuration

An alternate static configuration option for TCP/IP network connections that provides simplified computer migration between networks.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

DHCP decline message (DHCPDECLINE)

A message sent by a DHCP client to the DHCP server to decline the offer of an IP address on the network. This message is used when the client detects a potential conflict because the IP address is found to be already in use on the network. The DHCP decline message name is DHCPDECLINE.

See also: DHCP client; DHCP server; Dynamic Host Configuration Protocol (DHCP)

DHCP information message (DHCPINFORM)

A reserved DHCP message type used by computers on the network to request and obtain information from a DHCP server for use in their local configuration. When this message type is used, the sender is already externally configured for its IP address on the network, which may or may not have been obtained using DHCP. The DHCP information message name is DHCPINFORM.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP)

DHCP negative acknowledgment message (DHCPNAK)

A message sent by a DHCP server to a client to indicate that the IP address that the client requested is not correct for the local IP network served by the DHCP server. This message is most often used when the client computer was moved to a new location, but it could also indicate that the client's lease with the server has expired. The DHCP negative acknowledgment message name is DHCPNAK.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); lease

DHCP offer message (DHCPOFFER)

A message used by DHCP servers to offer the lease of an IP address to a DHCP client when it starts on the network. When this message is used, a client can receive more than one offer if multiple DHCP servers are contacted during the DHCP discovery phase, but the client will typically select the first address it is offered. The DHCP offer message name is DHCPOFFER.

See also: DHCP client; DHCP server; Dynamic Host Configuration Protocol (DHCP)

DHCP option

Address configuration parameters that a DHCP service assigns to clients. Most DHCP options are predefined, based on optional parameters defined in Request for Comments (RFC) 1542, although extended options can be added by vendors or users.

See also: DHCP service; Dynamic Host Configuration Protocol (DHCP)

DHCP release message (DHCPRELEASE)

A message sent by clients to the DHCP server to indicate release of its leased IP address. The client uses this message to cancel its currently active lease. You can perform address release manually using the ipconfig /release command at a command prompt. The DHCP release message name is DHCPRELEASE.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); lease

DHCP request message (DHCPREQUEST)

A message sent by clients to the DHCP server to request or renew lease of its IP address. The client uses this message under the following conditions:

  • To select and request a lease from a specific DHCP server when lease offers were made simultaneously from several different servers.
  • To confirm a previously leased IP address after the client system is restarted.
  • To extend the current IP address lease for the client.

The DHCP request message name is DHCPREQUEST.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); lease

DHCP server

A computer running the Microsoft DHCP service that offers dynamic configuration of IP addresses and related information to DHCP-enabled clients.

See also: DHCP service; Dynamic Host Configuration Protocol (DHCP); IP address

DHCP service

A service that enables a computer to function as a DHCP server and configure DHCP-enabled clients on a network. DHCP runs on a server, enabling the automatic, centralized management of IP addresses and other TCP/IP configuration settings for network clients.

See also: Dynamic Host Configuration Protocol (DHCP); IP address; service

DHCP service resource

A resource type that provides DHCP services from a cluster.

See also: cluster; Dynamic Host Configuration Protocol (DHCP)

DHCP/BOOTP Relay Agent

The agent program or component responsible for relaying Dynamic Host Configuration Protocol (DHCP) and bootstrap protocol (BOOTP) broadcast messages between a DHCP server and a client across an Internet Protocol (IP) router. A DHCP relay agent supports DHCP/BOOTP message relay as defined in RFCs 1541 and 2131. The DHCP Relay Agent service is managed using the Routing and Remote Access service.

See also: bootstrap protocol (BOOTP); DHCP server; Dynamic Host Configuration Protocol (DHCP); Request for Comments (RFC)

DHCPACK

See definition for: DHCP acknowledgment message (DHCPACK)

DHCPDECLINE

See definition for: DHCP decline message (DHCPDECLINE)

DHCPINFORM

See definition for: DHCP information message (DHCPINFORM)

DHCPNAK

See definition for: DHCP negative acknowledgment message (DHCPNAK)

DHCPOFFER

See definition for: DHCP offer message (DHCPOFFER)

DHCPRELEASE

See definition for: DHCP release message (DHCPRELEASE)

DHCPREQUEST

See definition for: DHCP request message (DHCPREQUEST)

dial location

The country code, area code, and specific dialing requirements for the place you are dialing from. Once you have created a dial location, you can select it to apply the dialing requirements to all your calls. To change dialing locations, select or create a different one.

dial-in constraints

Settings in a remote access policy that permit or deny access to remote access clients.

See also: remote access policy

dial-up connection

The connection to your network if you use a device that uses the telephone network. This includes modems with a standard telephone line, ISDN cards with high-speed ISDN lines, or X.25 networks.

If you are a typical user, you might have one or two dial-up connections, for example, to the Internet and to your corporate network. In a more complex server situation, multiple network modem connections might be used to implement advanced routing.

See also: Integrated Services Digital Network (ISDN); modem (modulator/demodulator)

dial-up line

A standard dial-up connection, such as telephone and Integrated Services Digital Network (ISDN) lines. Also called switched circuit.

See also: Integrated Services Digital Network (ISDN)

differential backup

A backup that copies files created or changed since the last normal or incremental backup. It does not mark files as having been backed up (in other words, the archive attribute is not cleared). If you are performing a combination of normal and differential backups, restoring files and folders requires that you have the last normal as well as the last differential backup.

See also: copy backup; daily backup; incremental backup; normal backup

differential data

Saved copies of changed data that can be applied to an original volume to generate a volume shadow copy.

See also: volume; volume shadow copy

Diffie-Hellman key agreement protocol

A cryptographic mechanism that allows two parties to establish a shared secret key without having any preestablished secrets between them. Diffie-Hellman is frequently used to establish the shared secret keys that are used by common applications of cryptography, such as Internet Protocol security (IPSec). It is not normally used for data protection.

See also: cryptography; Internet Protocol security (IPSec); key

digest

See definition for: Digest authentication

Digest authentication

An authentication mechanism that hashes user name, password, and other data before transmitting it over the network.

See also: authentication; Basic authentication; encryption; hash; password; user name

digital signature

A means for originators of a message, file, or other digitally encoded information to bind their identity to the information. The process of digitally signing information entails transforming the information, as well as some secret information held by the sender, into a tag called a signature. Digital signatures are used in public key environments, and they provide nonrepudiation and integrity services.

See also: Digital Signature Standard (DSS); public key cryptography; service; time stamp

Digital Signature Standard (DSS)

A standard that uses the Digital Signature Algorithm (DSA) for its signature algorithm and Secure Hash Algorithm (SHA-1) as its message hash algorithm. DSA is a public-key cipher that is used only to generate digital signatures and cannot be used for data encryption.

See also: digital signature; Secure Hash Algorithm (SHA-1)

digital subscriber line (DSL)

A special communication line that uses modulation technology to maximize the amount of data that can be sent over copper wires. DSL is used for connections from telephone switching stations to a subscriber rather than between switching stations.

digital video disc (DVD)

A type of optical disc storage technology. A digital video disc (DVD) looks like a CD-ROM disc, but it can store greater amounts of data. DVDs are often used to store full-length movies and other multimedia content that requires large amounts of storage space.

See also: DVD decoder; DVD drive

direct cable connection

A link between the input/output (I/O) ports of two computers created with a single cable rather than a modem or other interfacing devices. In most cases, a direct cable connection is made with a null modem cable.

See also: input/output (I/O) port; null modem cable

direct hosting

For Microsoft networking, the sending of file and print sharing traffic using the Server Message Block (SMB) protocol (also known as the Common Internet File System (CIFS) protocol) without the use of network basic input/output system (NetBIOS). Direct hosting for the Microsoft redirector (the Workstation service) and file server (the Server service) is supported over both TCP/IP and Internetwork Packet Exchange (IPX). Although direct hosting may be more efficient, a direct hosting client can connect only to a direct hosting server.

See also: Internetwork Packet Exchange (IPX); network basic input/output system (NetBIOS); NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink); Server Message Block (SMB); Transmission Control Protocol/Internet Protocol (TCP/IP)

direct memory access (DMA)

Memory access that does not involve the microprocessor. DMA is frequently used for data transfer directly between memory and a peripheral device such as a disk drive.

See also: hardware configuration

directory

An information source that contains information about users, computer files, or other objects. In a file system, a directory stores information about files. In a distributed computing environment (such as a Windows domain), the directory stores information about objects such as printers, fax servers, applications, databases, and other users.

See also: domain; object

directory database

The physical storage for each replica of Active Directory. Also called the store.

See also: Active Directory; replica

directory partition

A contiguous subtree of Active Directory that is replicated as a unit to other domain controllers in the forest that contain a replica of the same subtree. In Active Directory, a single domain controller always holds at least three directory partitions: schema (class and attribute definitions for the directory), configuration (replication topology and related metadata), and domain (subtree that contains the per-domain objects for one domain). Domain controllers running Windows Server 2003 can also store one or more application directory partitions.

See also: Active Directory; application directory partition; attribute; domain; global catalog; replica; replication; schema

directory service

Both the directory information source and the service that makes the information available and usable. A directory service enables the user to find an object when given any one of its attributes.

See also: Active Directory; attribute; directory; object

directory store

The physical storage for Active Directory directory partition replicas on a specific domain controller. The store is implemented using the Extensible Storage Engine.

See also: Active Directory; directory partition; domain controller; replica

DirectX

An extension of the Microsoft Windows operating system. DirectX technology helps games and other programs use the advanced multimedia capabilites of your hardware.

dirty bit

A bit that is used to mark modified data in a cache so that the modifications may be carried over to primary memory.

For Windows file systems, a bit that is used to indicate that the file system is in an inconsistent and possibly corrupted state. When it is set, the file system's dirty bit triggers the chkdsk command to run when the computer is restarted.

See also: bit (binary digit); file system

disable

To make a device nonfunctional. For example, if you disable a device in a hardware configuration, you cannot use the device when your computer uses that hardware configuration. Disabling a device frees the resources that were allocated to the device.

See also: device; enable; hardware configuration

discretionary access control list (DACL)

The part of an object's security descriptor that grants or denies specific users and groups permission to access the object. Only the owner of an object can change permissions granted or denied in a DACL; thus, access to the object is at the owner's discretion.

See also: access control entry (ACE); distribution group; object; security descriptor; security group; system access control list (SACL)

disk

A storage device that is attached to a computer.

See also: basic disk; dynamic disk

disk configuration information

Information in the Windows registry on assigned drive letters, simple volumes, striped volumes, mirrored volumes, spanned volumes, and RAID-5 volumes. You can change the disk configuration by using Disk Management.

See also: mirrored volume; RAID-5 volume; registry; simple volume; spanned volume; striped volume; volume

disk mirroring

A set of software processes that maintains a backup copy of a volume at all times. Each mirror of a volume resides on a different disk; ideally, each disk has its own controller. If one mirror becomes unavailable (due to a disk failure, for example), you can use the other mirror to gain access to the volume's data.

See also: mirror; volume

dismount

To remove a removable tape or disc from a drive.

See also: library; mount

display adapter

See definition for: video adapter

display password

A password that allows the user to open only previously saved capture (.cap) files.

See also: capture password; password

distinguished name

A name that uniquely identifies an object by using the relative distinguished name for the object, plus the names of container objects and domains that contain the object. The distinguished name identifies the object as well as its location in a tree. Every object in Active Directory has a distinguished name. A typical distinguished name might be

CN=MyName,CN=Users,DC=Microsoft,DC=Com

This identifies the MyName user object in the microsoft.com domain.

See also: Active Directory; container object; domain; object; relative distinguished name

Distributed Component Object Model (DCOM)

The Microsoft Component Object Model (COM) specification that defines how components communicate over Windows-based networks. Use the DCOM Configuration tool to integrate client/server applications across multiple computers. DCOM can also be used to integrate robust Web browser applications.

See also: Component Object Model (COM)

Distributed File System (DFS)

A service that allows system administrators to organize distributed network shares into a logical namespace, enabling users to access files without specifying their physical location and providing load sharing across network shares.

See also: service

distribution group

A group that is used solely for e-mail distribution and that is not security-enabled. Distribution groups cannot be listed in discretionary access control lists (DACLs) used to define permissions on resources and objects. Distribution groups can be used only with e-mail applications (such as Microsoft Exchange) to send e-mail to collections of users. If you do not need a group for security purposes, create a distribution group instead of a security group.

See also: discretionary access control list (DACL); security group

DLC

See definition for: Data Link Control (DLC)

DLL

See definition for: dynamic-link library (DLL)

DMA

See definition for: direct memory access (DMA)

DMZ

See definition for: demilitarized zone (DMZ)

DNS

See definition for: Domain Name System (DNS)

DNS client

A client computer that queries DNS servers in an attempt to resolve DNS domain names. DNS clients maintain a temporary cache of resolved DNS domain names.

See also: client; DNS server; Domain Name System (DNS)

DNS dynamic update protocol

See definition for: dynamic update

DNS Security Extensions (DNSSEC)

DNS extensions that use digital signatures to provide data authentication and integrity to compliant DNS resolvers and applications.

See also: authentication; digital signature; Domain Name System (DNS); resolver; resource record (RR); secure zone

DNS server

A server that maintains information about a portion of the DNS database and that responds to and resolves DNS queries.

See also: DNS client; Domain Name System (DNS); server

DNS suffix

For DNS, a character string that represents a domain name. The DNS suffix shows where a host is located relative to the DNS root, specifying a host’s location in the DNS hierarchy. Usually, the DNS suffix describes the latter portion of a DNS name, following one or more of the first labels of a DNS name.

See also: domain name; Domain Name System (DNS)

DNS zone

In a DNS database, a contiguous portion of the DNS tree that is administered as a single, separate entity by a DNS server. The zone contains resource records for all the names within the zone.

See also: DNS server; Domain Name System (DNS); resource record (RR)

DNSSEC

See definition for: DNS Security Extensions (DNSSEC)

docking station

A unit for housing a portable computer that contains a power connection, expansion slots, and connections to peripherals, such as a monitor, printer, full-sized keyboard, and mouse. The docking station turns the portable computer into a desktop computer.

document

Any self-contained piece of work created with an application program and, if saved on disk, given a unique file name by which it can be retrieved.

See also: filter; property cache

domain

In Active Directory, a collection of computer, user, and group objects defined by the administrator. These objects share a common directory database, security policies, and security relationships with other domains.

In DNS, any tree or subtree within the DNS namespace. Although the names for DNS domains often correspond to Active Directory domains, DNS domains should not be confused with Active Directory domains.

See also: Active Directory; directory database; Domain Name System (DNS); object

domain administrator

A person who is a member of the Domain Admins group. Domain administrators can create, delete, and manage all objects that reside within the domain in which they are administrators. They can also assign and reset passwords and delegate administrative authority for network resources to other trusted users.

See also: domain; object; resource

domain controller

In an Active Directory forest, a server that contains a writable copy of the Active Directory database, participates in Active Directory replication, and controls access to network resources. Administrators can manage user accounts, network access, shared resources, site topology, and other directory objects from any domain controller in the forest.

See also: Active Directory; authentication; directory; forest; shared resource

domain controller locator (Locator)

An algorithm running in the context of the Net Logon service that enables a client to locate a domain controller. Locator can find domain controllers by using DNS or network basic input/output system (NetBIOS) names. The DNS service (SRV) resource records registered by Locator on behalf of domain controllers are also known as domain controller locator (Locator) resource records.

See also: domain controller; Domain Name System (DNS); network basic input/output system (NetBIOS); service (SRV) resource record

domain DFS

An implementation of Distributed File System (DFS) in which DFS topological information is stored in Active Directory. Because this information is made available on multiple domain controllers in the domain, domain DFS provides fault tolerance for any distributed file system in the domain.

See also: Active Directory; DFS topology; Distributed File System (DFS); fault tolerance

domain functionality

The functional level of an Active Directory domain that has one or more domain controllers running Windows Server 2003. The functional level of a domain can be raised to enable new Active Directory features that will apply to that domain only. There are four domain functional levels: Windows 2000 mixed, Windows 2000 native, Windows Server 2003 interim, and Windows Server 2003. The default domain functional level is Windows 2000 mixed. When the domain functional level is raised to Windows 2000 native, Windows Server 2003 interim, or Windows Server 2003, advanced domain-wide Active Directory features are available.

See also: Active Directory; domain; domain controller

domain hierarchy

The parent/child tree structure of domains.

See also: domain

domain local group

A security or distribution group that can contain universal groups, global groups, other domain local groups from its own domain, and accounts from any domain in the forest. Domain local security groups can be granted rights and permissions on resources that reside only in the same domain where the domain local group is located.

See also: distribution group; domain tree; forest; global group; security group; universal group

domain name

The name given by an administrator to a collection of networked computers that share a common directory. Part of the DNS naming structure, domain names consist of a sequence of name labels separated by periods.

See also: domain; Domain Name System (DNS); label

Domain Name System (DNS)

A hierarchical, distributed database that contains mappings of DNS domain names to various types of data, such as IP addresses. DNS enables the location of computers and services by user-friendly names, and it also enables the discovery of other information stored in the database.

See also: domain name; IP address; ping; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

domain namespace

The database structure used by DNS.

See also: Domain Name System (DNS)

domain naming master

A domain controller that holds the domain naming operations master role in Active Directory. The domain naming master controls the addition or removal of domains in the forest. At any time, the domain naming master role can be assigned to only one domain controller in the forest.

See also: Active Directory; domain controller; operations master

domain of origin

The parent DNS domain name that is used to root either a zone or a resource record within a zone. This name is joined to the end of unqualified or relative domain names to form a fully qualified domain name (FQDN) within the zone. In DNS Manager, the domain of origin will correspond to Zone name as it appears in the Add Zone Wizard or the name that appears in the Parent domain name field for any resource records created within the zone.

See also: domain; domain name; Domain Name System (DNS); fully qualified domain name (FQDN); relative name; resource record (RR); zone

domain root

A DFS namespace, for which the configuration information is stored in Active Directory. The path to access the root or a link starts with the host domain name. A domain root can have multiple root targets, which offer fault tolerance and load sharing at the root level.

See also: Active Directory; DFS namespace; root target

domain suffix

For DNS, an optional parent domain name that can be appended to the end of a relative domain name used in a name query or host lookup. The domain suffix can be used to complete an alternate fully qualified DNS domain name to be searched when the first attempt to query a name fails.

See also: Domain Name System (DNS); fully qualified domain name (FQDN); parent domain

domain tree

In DNS, the inverted hierarchical tree structure that is used to index domain names. Domain trees are similar in purpose and concept to the directory trees used by computer filing systems for disk storage. For example, when numerous files are stored on disk, directories can be used to organize the files into logical collections. When a domain tree has one or more branches, each branch can organize domain names used in the namespace into logical collections.

In Active Directory, a hierarchical structure of one or more domains, connected by transitive, bidirectional trusts, that forms a contiguous namespace. Multiple domain trees can belong to the same forest.

See also: Active Directory; domain; domain name; Domain Name System (DNS); forest; transitive trust; two-way trust

dots per inch (DPI)

The standard used to measure screen and printer resolution, expressed as the number of dots that a device can display or print per linear inch. The greater the number of dots per inch, the better the resolution.

downcasing

The case-insensitive handling of DNS domain names. Windows DNS servers use downcasing to convert any uppercase letters used in domain names to equivalent lowercase letters. For example, the name HOST.example.Microsoft.com would be downcased to host.example.microsoft.com.

See also: DNS server; domain name; Domain Name System (DNS); upcasing

downloadable fonts

A set of characters stored on disk and sent (downloaded) to a printer's memory when needed for printing a document. Downloadable fonts are most commonly used with laser printers and other page printers, although many dot-matrix printers can accept some of them. Also called soft fonts.

See also: font; font cartridge; PostScript fonts

DPI

See definition for: dots per inch (DPI)

drag

To move an item on the screen by selecting the item and then pressing and holding down the mouse button while moving the mouse. For example, you can move a window to another location on the screen by dragging its title bar.

drain

For Network Load Balancing, a command that disables new traffic handling for the rule whose port range contains the specified port. All ports specified by the port rule are affected.

See also: cluster; drainstop; Network Load Balancing; port; port rule

drainstop

For Network Load Balancing, a command that disables all new traffic handling on the specified hosts. The hosts then enter draining mode to complete existing connections.

While draining, hosts remain in the cluster and stop their cluster operations when there are no more active connections. To terminate draining mode, explicitly stop cluster mode with the stop command, or restart new traffic handling with the start command. To drain connections from a specific port, use the drain command.

See also: drain; host; Network Load Balancing

drive

An area of storage that is formatted with a file system and has a drive letter. The storage can be a floppy disk, a CD, a hard disk, or another type of disk. You can view the contents of a drive by clicking its icon in Windows Explorer or My Computer.

See also: drive letter; file system; volume

drive letter

The naming convention for disk drives on IBM and compatible computers. Drives are named by letter, beginning with A, followed by a colon.

See also: drive

drop folder

In the Macintosh environment, a folder for which you have the Make Changes permission but not the See Files or See Folders permission. You can copy files into a drop folder, but you cannot see what files and subfolders the drop folder contains.

See also: Make Changes

DSL

See definition for: digital subscriber line (DSL)

DSS

See definition for: Digital Signature Standard (DSS)

DTE

See definition for: Data Terminal Equipment (DTE)

dual boot

A computer configuration that can start two different operating systems.

See also: boot; multiple boot; startup environment

duplex

A system capable of transmitting information in both directions over a communications channel.

See also: full-duplex; half-duplex

DVD

See definition for: digital video disc (DVD)

DVD decoder

A hardware or software component that allows a digital video disc (DVD) drive to display movies on your computer screen.

See also: digital video disc (DVD); DVD drive; hardware decoder; software decoder

DVD drive

A disk storage device that uses digital video disc (DVD) technology. A DVD drive reads both CD-ROM and DVDs; however, you must have a DVD decoder to display DVD movies on your computer screen.

See also: digital video disc (DVD); DVD decoder

DWORD

A data type that is composed of hexadecimal data with a maximum allotted space of 4 bytes.

dynamic data exchange (DDE)

A form of interprocess communication (IPC) implemented in the Microsoft Windows family of operating systems. Two or more programs that support dynamic data exchange (DDE) can exchange information and commands.

See also: Network DDE service

dynamic disk

A physical disk that provides features that basic disks do not, such as support for volumes that span multiple disks. Dynamic disks use a hidden database to track information about dynamic volumes on the disk and other dynamic disks in the computer. You convert basic disks to dynamic by using the Disk Management snap-in or the DiskPart command-line tool. When you convert a basic disk to dynamic, all existing basic volumes become dynamic volumes.

See also: active volume; basic disk; basic volume; dynamic volume; partition; volume

Dynamic Host Configuration Protocol (DHCP)

A TCP/IP service protocol that offers dynamic leased configuration of host IP addresses and distributes other configuration parameters to eligible network clients. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of client IP addresses on the network.

DHCP uses a client/server model where the DHCP server maintains centralized management of IP addresses that are used on the network. DHCP-supporting clients can then request and obtain lease of an IP address from a DHCP server as part of their network boot process.

See also: DHCP client; DHCP server; IP address; lease; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

dynamic routing

The use of routing protocols to update routing tables. Dynamic routing responds to changes in the internetwork topology.

See also: protocol; routing

dynamic storage

A storage method in Windows that allows disk and volume management without requiring operating system restart.

See also: basic storage

dynamic update

An update to the Domain Name System (DNS) standard that permits DNS clients to dynamically register and update their resource records in zones.

See also: DNS client; DNS server; Domain Name System (DNS); resource record (RR); zone

dynamic volume

A volume that resides on a dynamic disk. Windows supports five types of dynamic volumes: simple, spanned, striped, mirrored, and RAID-5. A dynamic volume is formatted by using a file system, such as file allocation table (FAT) or NTFS, and has a drive letter assigned to it.

See also: basic disk; basic volume; dynamic disk; mirrored volume; RAID-5 volume; simple volume; spanned volume; striped volume; volume

dynamic-link library (DLL)

An operating system feature that allows executable routines (generally serving a specific function or set of functions) to be stored separately as files with .dll extensions. These routines are loaded only when needed by the program that calls them.

See also: Resource DLL

E

EAP

See definition for: Extensible Authentication Protocol (EAP)

effective permissions

Overall permissions that a user or group has on an object, taking into account group membership as well as inheritance from the parent object.

See also: group; inheritance; object; parent object; permission

EFI

See definition for: Extensible Firmware Interface (EFI)

EFI system partition

On Itanium-based computers, a portion on a GUID partition table (GPT) disk that is formatted with the file allocation table (FAT) file system and contains the files necessary to start the computer. Every Itanium-based computer must have at least one GPT disk with an EFI system partition. The EFI system partition serves the same purpose as the system volume found on x86-based computers.

See also: Extensible Firmware Interface (EFI); file allocation table (FAT); GUID partition table (GPT); Itanium; Microsoft Reserved (MSR) partition; system volume; x86

EFS

See definition for: Encrypting File System (EFS)

ELAN

See definition for: emulated local area network (ELAN)

embedded object

Information created in another program that has been pasted inside your document. When information is embedded, you can edit the information in the new document using toolbars and menus from the original program.

To edit the embedded information, double-click it and the toolbars and menus from the program used to create the information appear. Embedded information is not linked to the original source. If you change information in one place, it is not updated in the other.

See also: linked object; OLE; package; source document

emulated local area network (ELAN)

A logical ATM network that emulates the services of an Ethernet or Token Ring LAN.

See also: asynchronous transfer mode (ATM); local area network (LAN); Token Ring

enable

To make a device functional. For example, if a device in your hardware configuration settings is enabled, the device is available for use when your computer uses that hardware configuration.

See also: disable; hardware configuration

encapsulated PostScript (EPS) file

A file that prints at the highest possible resolution for your printer. An EPS file may print faster than other graphical representations. Some Windows-based and non-Windows-based graphical programs can import EPS files.

See also: PostScript

Encapsulating Security Payload (ESP)

An Internet Protocol security (IPSec) protocol that provides confidentiality, in addition to authentication, integrity, and anti-replay. ESP can be used alone, in combination with Authentication Header (AH), or nested with the Layer Two Tunneling Protocol (L2TP). ESP does not normally sign the entire packet unless it is being tunneled. Ordinarily, just the data payload is protected, not the IP header.

See also: authentication; Authentication Header (AH); Internet Protocol security (IPSec); Layer Two Tunneling Protocol (L2TP)

encapsulation

The method used to pass data from one protocol over a network within a different protocol. Data from one protocol is wrapped with the header of a different protocol. Encapsulation is described in RFC 1483.

See also: protocol; Request for Comments (RFC)

encrypted channel

A path or link through which encrypted information passes between two devices. This information typically includes the primary message content, not session configuration information.

See also: device; encryption

encrypted password

A password that is scrambled. Encrypted passwords are more secure than plaintext passwords, which are susceptible to network sniffers.

See also: encryption; password

Encrypting File System (EFS)

A feature in this version of Windows that enables users to encrypt files and folders on an NTFS volume disk to keep them safe from access by intruders.

See also: NTFS file system; recovery agent

encryption

The process of disguising a message or data in such a way as to hide its substance.

See also: public key encryption; symmetric encryption

Enforce

In Group Policy Management console (GPMC), to force the Group Policy object (GPO) links of the parent container to take precedence over the GPO links of the child containers. By default, the GPO links that are closest to the user or computer (links to the child container) have higher precedence than GPO links higher up (links to the parent container). Enforcement causes GPOs that are linked in parent containers to take precedence instead. In operating systems in the Windows Server 2003 family without GPMC, No Override is used instead of Enforce.

See also: block inheritance; Group Policy Management console (GPMC); Group Policy object link; inheritance; No Override; precedence

enhanced small device interface (ESDI)

A standard that can be used with high-capacity hard disks, floppy disk drives, and tape drives to allow these devices to communicate with a computer at high speeds.

enterprise certification authority

A certification authority (CA) that is fully integrated with Active Directory.

See also: Active Directory; certification authority (CA)

Enterprise Memory Architecture

A feature of Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition, that allows you to run applications that take advantage of large amounts of physical memory. Enterprise Memory Architecture supports two types of memory enhancement: application memory tuning, also known as 4-gigabyte tuning (4GT), and Physical Address Extension (PAE) X86.

See also: application memory tuning; Physical Address Extension (PAE)

entry

The lowest level element in the registry. Entries appear in the details pane of a Registry Editor window. Each entry consists of an entry name, its data type, and its value. Entries store the configuration data that affects the operating system and the programs that run on the system. As such, they are different from registry subtrees, keys, and subkeys, which are containers.

See also: key; registry; subkey; subtree

environment variable

A string consisting of environment information, such as a drive, path, or file name, associated with a symbolic name that can be used by Windows. You use System in Control Panel or the set command from the command prompt to define environment variables.

See also: string; variable

error detection

A technique for detecting when data is lost during transmission. This allows the software to recover lost data by notifying the transmitting computer that it needs to retransmit the data.

ESDI

See definition for: enhanced small device interface (ESDI)

ESP

See definition for: Encapsulating Security Payload (ESP)

event

Any significant occurrence in the system or an application that requires users to be notified or an entry to be added to a log.

Event Log service

A service that records events in the system, security, and application logs. The Event Log service is located in Event Viewer.

See also: event; event logging; Event Viewer; service

event logging

The process of recording an audit entry in the audit trail whenever certain events occur, such as services starting and stopping or users logging on and off and accessing resources.

See also: auditing; event; Event Viewer; service

Event Viewer

A component you can use to view and manage event logs, gather information about hardware and software problems, and monitor security events. Event Viewer maintains logs about program, security, and system events.

See also: event; event logging

everyone category

In the Macintosh environment, one of the user categories to which you assign permissions for a folder. Permissions granted to everyone apply to all users who use the server, including guests.

See also: permission

exclusion range

A small range of one or more IP addresses within a DHCP scope excluded from the DHCP service. Exclusion ranges ensure that these scope addresses will never be offered to clients by the DHCP server.

See also: DHCP server; DHCP service; scope

expanded memory

Type of memory that can be added to IBM personal computers. The use of expanded memory is defined by the Expanded Memory Specification (EMS), which supports memory boards containing RAM that can be enabled or disabled by software.

See also: extended memory

expansion slot

A socket in a computer, designed to hold expansion boards and connect them to the system bus.

See also: bus

expire interval

For DNS, the number of seconds that DNS servers operating as secondary masters for a zone will use to determine if zone data should be expired when the zone is not refreshed and renewed.

See also: DNS server; Domain Name System (DNS); zone

explicit permissions

Object permissions that are defined when the object is created, specifically assigned, or changed by the owner of the object.

See also: object; permission

express message

For Message Queuing, a message that uses fewer resources and is faster than a recoverable message. However, because express messages are mapped to memory, they are lost if the computer storing them fails.

See also: Message Queuing; recoverable message

extended memory

Memory beyond one megabyte in 80286, 80386, 80486, and Pentium computers.

See also: expanded memory

extended partition

A type of partition that you can create only on basic master boot record (MBR) disks. Extended partitions are useful if you want to create more than four volumes on a basic MBR disk. Unlike primary partitions, you do not format an extended partition with a file system and then assign a drive letter to it. Instead, you create one or more logical drives within the extended partition. After you create a logical drive, you format it and assign it a drive letter. An MBR disk can have up to four primary partitions or three primary partitions, one extended partition, and multiple logical drives.

See also: basic disk; drive letter; logical drive; master boot record (MBR); partition; primary partition; unallocated space; volume

Extensible Authentication Protocol (EAP)

An extension to the Point-to-Point Protocol (PPP) that allows for arbitrary authentication mechanisms to be employed for the validation of a PPP connection.

See also: Point-to-Point Protocol (PPP)

Extensible Firmware Interface (EFI)

In computers with the Intel Itanium processor, the interface between a computer's firmware, hardware, and the operating system. EFI defines a new partition style called GUID partition table (GPT). EFI serves the same purpose for Itanium-based computers as the basic input/output system (BIOS) found in x86-based computers. However, it has expanded capabilities that provide a consistent way to start any compatible operating system and an easy way to add EFI drivers for new bootable devices without the need to update the computer's firmware.

See also: basic input/output system (BIOS); GUID partition table (GPT); Itanium; x86

Extensible Markup Language (XML)

A meta-markup language that provides a format for describing structured data. This facilitates more precise declarations of content and more meaningful search results across multiple platforms. In addition, XML enables a new generation of Web-based data viewing and manipulation applications.

See also: Hypertext Markup Language (HTML)

extension-type association

The association of a file name extension with a Macintosh file type and file creator. By creating extension-type associations, you can choose which program starts automatically when you open a file with a particular extension. Services for Macintosh has many predefined extension-type associations.

external network number

A 4-byte hexadecimal number used for addressing and routing purposes on NetWare networks. The external network number is associated with physical network adapters and networks.

See also: internal network number; Internetwork Packet Exchange (IPX)

external trust

A trust that is manually created between two Active Directory domains that are located in different forests or between an Active Directory domain and a Windows NT 4.0 or earlier domain. External trusts are nontransitive and one-way.

See also: Active Directory; domain; forest; nontransitive trust; one-way trust; trust relationship

extranet

A limited subset of computers or users on a public network, typically the Internet, that can access an organization's internal network. For example, the computers or users might belong to a partner organization.

F

failback

The process of moving resources, either individually or in a group, back to their preferred node after the node has failed and come back online.

See also: failback policy; node; resource

failback policy

Parameters that an administrator can set using Cluster Administrator that affect failback operations.

See also: Cluster Administrator; failback

failed

A state that applies to a resource or a node in a cluster. A resource or a node is placed in the failed state after an unsuccessful attempt has been made to bring it online.

See also: cluster; node; resource

failover

In server clusters, the process of taking resource groups offline on one node and bringing them online on another node. When failover occurs, all resources within a resource group fail over in a predefined order; resources that depend on other resources are taken offline before, and are brought back online after, the resources on which they depend.

See also: failover policy; node; offline; possible owner; server cluster

failover policy

Parameters that an administrator can set, using Cluster Administrator, that affect failover operations.

See also: Cluster Administrator; failover

FAT

See definition for: file allocation table (FAT)

FAT32

A derivative of the file allocation table (FAT) file system. FAT32 supports smaller cluster sizes and larger volumes than FAT, which results in more efficient space allocation on FAT32 volumes.

See also: file allocation table (FAT)

fault tolerance

The ability of computer hardware or software to ensure data integrity when hardware failures occur. Fault-tolerant features appear in many server operating systems and include mirrored volumes, RAID-5 volumes, and server clusters.

See also: cluster; mirrored volume; RAID-5 volume

Fax Service

A system service that provides fax services to local and remote network clients. Fax services include receiving faxes and faxing documents, fax wizard messages, and e-mail messages.

See also: service

FCB

See definition for: file control block (FCB)

Federal Information Processing Standard (FIPS)

A standard entitled Security Requirements for Cryptographic Modules. FIPS 140-1 (1994) and FIPS 140-2 (2001) describe government requirements for hardware and software cryptomodules used in the U.S. government.

See also: cryptography

FEK

See definition for: file encryption key (FEK)

FEP

See definition for: front-end processor (FEP)

file allocation table (FAT)

A file system used by MS-DOS and other Windows operating systems to organize and manage files. The file allocation table is a data structure that Windows creates when you format a volume by using FAT or FAT32 file systems. Windows stores information about each file in the file allocation table so that it can retrieve the file later.

See also: FAT32; file system; NTFS file system

file control block (FCB)

A small block of memory temporarily assigned by a computer's operating system to hold information about a file that has been opened for use. An FCB typically contains such information as the file's identification, its location on disk, and a pointer that marks the user's current (or last) position in the file.

file creator

A four-character sequence that identifies which program was used to create a file. With Services for Macintosh, you can associate file name extensions with file creators and file types to specify which program starts automatically when you open a file with a particular extension.

See also: extension-type association

file encryption key (FEK)

A pseudo-random cryptographic key that Encrypting File System (EFS) uses to encrypt a file. The FEK is encrypted by the public key of the user performing the encryption, and it is typically different for each encrypted file.

See also: Encrypting File System (EFS); encryption; key; public key

file fork

One of two subfiles of a Macintosh file. When Macintosh files are stored on a computer running Services for Macintosh, each fork is stored as a separate file. Each fork can be independently opened by Macintosh users.

File Replication service (FRS)

A service that provides multimaster file replication for designated directory trees between designated servers running Windows Server 2003. The designated directory trees must be on disk partitions formatted with the version of NTFS used with the Windows Server 2003 family. FRS is used by Distributed File System (DFS) to automatically synchronize content between assigned replicas and by Active Directory to automatically synchronize content of the system volume information across domain controllers.

See also: Active Directory; NTFS file system; replica; replication; service

File Server for Macintosh

A service that allows users of Macintosh computers to store, access, and share files on servers running Services for Macintosh. Also called MacFile.

See also: service

file share

In a server cluster, any folder that has an associated File Share resource and is managed by the Cluster service. The file share can fail over from one node to another, but to the end user, the folder looks like a regular folder that remains in one location. Multiple users can access a file share.

See also: cluster; resource; service

File Share resource

A file share accessible by a network path that is supported as a cluster resource by a Resource DLL.

See also: Resource DLL

file system

In an operating system, the overall structure in which files are named, stored, and organized. NTFS, FAT, and FAT32 are types of file systems.

See also: FAT; FAT32; NTFS file system

file system cache

An area of physical memory that holds frequently used pages. It allows applications and services to locate pages rapidly and reduces disk activity.

See also: cache

File Transfer Protocol (FTP)

A member of the TCP/IP suite of protocols, used to copy files between two computers on the Internet. Both computers must support their respective FTP roles: one must be an FTP client and the other an FTP server.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

file type

In the Windows environment, a designation of the operational or structural characteristics of a file. The file type identifies the program, such as Microsoft Word, that is used to open the file. File types are associated with a file name extension. For example, files that have the .txt or .log extension are of the Text Document type and can be opened using any text editor.

In the Macintosh environment, a four-character sequence that identifies the type of a Macintosh file. The Macintosh Finder uses the file type and file creator to determine the appropriate desktop icon for that file.

filter

For Indexing Service, software that extracts content and property values from a document to index them.

For Internet Protocol security (IPSec), a specification of Internet Protocol (IP) traffic that provides the ability to trigger security negotiations for a communication based on the source, destination, and type of IP traffic.

For Internet Information Services (IIS), a feature of Internet Server Application Programming Interface (ISAPI) that allows preprocessing of requests and postprocessing of responses, permitting site-specific handling of Hypertext Transfer Protocol (HTTP) requests and responses.

In IP and Internetwork Packet Exchange (IPX) packet filtering, a definition in a series of definitions that indicates to the router the type of traffic allowed or disallowed on each interface.

See also: Indexing Service; Internet Information Services (IIS); Internet Protocol (IP); Internet Protocol security (IPSec); Internet Server Application Programming Interface (ISAPI); Internetwork Packet Exchange (IPX)

filtering mode

For Network Load Balancing, the method by which network traffic inbound to a cluster is handled by the hosts within the cluster. Traffic can either be handled by a single server, load balanced among the hosts within the cluster, or disabled completely.

See also: cluster; host; load balancing; Network Load Balancing

FIPS

See definition for: Federal Information Processing Standard (FIPS)

firewall

A combination of hardware and software that provides a security system, usually to prevent unauthorized access from outside to an internal network or intranet. A firewall prevents direct communication between network and external computers by routing communication through a proxy server outside the network. The proxy server determines whether it is safe to let a file pass through to the network. Also called a security-edge gateway.

See also: proxy server

Firewire

See definition for: IEEE 1394

firmware

Software routines and low-level input/output instructions stored in read-only memory (ROM). Unlike random-access memory (RAM), read-only memory stays intact even in the absence of electrical power.

See also: random access memory (RAM); read-only memory (ROM)

flexible single-master operations (FSMO)

See definition for: operations master

font

A graphic design applied to a collection of numbers, symbols, and characters. A font describes a certain typeface, along with other qualities such as size, spacing, and pitch.

See also: OpenType fonts; PostScript fonts; screen font; Type 1 fonts

font cartridge

A plug-in unit available for some printers that contains fonts in several styles and sizes. As with downloadable fonts, printers using font cartridges can produce characters in sizes and styles other than those created by the fonts built into it.

See also: downloadable fonts; font

foreground program

The program that runs in the active window (the uppermost window with the highlighted title bar). The foreground program responds to commands issued by the user.

See also: background program; title bar

foreign computer

A computer that uses another message queuing system but, through a connector application, can exchange messages with computers that run Message Queuing.

See also: connector application; Message Queuing

foreign security principal

An object in a domain that represents a security principal that exists in a trusted domain located in a different forest. Foreign security principals are necessary for users in a domain to access resources that exist in a different forest.

See also: domain; forest; object; resource; security principal

forest

One or more Active Directory domains that share the same class and attribute definitions (schema), site and replication information (configuration), and forest-wide search capabilities (global catalog). Domains in the same forest are linked with two-way, transitive trust relationships.

See also: Active Directory; domain; global catalog; schema; transitive trust; two-way trust

forest functionality

The functional level of an Active Directory forest that has one or more domain controllers running Windows Server 2003. The functional level of a forest can be raised to enable new Active Directory features that will apply to every domain in the forest. There are three forest functional levels: Windows 2000, Windows Server 2003 interim, and Windows Server 2003. The default forest functional level is Windows 2000. When the forest functional level is raised to Windows Server 2003 interim or Windows Server 2003, advanced forest-wide Active Directory features are available.

See also: Active Directory; domain; domain controller; forest

forest root domain

The first domain created in a new forest. The forest-wide administrative groups, Enterprise Admins and Schema Admins, are located in this domain. As a best practice, new domains are created as children of the forest root domain.

See also: child domain; domain; domain hierarchy; forest

forest trust

A trust between two Windows Server 2003 forests that forms trust relationships between every domain in both forests. A forest trust can be created only between the forest root domains in each forest. Forest trusts are transitive, and they can be one-way or two-way. An administrator must manually establish a forest trust, unlike an automatically established trust, such as a parent-child trust.

See also: domain; forest; one-way trust; parent-child trust; root domain; transitive trust; trust relationship; two-way trust

form

The specification of physical characteristics such as paper size (that is, letter or legal) and printer area margins of paper or other print media. For example, by default, the Letter form has a paper size of 8.5 inches by 11 inches and does not reserve space for margins.

FORTEZZA

A family of security products including PCMCIA-based cards, compatible serial port devices, combination cards (such as FORTEZZA/Modem and FORTEZZA/Ethernet), server boards, and others. FORTEZZA is a registered trademark held by the U.S. National Security Agency.

See also: serial port

forward lookup

A DNS query for a DNS name.

See also: Domain Name System (DNS)

forwarder

A DNS server designated by other internal DNS servers to be used to forward queries for resolving external or offsite DNS domain names.

See also: DNS server; domain name; Domain Name System (DNS)

FQDN

See definition for: fully qualified domain name (FQDN)

fragmentation

The scattering of parts of the same disk file over different areas of the disk. Fragmentation occurs as files on a disk are deleted and new files are added. It slows disk access and degrades the overall performance of disk operations, although usually not severely.

See also: defragmentation

frame

In synchronous communication, a package of information transmitted as a single unit from one device to another.

See also: capture

frame type

The way in which a network type, such as Ethernet, formats data to be sent over a network. When multiple frame types are allowed for a particular network type, the packets are structured differently and are, therefore, incompatible. All computers on a network must use the same frame type to communicate. Also called frame format.

See also: frame; packet

free media pool

A logical collection of unused data-storage media that can be used by applications or other media pools. When media are no longer needed by an application, they are returned to a free media pool so that they can be used again.

See also: media pool; Removable Storage

free space

Available space that you use to create logical drives within an extended partition.

See also: extended partition; logical drive; unallocated space

front-end processor (FEP)

In communications, a computer that is located between communications lines and a main (host) computer and used to relieve the host of tasks related to communications; sometimes considered synonymous with communications controller. A front-end processor is dedicated entirely to handling transmitted information, including error detection and control; receipt, transmission, and possibly encoding of messages; and management of the lines running to and from other devices.

See also: host

FRS

See definition for: File Replication service (FRS)

FSMO

See definition for: operations master

FTP

See definition for: File Transfer Protocol (FTP)

full computer name

A fully qualified domain name (FQDN). The full computer name is a concatenation of the computer name (for example, client1) and the primary DNS suffix of the computer (for example, reskit.com.). The same computer could be identified by more than one FQDN. However, it has only one full computer name.

See also: DNS suffix; fully qualified domain name (FQDN)

Full Control

An access control entry (ACE) that assigns all applicable rights to a file system or directory service object.

See also: access control entry (ACE); object; permission

full name

A user's complete name, usually consisting of the last name, first name, and middle initial. The full name is information that Local Users and Groups or Active Directory Users and Computers can maintain as part of the information identifying and defining a user account.

See also: Active Directory Users and Computers; user account

full zone transfer (AXFR)

The standard query type supported by all DNS servers to update and synchronize zone data when the zone has been changed. When a DNS query is made using AXFR as the specified query type, the entire zone is transferred as the response.

See also: DNS server; zone

full-duplex

A system capable of simultaneously transmitting information in both directions over a communications channel.

See also: duplex; half-duplex

fully qualified domain name (FQDN)

A DNS name that has been stated to indicate its absolute location in the domain namespace tree. In contrast to relative names, an FQDN has a trailing period (.) to qualify its position to the root of the namespace (host.example.microsoft.com.).

See also: domain name; Domain Name System (DNS); domain namespace; relative name

G

gateway

A dedicated device (or a set of services running on a dedicated computer) that routes network traffic and enables communication between different networking protocols. A gateway is a multiprotocol Internet Protocol (IP) router that translates between different transport protocols or data formats.

See also: device; Internet Protocol (IP)

GDI objects

Objects from the Graphics Device Interface (GDI) library of application programming interfaces (APIs) for graphics output devices. In Task Manager, the number of GDI objects currently used by a process.

See also: application programming interface (API); Task Manager

Generic Application resource

An application that is supported as a cluster resource by a Resource DLL.

See also: Resource DLL

Generic Service resource

A Windows service that is supported as a cluster resource by a Resource DLL.

See also: Resource DLL; service

global account

In an Active Directory network, a normal user account in a user's domain. Most user accounts are global accounts. If there are multiple domains in the network, it is best if each user in the network has only one user account in only one domain, and each user's access to other domains is accomplished through the establishment of domain trust relationships.

In Microsoft Provisioning System, the Exchange server maintains a list of global catalogs, and it maintains a load balance across global catalogs.

See also: Active Directory; domain; global catalog

global catalog

A directory database that applications and clients can query to locate any object in a forest. The global catalog is hosted on one or more domain controllers in the forest. It contains a partial replica of every domain directory partition in the forest. These partial replicas include replicas of every object in the forest, as follows: the attributes most frequently used in search operations and the attributes required to locate a full replica of the object.

In Microsoft Provisioning System, the Exchange server maintains a list of global catalogs, and it maintains a load balance across global catalogs.

See also: Active Directory; attribute; domain controller; forest; replication

global group

A security or distribution group that can contain users, groups, and computers from its own domain as members. Global security groups can be granted rights and permissions for resources in any domain in the forest.

See also: group; local group; member server; permission; user account

globally unique identifier (GUID)

A 16-byte value generated from the unique identifier on a device, the current date and time, and a sequence number. A GUID is used to identify a particular device or component.

See also: device

glue chasing

In DNS, queries to resolve delegation name server (NS) resource records that do not have corresponding glue address (A) resource records in the same zone.

See also: address (A) resource record; delegation; Domain Name System (DNS); glue record; name server (NS) resource record; zone

glue record

In DNS, a delegation resource record used for locating the authoritative DNS servers for a delegated zone. These records are used to glue zones together and provide an effective delegation and referral path for other DNS servers to follow when resolving a name.

See also: authoritative; delegation; DNS server; Domain Name System (DNS); glue chasing; resource record (RR); zone

GPMC

See definition for: Group Policy Management console (GPMC)

GPO

See definition for: Group Policy object (GPO)

GPO link

See definition for: Group Policy object link

GPT

See definition for: GUID partition table (GPT)

graphics mode

A display mode in which lines and characters on the screen are drawn pixel by pixel. Graphics mode displays images by grouping individual dots into shapes, such as the arrowhead of a mouse pointer. It can also preview character formatting, such as boldface and italics, as it will appear in print.

See also: character mode

gratuitous ARP

An Address Resolution Protocol (ARP) Request frame sent by a host for the host's own Internet Protocol version 4 (IPv4) address when the TCP/IP protocol obtains addressing information. Gratuitous ARPs are used to check for duplicate IPv4 addresses on the subnet. If the host receives a reply to the gratuitous ARP request from another host or computer, it detects a conflict for its configured IPv4 address and will not use it.

See also: Address Resolution Protocol (ARP); frame; host; IP address; subnet

group

A collection of users, computers, contacts, and other groups. Groups can be used as security or as e-mail distribution collections. Distribution groups are used only for e-mail. Security groups are used both to grant access to resources and as e-mail distribution lists.

See also: domain; global group; local group

group account

A collection of user accounts. By making a user account a member of a group, you give the related user all the rights and permissions granted to the group.

See also: group; user account

group memberships

The groups to which a user account belongs. Permissions and rights granted to a group are also provided to its members. In most cases, the actions a user can perform in Windows are determined by the group memberships of the user account to which the user is logged on.

See also: group; user account

Group Policy

The infrastructure within Active Directory directory service that enables directory-based change and configuration management of user and computer settings, including security and user data. You use Group Policy to define configurations for groups of users and computers. With Group Policy, you can specify policy settings for registry-based policies, security, software installation, scripts, folder redirection, remote installation services, and Internet Explorer maintenance. The Group Policy settings that you create are contained in a Group Policy object (GPO). By associating a GPO with selected Active Directory system containers—sites, domains, and organizational units—you can apply the GPO's policy settings to the users and computers in those Active Directory containers. To create an individual GPO, use the Group Policy Object Editor. To manage Group Policy objects across an enterprise, you can use the Group Policy Management console.

See also: Active Directory; Group Policy Management console (GPMC); Group Policy object (GPO); Group Policy Object Editor; Group Policy object link

Group Policy Management console (GPMC)

An optional tool that unifies and centralizes administration of Group Policy.

See also: Group Policy

Group Policy object (GPO)

A collection of Group Policy settings. GPOs are essentially the documents created by the Group Policy Object Editor. GPOs are stored at the domain level, and they affect users and computers that are contained in sites, domains, and organizational units. In addition, each computer has exactly one group of policy settings stored locally, called the local Group Policy object.

See also: Group Policy; Group Policy Management console (GPMC); Group Policy Object Editor; Group Policy object link

Group Policy Object Editor

The Microsoft Management Console (MMC) snap-in that is used to edit Group Policy objects (GPOs).

See also: Group Policy Management console (GPMC); Group Policy object (GPO); Group Policy object link; Microsoft Management Console (MMC)

Group Policy object link

A method of applying settings in a Group Policy object (GPO) to an Active Directory container (site, domain, or organizational unit). Linking a GPO applies the settings of that GPO to the users and computers in a site, domain, or organizational unit and, by default, to the users and computers in all child containers.

See also: Active Directory; Group Policy Management console (GPMC); Group Policy object (GPO); inheritance; precedence

Group Policy Security Settings

The subtrees of the Group Policy Object Editor that allow a security administrator to manually configure security levels assigned to a Group Policy object (GPO) or local computer policy.

See also: Group Policy object (GPO); Group Policy Object Editor

guest

A user who does not have a user account or who does not provide a password.

See also: password; user account

Guest account

A built-in account used to log on to a computer running Windows when a user does not have an account on the computer or domain or in any of the domains trusted by the computer's domain.

See also: domain; user account

GUI mode

The portion of Setup that uses a graphical user interface (GUI).

See also: Setup; text mode

GUID

See definition for: globally unique identifier (GUID)

GUID partition table (GPT)

A disk-partitioning scheme that is used by the Extensible Firmware Interface (EFI) in Itanium-based computers. GPT offers more advantages than master boot record (MBR) partitioning because it allows up to 128 partitions per disk, provides support for volumes up to 18 exabytes in size, allows primary and backup partition tables for redundancy, and supports unique disk and partition IDs (GUIDs).

See also: Extensible Firmware Interface (EFI); Itanium; master boot record (MBR)

H

H.323

The International Telecommunication Union - Telecommunication (ITU-T) standard for packet-based multimedia communications.

See also: International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T); packet

half-duplex

A system capable of transmitting information in only one direction at a time over a communications channel.

See also: duplex; full-duplex

handle

In the user interface, an interface added to an object that facilitates moving, sizing, reshaping, or other functions pertaining to an object. In programming, a pointer to a pointer, that is, a token that lets a program access an identified resource.

handle count

In Task Manager, the number of object handles in a process's object table.

See also: Task Manager

handshaking

A series of signals acknowledging that communication can take place between computers or other devices. A hardware handshake is an exchange of signals over specific wires (other than the data wires), in which each device indicates its readiness to send or receive data. A software handshake consists of signals transmitted over the same wires used to transfer data, as in modem-to-modem communications over telephone lines.

See also: device; modem (modulator/demodulator)

Hardware Compatibility List (HCL)

A hardware list that Microsoft compiled for specific products, including Windows 2000 and earlier versions of Windows. The list for a specific product, such as Windows 2000, includes the hardware devices and computer systems that are compatible with that version of the product. For products in the Windows Server 2003 family, you can find the equivalent information on the Windows Catalog Web site.

See also: device; Windows Catalog

hardware compression

A feature available on some tape devices that automatically compresses the data that is being stored on the device. This is usually an option that is turned on or off in a backup program.

See also: backup; device

hardware configuration

Resource settings that have been allocated for a specific device. Each device on your computer has a hardware configuration, which can consist of interrupt request (IRQ) lines, direct memory access (DMA), an input/output (I/O) port, or memory address settings.

See also: device; direct memory access (DMA); input/output (I/O) port; interrupt request (IRQ) lines; memory address

hardware decoder

A type of digital video disc (DVD) decoder that allows a DVD drive to display movies on your computer screen. A hardware decoder uses both software and hardware to display movies.

See also: DVD decoder; DVD drive; software decoder

hardware profile

Data that describes the configuration and characteristics of specific computer equipment. This information can be used to configure computers for using peripheral devices.

See also: device

hardware type

A classification for similar devices. For example, Imaging Device is a hardware type for digital cameras and scanners.

See also: device

hash

A fixed-size result that is obtained by applying a one-way mathematical function (sometimes called a hash algorithm) to an arbitrary amount of data. If there is a change in the input data, the hash changes. The hash can be used in many operations, including authentication and digital signing. Also called a message digest.

See also: authentication; hash algorithm

hash algorithm

An algorithm that produces a hash value of some piece of data, such as a message or session key. With a good hash algorithm, changes in the input data can change every bit in the resulting hash value; for this reason, hashes are useful in detecting any modification in a data object, such as a message. Furthermore, a good hash algorithm makes it computationally infeasible to construct two independent inputs that have the same hash. Typical hash algorithms include MD2, MD4, MD5, and SHA-1. Also called a hash function.

See also: Hash-based Message Authentication Mode (HMAC); MD2; MD4; MD5; message digest; Secure Hash Algorithm (SHA-1)

Hash-based Message Authentication Mode (HMAC)

A mechanism for message authentication using cryptographic hash functions. HMAC can be used with any iterative cryptographic hash function (for example, MD5 and SHA-1) in combination with a secret shared key. The cryptographic strength of HMAC depends on the properties of the underlying hash function.

See also: hash algorithm; MD5; Secure Hash Algorithm (SHA-1)

HCL

See definition for: Hardware Compatibility List (HCL)

header error control (HEC)

The fifth byte in the asynchronous transfer mode (ATM) cell header used to detect and correct errors in the ATM header.

See also: asynchronous transfer mode (ATM)

headless server

See definition for: remotely administered server

heartbeat

A message that is sent at regular intervals by one computer on a Network Load Balancing cluster or server cluster to another computer within the cluster to detect communication failures.

See also: Network Load Balancing; Network Load Balancing cluster; server cluster

HEC

See definition for: header error control (HEC)

heterogeneous environment

An internetwork with servers and workstations running different operating systems, such as Microsoft Windows, Apple Macintosh, or Novell NetWare, using a mix of different transport protocols.

See also: protocol; server

hexadecimal

A base-16 number system represented by the digits 0 through 9 and the uppercase or lowercase letters A (equivalent to decimal 10) through F (equivalent to decimal 15).

high availability

For server clusters, the restarting of a failed application or the dispersion of the work to remaining computers when a computer or application in the server cluster fails.

See also: server cluster

histogram

A chart consisting of horizontal or vertical bars, the widths or heights of which represent the values of certain data.

hive

A file in which the system stores a portion of the registry (named for their resemblance to the cellular structure of a beehive). A hive is backed by a single file and a .log file, which are in either the systemroot\System32\Config folder or the systemroot\Profiles\username folder.

By default, most hive files (Default, SAM, Security, and System) are stored in the systemroot\System32\Config folder. The systemroot\Profiles folder contains the user profile for each user of the computer. Because a hive is a file, it can be moved from one system to another. However, you must use the Registry Editor, Regedit.exe, to edit the file.

See also: key; registry; systemroot

HMAC

See definition for: Hash-based Message Authentication Mode (HMAC)

home folder

A folder (usually on a file server) that administrators can assign to individual users or groups. Administrators use home folders to consolidate user files onto specific file servers for easy backup. Home folders are used by some programs as the default folder for the Open and Save As dialog boxes. Sometimes referred to as home directories.

See also: group

hop count

The value in the Transport Control field that indicates the number of Internetwork Packet Exchange (IPX) routers that have processed the IPX packet.

See also: Internetwork Packet Exchange (IPX); packet; router

host

Any device on a TCP/IP network that has an Internet Protocol (IP) address. Examples of hosts include servers, workstations, network-interface print devices, and routers. Sometimes used to refer to a specific network computer that is running a service used by network or remote clients.

For Network Load Balancing, a cluster consists of multiple hosts connected over a local area network (LAN).

See also: client; cluster; local area network (LAN); Network Load Balancing; server; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

host domain

The domain in which a DFS namespace has been configured.

See also: DFS namespace; domain

host ID

The portion of the IP address that identifies a computer within a particular network ID.

See also: IP address

host name

The DNS name of a device on a network. These names are used to locate computers on the network. To find another computer, its host name must either appear in the Hosts file or be known by a DNS server. For most Windows-based computers, the host name and the computer name are the same.

See also: DNS server; Domain Name System (DNS)

host priority

For Network Load Balancing, a host's precedence for handling default network traffic for TCP and UDP ports. It is used if a host within the cluster goes offline, and it determines which host within the cluster will assume responsibility for the traffic previously handled by the offline host.

See also: cluster; host; Network Load Balancing; User Datagram Protocol (UDP)

host server

The server on which a root target is located.

See also: root; root target; server

Hosts file

A local text file in the same format as the 4.3 Berkeley Software Distribution (BSD) UNIX /etc/hosts file. This file maps host names to IP addresses, and it is stored in the \%Systemroot%\System32\Drivers\Etc folder.

See also: systemroot

HTML

See definition for: Hypertext Markup Language (HTML)

HTTP

See definition for: Hypertext Transfer Protocol (HTTP)

HTTPS

See definition for: Secure Hypertext Transfer Protocol

hub

A common connection point for devices in a network. Typically used to connect segments of a local area network (LAN), a hub contains multiple ports. When data arrives at one port, it is copied to the other ports so that all segments of the LAN can see the data.

See also: local area network (LAN); port; switching hub

hubbed mode

A mode in which the Address Resolution Protocol/multicast address resolution service (ARP/MARS) provides asynchronous transfer mode (ATM) addresses to requesting clients in the form of a multicast server (MCS) list value. In this mode, ARP/MARS acts as a multicast server, providing active forwarding of all multicast and broadcast traffic destined for IP addresses contained within the ranges specified in the list.

See also: Address Resolution Protocol (ARP); asynchronous transfer mode (ATM); IP address; multicast address resolution service (MARS); multicast server (MCS); nonhubbed mode

hue

The position of a color along the color spectrum. For example, green is between yellow and blue. This attribute can be set using Display in Control Panel.

See also: saturation

Hypertext Markup Language (HTML)

A simple markup language used to create hypertext documents that are portable from one platform to another. HTML files are simple ASCII text files with codes embedded (indicated by markup tags) to denote formatting and hypertext links.

See also: American Standard Code for Information Interchange (ASCII)

Hypertext Transfer Protocol (HTTP)

The protocol used to transfer information on the World Wide Web. An HTTP address (one kind of Uniform Resource Locator (URL)) takes the following form: http://www.microsoft.com.

See also: protocol

I

IAS

See definition for: Internet Authentication Service (IAS)

ICMP

See definition for: Internet Control Message Protocol (ICMP)

IDE

See definition for: integrated device electronics (IDE)

identity

A person or entity that must be verified by means of authentication, based on criteria such as a password or a certificate.

See also: authentication; certificate; password

IEEE

Institute of Electrical and Electronics Engineers, founded in 1963. IEEE is an organization composed of engineers, scientists, and students, best known for developing standards for the computer and electronics industry.

IEEE 1394

A standard for high-speed serial devices such as digital video and digital audio editing equipment.

See also: device

IETF

See definition for: Internet Engineering Task Force (IETF)

IGMP

See definition for: Internet Group Management Protocol (IGMP)

IIS

See definition for: Internet Information Services (IIS)

IIS Server Instance resource

A server-instance designation used with Internet Information Services (IIS) that supports the WWW and FTP services. IIS server instances are supported as cluster resources by a Resource DLL. IIS Server Instance resources can have dependencies on IP Address resources, Network Name resources, and Physical Disk resources. Access information for server instances does not fail over.

See also: dependency; failover; Internet Information Services (IIS); Resource DLL

IKE

See definition for: Internet Key Exchange (IKE)

ILMI

See definition for: integrated local management interface (ILMI)

Image Name

The name of a process as displayed in Task Manager.

See also: Task Manager

impersonation

A circumstance that occurs when Windows allows one process to take on the security attributes of another.

See also: attribute; security

impersonation token

An access token that captures the security information of a client process, allowing a service to "impersonate" the client process in security operations.

See also: access token

import media pool

A logical collection of data-storage media that has not been cataloged by Removable Storage. Media in an import media pool is cataloged as soon as possible so that they can be used by an application.

See also: media pool; Removable Storage

in-addr.arpa domain

A special top-level DNS domain reserved for reverse mapping of IP addresses to DNS host names.

See also: Domain Name System (DNS); reverse lookup; top-level domains

in-band connection

A connection between two computers that relies on a standard network, such as a local area network (LAN) or the Internet, and standard remote administration tools, such as Remote Desktop or Telnet. An in-band connection can only be used to manage computers remotely if both the local and remote computers are in a functional state and accessible on the network.

See also: local area network (LAN); out-of-band connection; Telnet

Incoming Forest Trust Builders group

A group whose members can create incoming, one-way forest trusts to the forest-root domain. For example, members of this group residing in forest A can create a one-way incoming forest trust from forest B. This one-way incoming forest trust allows users in forest A to access resources that are located in forest B. Members of this group are assigned the permission Create Inbound Forest Trust on the forest-root domain. This group has no default members.

See also: forest; forest root domain; forest trust; group; one-way trust; permission; resource

incremental backup

A backup that copies only those files created or changed since the last normal or incremental backup. It marks files as having been backed up (in other words, the archive attribute is cleared). If you use a combination of normal and incremental backups to restore your data, you will need to have the last normal backup and all incremental backup sets.

See also: copy backup; daily backup; differential backup; normal backup

incremental zone transfer (IXFR)

In DNS, a zone transfer request involving only incremental resource record changes between each version of the zone. An IXFR contrasts with a full zone transfer (AXFR) request for all resource records.

See also: DNS server; Domain Name System (DNS); full zone transfer (AXFR); zone; zone transfer

independent client

A computer with Message Queuing installed that can host queues and store messages locally. Independent clients do not require synchronous access to a Message Queuing server to send and receive messages, but they can use Message Queuing servers with routing enabled for efficient message routing.

See also: dependent client; Message Queuing server; routing services

Indexing Service

Software that provides search functions for documents stored on disk, allowing users to search for specific document text or properties.

infrared (IR)

Light that is beyond red in the color spectrum. While the light is not visible to the human eye, infrared transmitters and receivers can send and receive infrared signals.

See also: Infrared Data Association (IrDA); infrared device; infrared port

Infrared Data Association (IrDA)

The industry organization of computer, component, and telecommunications vendors who establish the standards for infrared communication between computers and peripheral devices, such as printers.

See also: infrared (IR)

infrared device

A computer, or a computer peripheral such as a printer, that can communicate by using infrared light.

See also: infrared (IR)

infrared file transfer

Wireless file transfer between a computer and another computer or device using infrared light.

See also: infrared (IR)

infrared network connection

A direct or incoming network connection to a remote access server using an infrared port.

See also: infrared port; remote access server

infrared port

An optical port on a computer that enables communication with other computers or devices by using infrared light, without cables. Infrared ports can be found on some portable computers, printers, and cameras.

See also: infrared (IR); infrared device; port

infrastructure master

A domain controller that holds the infrastructure operations master role in Active Directory. The infrastructure master updates the group-to-user reference whenever group memberships change and replicates these changes across the domain. At any time, the infrastructure master role can be assigned to only one domain controller in each domain.

See also: Active Directory; domain controller; operations master

inheritance

In security, a mechanism that allows a specific access control entry (ACE) to be copied from the container where it was applied to all children of the container. Inheritance can be used to manage access to a whole subtree of objects in a single update operation.

In Active Directory, the ability to build new object classes from existing object classes. The new object is defined as a subclass of the original object class. The original object class becomes a superclass of the new object. A subclass inherits the attributes of the superclass, including structure rules and content rules.

In Group Policy, a mechanism that allows policy settings in Group Policy objects (GPOs) that are linked to parent containers to be applied to objects in child containers.

See also: access control entry (ACE); Active Directory; block inheritance; delegation; Enforce; Group Policy Management console (GPMC); Group Policy object (GPO); object class; precedence

inherited permissions

Permissions on an object that are automatically inherited from its parent object. Inherited permissions cannot be modified.

See also: object; parent object; permission

initialize

In Disk Management, the process of detecting a disk or volume and assigning it a status (for example, healthy) and a type (for example, dynamic).

See also: basic disk; basic volume; dynamic disk; dynamic volume

Input language

A Regional and Language Options setting that specifies the combination of the language entered and the keyboard layout, Input Method Editor (IME), speech-to-text converter, or other device used to enter it. Formerly known as input locale.

See also: Input Method Editor (IME)

Input Method Editor (IME)

A program used to enter the thousands of different characters in written Asian languages with a standard 101-key keyboard. An IME consists of both an engine that converts keystrokes into phonetic and ideographic characters and a dictionary of commonly used ideographic words. As the user enters keystrokes, the IME engine attempts to identify which character or characters that the keystrokes should be converted into.

input/output (I/O) port

A channel through which data is transferred between a device and the microprocessor. The port appears to the microprocessor as one or more memory addresses that it can use to send or receive data.

See also: device; memory address; port

install

When referring to software, to add program files and folders to your hard disk and related data to your registry so that the software runs properly. Installing contrasts with upgrading, where existing program files, folders, and registry entries are updated to a more recent version.

When referring to hardware, to physically connect the device to your computer, to load device drivers onto your computer, and to configure device properties and settings.

See also: device driver; registry; uninstall; upgrade

integrated device electronics (IDE)

A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

integrated local management interface (ILMI)

A limited set of Simple Network Management Protocol (SNMP) functions included in the asynchronous transfer mode (ATM) specification for the ATM user network interface (UNI).

See also: asynchronous transfer mode (ATM); Simple Network Management Protocol (SNMP); user-to-network interface (UNI)

Integrated Services Digital Network (ISDN)

A digital phone line used to provide higher bandwidth. ISDN in North America is typically available in two forms: Basic Rate Interface (BRI) consists of 2 B-channels at 64 kilobits per second (Kbps) and a D-channel at 16 Kbps; Primary Rate Interface (PRI) consists of 23 B-channels at 64 Kbps and a D-channel at 64 Kbps. An ISDN line must be installed by the phone company at both the calling site and the called site.

See also: B-channel; D-channel; multilink dialing; Service Profile Identifier (SPID); switch type

Integrated Services over Slow Links (ISSLOW)

A queuing mechanism used to optimize slow (low-capacity) network interfaces by reducing latency. In particular, it is designed for interfaces that forward traffic to modem links, Integrated Services Digital Network (ISDN) B-channels, and sub-T1 links.

See also: B-channel; Integrated Services Digital Network (ISDN)

Integrated Windows authentication

A configuration setting that enables negotiation of authentication protocols in Internet Information Services (IIS).

See also: authentication protocol; Internet Information Services (IIS)

IntelliMirror

A set of change and configuration management features based on Active Directory that enables management of user and computer data and settings, including security data. IntelliMirror also provides limited ability to deploy software to Windows 2000 and later workstations or servers.

See also: Active Directory

interactive dialog box

A dialog box that requires a response from the user. Intermediary devices such as a security host require such a dialog box as an added layer of security between the client and the remote access server. In such dialog boxes, the user types an access code or a user name and password on the remote access terminal screen.

See also: intermediary device; remote access server; static dialog box

interactive logon

A local logon process to a computer, when the user types information in the Log On to Windows dialog box that is displayed by the computer's operating system or inserts a smart card.

See also: smart card

interconnect

A private network that connects nodes in a cluster.

See also: cluster; node

intermediary device

A device other than a modem or X.25 PAD, located between a network connection and the remote access server. This device is typically a modem-pool switch or security host and requires either a static or interactive dialog box between the client and itself.

See also: interactive dialog box; PAD (packet assembler/disassembler); remote access server; static dialog box

internal network number

A 4-byte hexadecimal number used for addressing and routing purposes. The internal network number identifies a virtual network inside a computer. The internal network number must be unique to the IPX internetwork. Also called virtual network number.

See also: external network number; Internetwork Packet Exchange (IPX)

internal private queue

For Message Queuing, a queue that stores various types of administrative messages, or an interim queue for storing and forwarding messages in transit to a destination queue. Internal private queues are not displayed in Microsoft Management Console (MMC) snap-ins, and they cannot be deleted.

See also: Message Queuing; private queue; queue

internal router

A router for which all the networks that it is connected to belong in the same area.

See also: router

international prefix

Digits dialed before the country code to access the international phone service. The actual digits depend on the country or region in which you are dialing an international number. For example, in the United States of America, the prefix for international dialing is 011. To dial from the United States of America to Honduras, which has the country code 504, you would dial: (011) (504) (000) 000-0000

International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T)

The sector of the International Telecommunication Union (ITU) responsible for telecommunication standards. ITU-T replaces the Comite Consultatif International Telegraphique et Telephonique (CCITT). Its responsibilities include standardizing modem design and operations, and standardizing protocols for networks and facsimile transmission. ITU is an international organization within which governments and the private sector coordinate global telecom networks and services.

internet

internet. Two or more network segments connected by routers. Another term for internetwork.

Internet. A worldwide network of computers. If you have access to the Internet, you can retrieve information from millions of sources, including schools, governments, businesses, and individuals.

See also: World Wide Web

Internet address

An address for a resource on the Internet that is used by Web browsers to locate Internet resources. An Internet address typically starts with a protocol name, followed by the name of the organization that maintains the site; the suffix identifies the kind of organization it is. For example, the address http://www.yale.edu/ provides the following information:

  • http: This Web server uses the Hypertext Transfer Protocol.
  • www: This site is on the World Wide Web.
  • edu: This is an educational institution.
Internet address is also called Uniform Resource Locator (URL).

See also: protocol; Web server

Internet Authentication Service (IAS)

The Microsoft implementation of a Remote Authentication Dial-In User Service (RADIUS) server and proxy, which provides authentication and accounting for network access.

See also: authentication; Certificate Services; Remote Access Service (RAS); Remote Authentication Dial-In User Service (RADIUS); service; virtual private network (VPN)

Internet Control Message Protocol (ICMP)

A required maintenance protocol in the TCP/IP suite that reports errors and allows simple connectivity. ICMP is used by the Ping tool to perform TCP/IP troubleshooting.

See also: Internet Protocol (IP); protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet Engineering Task Force (IETF)

An open community of network designers, operators, vendors, and researchers concerned with the evolution of Internet architecture and the smooth operation of the Internet. Technical work is performed by working groups organized by topic areas (such as routing, transport, and security) and through mailing lists. Internet standards are developed in IETF Requests for Comments (RFCs), which are a series of notes that discuss many aspects of computing and computer communication, focusing on networking protocols, programs, and concepts.

See also: Request for Comments (RFC)

Internet Group Management Protocol (IGMP)

A protocol used by Internet Protocol version 4 (IPv4) hosts to report their multicast group memberships to any immediately neighboring multicast routers.

See also: Internet Protocol multicasting; Multicast Listener Discovery (MLD); protocol

Internet group name

A name known by a DNS service that includes a list of the specific addresses of systems that have registered the name.

See also: Domain Name System (DNS)

Internet Information Services (IIS)

Software services that support Web site creation, configuration, and management, along with other Internet functions. Internet Information Services include Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP).

See also: File Transfer Protocol (FTP); Network News Transfer Protocol (NNTP); Simple Mail Transfer Protocol (SMTP)

Internet Key Exchange (IKE)

A protocol that establishes the security association and shared keys necessary for two parties to communicate by using Internet Protocol security (IPSec).

See also: Internet Protocol security (IPSec); protocol

Internet Printing Protocol (IPP)

The protocol that uses the Hypertext Transfer Protocol (HTTP) to send print jobs to printers throughout the world. Windows 2000, Windows XP, and the Windows Server 2003 family support Internet Printing Protocol (IPP) version 1.0.

See also: protocol

Internet Protocol (IP)

A routable protocol in the TCP/IP protocol suite that is responsible for IP addressing, routing, and the fragmentation and reassembly of IP packets.

See also: Compression Control Protocol (CCP); packet; Transmission Control Protocol/Internet Protocol (TCP/IP); voluntary tunnel

Internet Protocol multicasting

The extension of local area network multicasting technology to a TCP/IP network. Hosts send and receive multicast datagrams, the destination fields of which specify IP host group addresses rather than individual IP addresses. A host indicates that it is a member of a group by means of the Internet Group Management Protocol (IGMP).

See also: Internet Group Management Protocol (IGMP); Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet Protocol security (IPSec)

A set of industry-standard, cryptography-based protection services and protocols. IPSec protects all protocols in the TCP/IP protocol suite and Internet communications by using Layer Two Tunneling Protocol (L2TP).

See also: Layer Two Tunneling Protocol (L2TP); protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet Server Application Programming Interface (ISAPI)

An application programming interface (API) that resides on a server computer for initiating software services tuned for Windows operating systems.

In Microsoft Provisioning System, ISAPI resides on the Web server.

See also: application programming interface (API)

Internet service provider (ISP)

A company that provides individuals or companies access to the Internet and the World Wide Web. An ISP provides a telephone number, a user name, a password, and other connection information so users can connect their computers to the ISP's computers. An ISP typically charges a monthly or hourly connection fee.

See also: Web server

Internetwork Packet Exchange (IPX)

A network protocol native to NetWare that controls addressing and routing of packets within and between local area networks (LANs). IPX does not guarantee that a message will be complete (no lost packets).

See also: Compression Control Protocol (CCP); Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX); local area network (LAN); Routing Information Protocol over IPX (RIPX)

Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX)

Transport protocols used in Novell NetWare networks, which together correspond to the combination of TCP and IP in the TCP/IP protocol suite. Windows implements IPX through NWLink.

See also: Internetwork Packet Exchange (IPX); NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink); Transmission Control Protocol/Internet Protocol (TCP/IP)

interrupt

A request for attention from the processor. When the processor receives an interrupt, it suspends its current operations, saves the status of its work, and transfers control to a special routine known as an interrupt handler, which contains the instructions for dealing with the particular situation that caused the interrupt.

See also: interrupt request (IRQ)

interrupt request (IRQ)

A signal sent by a device to get the attention of the processor when the device is ready to accept or send information. Each device sends its interrupt requests over a specific hardware line. Each device must be assigned a unique IRQ number.

See also: interrupt

interrupt request (IRQ) lines

Hardware lines over which devices can send signals to get the attention of the processor when the device is ready to accept or send information. Each device must have a unique IRQ line.

See also: device; interrupt request (IRQ)

intersite messaging service (ISM)

A service that supports transports for asynchronous, site-to-site messaging. Each transport serves two major roles: send/receive and topology queries (such as, what are the various sites connected by this transport, and at what cost?). The intersite messaging services shipped in Windows are remote procedure call (RPC) and Simple Mail Transfer Protocol (SMTP) (mail).

See also: remote procedure call (RPC); service; Simple Mail Transfer Protocol (SMTP)

intersite replication

In Active Directory, the replication of directory partition updates between sites. Intersite replication occurs between bridgehead servers that store the same domain or application directory partition. One bridgehead server per domain or application directory partition and per replication transport is designated automatically in each site. If two sites have no domains or application directory partitions in common, a bridgehead server in each site replicates both the configuration and schema directory partitions between the two sites.

See also: Active Directory; bridgehead server; directory partition; intrasite replication; replication; site

Intersite Topology Generator

An Active Directory process that runs on one domain controller in a site that considers the cost of intersite connections, checks if previously available domain controllers are no longer available, and checks if new domain controllers have been added. The Knowledge Consistency Checker (KCC) process then updates the intersite replication topology accordingly.

See also: Active Directory; domain controller; Knowledge Consistency Checker (KCC); replication topology; site

intrasite replication

In Active Directory, the replication of directory partition updates that occurs between two or more domain controllers that store the same domain or application directory partition and that reside within the same site.

See also: Active Directory; directory partition; domain controller; intersite replication; site

IP

See definition for: Internet Protocol (IP)

IP address

For Internet Protocol version 4 (IPv4), a 32-bit address used to identify a node on an IPv4 internetwork. Each node on the IP internetwork must be assigned a unique IPv4 address, which is made up of the network ID, plus a unique host ID. This address is typically represented with the decimal value of each octet separated by a period (for example, 192.168.7.27). You can configure the IP address statically or dynamically by using Dynamic Host Configuration Protocol (DHCP).

For Internet Protocol version 6 (IPv6), an identifier that is assigned at the IPv6 layer to an interface or set of interfaces and that can be used as the source or destination of IPv6 packets.

See also: Dynamic Host Configuration Protocol (DHCP); Internet Protocol (IP); node; scope

IP Address resource

A 32-bit number in dotted decimal format that represents an Internet Protocol (IP) address and is supported as a cluster resource by a Resource DLL provided with Windows.

See also: IP address; Resource DLL

IPP

See definition for: Internet Printing Protocol (IPP)

IPSec

See definition for: Internet Protocol security (IPSec)

IPSec policy

Configuration policy that defines which traffic Internet Protocol security (IPSec) examines, how that traffic is secured and encrypted, and how IPSec peers are authenticated.

See also: authentication; encryption; Internet Protocol security (IPSec); policy

IPX/SPX

See definition for: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX)

IR

See definition for: infrared (IR)

IrDA

See definition for: Infrared Data Association (IrDA)

IRQ

See definition for: interrupt request (IRQ)

ISAPI

See definition for: Internet Server Application Programming Interface (ISAPI)

ISDN

See definition for: Integrated Services Digital Network (ISDN)

ISM

See definition for: intersite messaging service (ISM)

ISP

See definition for: Internet service provider (ISP)

Itanium

An Intel microprocessor that uses explicitly parallel instruction set computing and 64-bit memory addressing.

Itanium-based refers to systems or platforms that are based on the Itanium processor. Itanium 2-based refers to systems or platforms that are based on the Itanium 2 processor. Itanium architecture-based refers to systems or platforms that are based on the Itanium and Itanium 2 processors.

iteration

See definition for: iterative query

iterative query

A query made to a DNS server for the best answer the server can provide without seeking further help from other DNS servers. Also called a nonrecursive query.

See also: DNS server; Domain Name System (DNS); recursive query; referral

ITU-T

See definition for: International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T)

IXFR

See definition for: incremental zone transfer (IXFR)

J

job object

A system-level structure that allows processes to be grouped together and managed as a single unit.

See also: process

journal

For Message Queuing, a queue where journal messages are stored.

See also: journal quota; Message Queuing; queue; source journaling; target journaling

journal quota

For Message Queuing, a property that specifies the cumulative limit for journal messages in a journal queue. The limit is based on cumulative journal message size. When a journal queue's quota is reached, messages are no longer stored.

See also: journal; Message Queuing; property

junction point

A physical location on a hard disk that points to data located at another location on your hard disk or another storage device. Junction points are created when you create a mounted drive. You can also create a junction point using the linkd command.

See also: mounted drive

K

KDC

See definition for: Key Distribution Center (KDC)

Kerberos V5 authentication protocol

An authentication mechanism used to verify user or host identity. The Kerberos V5 authentication protocol is the default authentication service. Internet Protocol security (IPSec) can use the Kerberos protocol for authentication.

See also: Internet Protocol security (IPSec); Key Distribution Center (KDC); realm; service ticket; ticket-granting service (TGS); ticket-granting ticket (TGT)

kernel mode

A highly privileged mode of operation where program code has direct access to all memory, including the address spaces of all user-mode processes and applications, and to hardware. Also known as supervisor mode, protected mode, or Ring 0.

key

In Registry Editor, a folder that appears in the left pane of the Registry Editor window. A key can contain subkeys and entries. For example, Environment is a key of HKEY_CURRENT_USER.

In IP security (IPSec), a value used in combination with an algorithm to encrypt or decrypt data. Key settings for IPSec are configurable to provide greater security.

See also: entry; Internet Protocol security (IPSec); registry; subkey

Key Distribution Center (KDC)

A network service that supplies session tickets and temporary session keys used in the Kerberos V5 authentication protocol.

See also: Kerberos V5 authentication protocol; ticket-granting service (TGS); ticket-granting ticket (TGT)

keyboard layout

The arrangement that accommodates the special characters and symbols used in different languages. Keyboard layouts affect which characters appear when you press the keys on your keyboard. After you change your keyboard layout, the characters that appear on your screen may no longer correspond to the characters that are printed on your keyboard keys.

Knowledge Consistency Checker (KCC)

A built-in process that runs on all domain controllers and generates the replication topology for the Active Directory forest. At specified intervals, the KCC reviews and makes modifications to the replication topology to ensure propagation of data either directly or transitively.

See also: Active Directory; domain controller; forest; replication topology

L

L2TP

See definition for: Layer Two Tunneling Protocol (L2TP)

label

In DNS, each part of a DNS domain name that represents a node in the domain namespace tree. For example, the three labels example, microsoft, and com make up the DNS domain name example.microsoft.com. Each label used in a DNS name cannot exceed 63 octets, 255 bytes including the terminating dot, for the fully qualified domain name (FQDN).

See also: domain name; Domain Name System (DNS); fully qualified domain name (FQDN); node

LAN

See definition for: local area network (LAN)

LAN emulation (LANE)

A group of software components that allows asynchronous transfer mode (ATM) to work with legacy networks and applications. With LANE, you can run your traditional local area network (LAN)-aware applications and protocols on an ATM network without modification. LANE makes the ATM protocol layers appear to be an Ethernet or Token Ring LAN to overlying protocols and applications. LANE provides an intermediate step between fully exploiting ATM and not using ATM at all.

See also: asynchronous transfer mode (ATM); local area network (LAN); protocol; Token Ring

LAN emulation client (LEC)

The client on an emulated local area network (ELAN) that performs data forwarding, address resolution, and other control functions. The LEC resides on end stations in an ELAN.

See also: client; emulated local area network (ELAN); LAN emulation (LANE)

LAN emulation configuration server

The service that assigns individual local area network emulation (LANE) clients to particular emulated local area networks (ELANs) by directing them to the LAN emulation server (LES).

See also: emulated local area network (ELAN); LAN emulation (LANE); LAN emulation server (LES); service

LAN emulation server (LES)

The central control point for an emulated local area network (ELAN). LES enables LAN emulation (LANE) clients to join the ELAN, and it resolves local area network (LAN) addresses to asynchronous transfer mode (ATM) addresses.

See also: asynchronous transfer mode (ATM); emulated local area network (ELAN); LAN emulation (LANE); local area network (LAN)

LANE

See definition for: LAN emulation (LANE)

Last Known Good Configuration

A hardware configuration that is available by pressing F8 during startup. If the current hardware settings prevent the computer from starting, Last Known Good Configuration can allow you to start the computer and examine the configuration. When Last Known Good Configuration is used, later configuration changes are lost.

See also: Safe Mode

latency

In Active Directory replication, the delay between the time an update is applied to a given replica and the time it is applied to some other replica. Sometimes referred to as propagation delay.

See also: Active Directory; replica; replication

Layer Two Tunneling Protocol (L2TP)

An industry-standard Internet tunneling protocol that provides encapsulation for sending Point-to-Point Protocol (PPP) frames across packet-oriented media. For IP networks, L2TP traffic is sent as User Datagram Protocol (UDP) messages. In Microsoft operating systems, L2TP is used in conjunction with Internet Protocol security (IPSec) as a virtual private network (VPN) technology to provide remote access or router-to-router VPN connections. L2TP is described in RFC 2661.

See also: frame; Internet Protocol security (IPSec); Point-to-Point Protocol (PPP); tunnel; User Datagram Protocol (UDP)

Layer Two Tunneling Protocol/Internet Protocol security (L2TP/IPSec)

A virtual private network (VPN) connection method that provides session authentication, address encapsulation, and strong encryption of private data between remote access servers and clients. L2TP provides address encapsulation and user authentication, and Internet Protocol security (IPSec) provides computer authentication and encryption of the L2TP session.

See also: authentication; encapsulation; encryption; Internet Protocol security (IPSec); Layer Two Tunneling Protocol (L2TP); virtual private network (VPN)

LDAP

See definition for: Lightweight Directory Access Protocol (LDAP)

LDAP Data Interchange Format (LDIF)

A draft Internet standard for a file format that can be used to perform batch operations on directories that conform to Lightweight Directory Access Protocol (LDAP) standards.

See also: batch program; Lightweight Directory Access Protocol (LDAP)

LDIF

See definition for: LDAP Data Interchange Format (LDIF)

lease

The length of time for which a DHCP client can use a dynamically assigned IP address configuration. Before the lease time expires, the client must either renew or obtain a new lease with DHCP.

See also: DHCP client; Dynamic Host Configuration Protocol (DHCP); IP address

LEC

See definition for: LAN emulation client (LEC)

LES

See definition for: LAN emulation server (LES)

library

A data-storage system, usually managed by Removable Storage. A library consists of removable media (such as tapes or discs) and a hardware device that can read from or write to the media. There are two major types of libraries: robotic libraries (automated multiple-media, multidrive devices) and stand-alone drive libraries (manually operated, single-drive devices). A robotic library is also called a jukebox or changer.

See also: Removable Storage

Lightweight Directory Access Protocol (LDAP)

The primary access protocol for Active Directory. LDAP is an industry-standard protocol, established by the Internet Engineering Task Force (IETF), that allows users to query and update information in a directory service. Active Directory supports both LDAP version 2 and LDAP version 3.

See also: Active Directory; directory service; Internet Engineering Task Force (IETF); protocol

Line Printer Daemon (LPD)

A service on a print server that receives print jobs from Line Printer Remote (LPR) tools that are running on client computers.

See also: Line Printer Remote (LPR); print job; print server; service

Line Printer Remote (LPR)

A connectivity tool that runs on client computers and that is used to print files to a computer running a Line Printer Daemon (LPD) server.

See also: Line Printer Daemon (LPD)

link state database

A map of an area maintained by Open Shortest Path First (OSPF) routers. It is updated after any change in the network topology. The link state database is used to compute Internet Protocol (IP) routes, which must be computed again after any change in the topology.

See also: adjacency; Internet Protocol (IP); Open Shortest Path First (OSPF)

linked object

An object that is inserted into a document but still exists in the source file. When information is linked, the new document is updated automatically if the information in the original document changes. If you want to edit the linked information, double-click it. The toolbars and menus from the original program will appear. If the original document is on your computer, changes that you make to the linked information will also appear in the original document.

See also: embedded object; OLE; package; source document

LIS

See definition for: logical IP subnet (LIS)

Lmhosts file

A local text file that maps network basic input/output (NetBIOS) names (commonly used for computer names) to IP addresses for hosts that are not located on the local subnet. In this version of Windows, this file is stored in the systemroot\System32\Drivers\Etc folder.

See also: host; IP address; network basic input/output system (NetBIOS); systemroot

load balancing

A technique used by Windows Clustering to scale the performance of a server-based program (such as a Web server) by distributing its client requests across multiple servers within the cluster. Each host can specify the load percentage that it will handle, or the load can be equally distributed across all the hosts. If a host fails, Windows Clustering dynamically redistributes the load among the remaining hosts.

See also: cluster; host

load weight

A Network Load Balancing parameter that specifies the relative amount of load-balanced network traffic that the host handles for the associated port rule. Allowed values range from 0 (zero) to 100. To prevent a host from handling any network traffic, set the load weight to 0 (zero).

See also: Network Load Balancing; Network Load Balancing cluster

local area network (LAN)

A communications network connecting a group of computers, printers, and other devices located within a relatively limited area (for example, a building). A LAN enables any connected device to interact with any other on the network.

See also: NetBIOS Extended User Interface (NetBEUI); network basic input/output system (NetBIOS); virtual local area network (VLAN); workgroup

local computer

The computer that you are currently logged on to as a user. More generally, a local computer is a computer that you can access directly without using a communications line or a communications device, such as a network adapter or a modem.

See also: remote computer

local group

A security group that can be granted rights and permissions on only resources on the computer on which the group is created. Local groups can have any user accounts that are local to the computer as members, as well as users, groups, and computers from a domain to which the computer belongs.

See also: global group; member server; user account

local printer

A printer that is directly connected to one of the ports on a computer.

See also: port

Local Security Authority (LSA)

A protected subsystem that authenticates and logs users on to the local computer. In addition, the LSA maintains information about all aspects of local security on a computer (collectively known as the local security policy), and it provides various services for translation between names and identifiers.

See also: security

local security policy

Security information about all aspects of local security on a computer. The local security policy identifies who is assigned privileges and what security auditing is to be performed.

See also: auditing; security

local service

A service that performs a specific operating system function for other local processes on the computer.

See also: service

Local Service account

A predefined local account that is used to start a service and provide the security context for that service. The name of the account is NT AUTHORITY\LocalService. The Local Service account has limited access to the local computer and Anonymous access to network resources.

See also: access control list (ACL); Local System account; Network Service account; service

local storage

For the Windows Server 2003 family, NTFS file system disk volumes used as primary data storage. Such disk volumes can be managed by Remote Storage by copying infrequently accessed files to remote (secondary) storage.

See also: NTFS file system; Remote Storage; volume

Local System account

A predefined local account that is used to start a service and provide the security context for that service. The name of the account is NT AUTHORITY\System. This account does not have a password, and any password information that you supply is ignored. The Local System account has full access to the system, including the directory service on domain controllers. Because the Local System account acts as a computer on the network, it has access to network resources.

See also: directory service; domain controller; Local Service account; Network Service account; service

local user profile

A computer-based record about an authorized user that is created automatically on the computer the first time a user logs on to a workstation or server computer.

LocalTalk

The Apple networking hardware built into every Macintosh computer. LocalTalk includes the cables and connector boxes that connect components and network devices that are part of the AppleTalk network system. Formerly known as AppleTalk Personal Network.

log file

A file that stores messages generated by an application, service, or operating system. These messages are used to track the operations performed. For example, Web servers maintain log files listing every request made to the server. Log files are usually plain text (ASCII) files and often have a .log extension.

In Backup, a file that contains a record of the date the tapes were created and the names of files and directories successfully backed up and restored. The Performance Logs and Alerts service also creates log files.

See also: American Standard Code for Information Interchange (ASCII); service

logical drive

A volume that you create within an extended partition on a basic master boot record (MBR) disk. Logical drives are similar to primary partitions, except that you are limited to four primary partitions per disk, whereas you can create an unlimited number of logical drives per disk. A logical drive can be formatted and assigned a drive letter.

See also: basic disk; basic volume; drive letter; extended partition; master boot record (MBR); primary partition; volume

logical IP subnet (LIS)

A group of Internet Protocol (IP) hosts that belong to the same IP subnet.

See also: host; Internet Protocol (IP); subnet

logical printer

The software interface between the operating system and the printer in Windows. While a printer is the device that does the actual printing, a logical printer is its software interface on the print server. This software interface determines how a print job is processed and how it is routed to its destination (to a local or network port, to a file, or to a remote print share). When you print a document, it is spooled (or stored) on the logical printer before it is sent to the printer itself.

See also: printer; spooling

logon event category

In auditing, a group of events that are logged when a user attempts to log on to or log off from a computer.

See also: auditing; event

logon rights

User rights that are assigned to a user and that specify the ways in which a user can log on to a system. An example of a logon right is the right to log on to a system remotely.

See also: user rights

logon script

A file, typically a batch file, that runs automatically every time a user logs on to a computer or network. It can be used to configure a user's working environment whenever a user logs on, and it allows an administrator to influence a user's environment without managing all aspects of it. A logon script can be assigned to one or more user accounts.

See also: batch program; logon script path; user account

logon script path

A sequence of directory names that specifies the location of the logon script. When a user logs on, the authenticating computer locates the specified logon script (if one has been assigned to that user account) by following that computer's local logon script path (usually systemroot\System32\Repl\Import\Scripts).

See also: logon script; systemroot; user account

long distance operator

Digits dialed before the area or city code to access a long distance phone service. For example, in the United States of America, you dial a 1 before the area or city code: (1) (206) 000-0000. The actual digits depend on the country/region or phone service. Area codes and long distance operators are not used in all countries/regions.

long name

A folder name or file name longer than the 8.3 file name standard (up to eight characters followed by a period and an extension of up to three characters) of the file allocation table (FAT) file system. This version of Windows supports file names up to 255 characters and automatically translates long names of files and folders to 8.3 names for MS-DOS and Windows 3.x users. In a Macintosh environment, users can assign names up to 31 characters, excluding colons, to files and folders.

See also: file allocation table (FAT); MS-DOS (Microsoft Disk Operating System)

loopback

An advanced Group Policy setting that is useful in certain closely managed environments, such as laboratories, classrooms, public kiosks, and reception areas. You can find the setting and its description in the Group Policy console tree under Computer Configuration\Administrative Templates\System\Group Policy. The full name of this setting is User Group Policy loopback processing mode.

See also: console tree; Group Policy

loose name checking

A form of domain name checking DNS uses that examines characters in DNS names for valid American National Standards Institute (ANSI) character compliance. However, loose name checking does not check for compliance with DNS naming requirements and valid character usage for Internet host names, as specified in RFC 1123, Requirements for Internet Hosts - Applications and Support.

For RFC compliance, DNS domain names will use name labels made up only of valid uppercase and lowercase letters, number characters, and hyphens (A through Z, a through z, 0 through 9, and -) separated by periods.

See also: domain name; Domain Name System (DNS); label; Request for Comments (RFC)

LPD

See definition for: Line Printer Daemon (LPD)

LPR

See definition for: Line Printer Remote (LPR)

luminosity

The brightness of a color based on a scale from black to white on your monitor.

M

machine-centric

A service model that requires specific computers and services be used to complete a task. If a user must connect to a specific computer to access a service, then that service is considered machine-centric.

See also: service; service-centric

Macintosh-accessible volume

Storage space on the server used for folders and files of Macintosh users. A Macintosh-accessible volume is equivalent to a shared folder for Windows users. Each Macintosh-accessible volume on a computer running Services for Macintosh will correspond to a folder. Both Windows users and Macintosh users can be given access to files located in a folder that is designated as both a shared folder and a Macintosh-accessible volume.

See also: shared folder; volume

Macintosh-style permissions

Folder and volume permissions that are similar to the access privileges used on a Macintosh.

See also: permission; privilege; volume

MADCAP

See definition for: Multicast Address Dynamic Client Allocation Protocol (MADCAP)

majority node set server cluster

A cluster configuration that has two or more nodes and that is configured so that the nodes may or may not be attached to one or more cluster storage devices. The cluster configuration data is stored on multiple disks across the cluster, and the Cluster service makes sure that this data is kept consistent across the different disks. There are advantages and limitations for each cluster configuration (single node server cluster, single quorum device server cluster, and majority node set server cluster).

See also: cluster; cluster storage; node; single node server cluster; single quorum device server cluster

Make Changes

The Macintosh-style privilege that allows you to change the contents of folders for which you have this privilege. If you have the Make Changes privilege, you can modify, rename, move, create, and delete files in folders for which you have that privilege. When Services for Macintosh translates Macintosh-style privileges into Windows permissions, you are granted Write and Delete permissions for any folders for which you have the Make Changes privilege.

See also: privilege

malicious program

Any program that is created to do intentional harm to or compromise the security of a computer. Examples of malicious programs include trojan horses and computer viruses.

See also: Trojan horse; virus

malicious user

A person who has legitimate access to a system and poses a security threat to it, such as someone who tries to elevate their user rights to gain access to unauthorized data.

See also: security; user rights

man-in-the-middle attack

A security attack in which an attacker intercepts and possibly modifies data that is transmitted between two users. The attacker pretends to be the other person to each user. In a successful man-in-the-middle attack, the users are unaware that there is an attacker between them, intercepting and modifying their data. Also referred to as a bucket brigade attack.

See also: security

managed volume

A local NTFS file system 5.0 volume whose disk space is managed by Remote Storage. Remote Storage frees up disk space by automatically moving infrequently accessed files to a remote storage device.

See also: local storage; NTFS file system; Remote Storage; volume

Management and Monitoring Tools

Software components that include utilities for network management and monitoring, along with services that support client dialing and the updating of client phone books. Also included is the Simple Network Management Protocol (SNMP).

See also: Simple Network Management Protocol (SNMP)

management information base (MIB)

A set of objects that represent various types of information about a device, used by Simple Network Management Protocol (SNMP) to manage the device. Because different network management services are used for different types of devices and protocols, each service has its own set of objects.

See also: service; Simple Network Management Protocol (SNMP)

management system

A network-enabled host running Simple Network Management Protocol (SNMP) management software. This software requests information from SNMP agents. Also called a management console.

See also: host; Simple Network Management Protocol (SNMP)

mandatory user profile

A user profile that is not updated when the user logs off. It is downloaded to the user's desktop each time the user logs on, and it is created by an administrator and assigned to one or more users to create consistent or job-specific user profiles. Only members of the Administrators group can change profiles.

See also: roaming user profile; user profile

map

To translate one value into another. In virtual memory systems, a computer might map a virtual address into a physical address.

See also: virtual memory

MAPI

See definition for: Messaging API (MAPI)

MARS

See definition for: multicast address resolution service (MARS)

master boot record (MBR)

The first sector on a hard disk, which begins the process of starting the computer. The MBR contains the partition table for the disk and a small amount of executable code called the master boot code.

See also: partition boot sector; Recovery Console

master file table (MFT)

An NTFS system file on NTFS-formatted volumes that contains information about each file and folder on the volume. The MFT is the first file on an NTFS volume.

See also: file allocation table (FAT); NTFS file system; volume

master server

An authoritative DNS server for a zone. Master servers can vary and are one of two types (either primary or secondary masters), depending on how the server obtains its zone data.

See also: authoritative; DNS server; primary master; zone; zone transfer

maximize

To enlarge a window to its largest size by clicking the Maximize button (at the right of the title bar), or by pressing ALT+SPACEBAR and then pressing X.

See also: minimize; title bar

maximum password age

The period of time a password can be used before the system requires the user to change it.

See also: password

MBR

See definition for: master boot record (MBR)

MCS

See definition for: multicast server (MCS)

MD2

A hash algorithm that creates a 128-bit hash value and was developed by RSA Data Security, Inc.

See also: hash algorithm

MD4

A hash algorithm that creates a 128-bit hash value and was developed by RSA Data Security, Inc.

See also: hash algorithm

MD5

An industry-standard one-way, 128-bit hashing scheme, developed by RSA Data Security, Inc., and used by various Point-to-Point Protocol (PPP) vendors for encrypted authentication. A hashing scheme is a method for transforming data (for example, a password) in such a way that the result is unique and cannot be changed back to its original form. The Challenge Handshake Authentication Protocol (CHAP) uses challenge-response with one-way MD5 hashing on the response. In this way, you can prove to the server that you know your password without actually sending the password over the network.

See also: Challenge Handshake Authentication Protocol (CHAP); hash algorithm; MD5; message digest

media

Any fixed or removable objects that store computer data. Examples include hard disks, floppy disks, tapes, and compact discs.

media access control (MAC) address

The address that is used for communication between network adapters on the same subnet. Each network adapter has an associated MAC address.

See also: multicast media access control (MAC) address; network adapter; subnet

media master

The original set of files that are copied to a tape or disk from local storage. Remote Storage can make up to three copies of the media master on different storage media. Each copy of the media master is called a copy set.

See also: copy set; media; Remote Storage

media pool

A logical collection of removable media that have the same management policies. Media pools are used by applications to control access to specific tapes or discs within libraries managed by Removable Storage.

See also: backup media pool; media; Removable Storage

media sensing

A feature that, when it detects a network cable connection failure, removes the bound protocols from the failed network adapter until the cable connection is reestablished. Without these bound protocols, the network interface connected through the failed network adapter is not available for cluster communication.

See also: network adapter; protocol

member server

A server that is joined to a domain but is not a domain controller. Member servers typically function as file servers, application servers, database servers, Web servers, certificate servers, firewalls, or remote access servers.

See also: domain; domain controller; stand-alone server; Web server

memory address

A portion of computer memory that can be allocated to a device or used by a program or the operating system. Devices are usually allocated a range of memory addresses.

See also: device

Memory Usage

In Task Manager, the current working set of a process, in kilobytes. The current working set is the number of pages currently resident in memory. On the Task Manager Processes tab, the column heading is Mem Usage.

See also: Task Manager

Memory Usage Delta

In Task Manager, the change in memory, in kilobytes, used since the last update.

See also: Task Manager

message

For Message Queuing, a unit of information sent between computers running Message Queuing. The message can contain text or binary data as defined by the sending application. All messages, including status messages, are stored in queues on Message Queuing computers.

See also: Message Queuing

Message Authentication Code (MAC)

An algorithm that ensures the quality of a block of data.

message digest

See definition for: hash

Message Queuing

A message queuing and routing system for Windows that enables distributed applications running at different times to communicate across heterogeneous networks and with computers that may be offline. Message Queuing provides guaranteed message delivery, efficient routing, security, and priority-based messaging. Formerly known as MSMQ.

See also: Microsoft Distributed Transaction Coordinator (MS DTC); MSMQ

Message Queuing resource

A resource type that can use Message Queuing in a cluster.

See also: cluster; Message Queuing; resource types

Message Queuing server

For Message Queuing (formerly known as MSMQ), a computer that can provide message queuing, routing, and directory services to client computers. Message Queuing servers can be used to:

  • Provide message routing and session concentration for independent clients
  • Provide message routing between sites over routing links
  • Create queues and store messages for dependent clients
  • Access information in Active Directory (if installed on a Windows domain controller)

See also: Active Directory; dependent client; independent client; MSMQ; routing link; routing services; session concentration

Messaging API (MAPI)

The application programming interface (API) for which Active Directory provides support for backward compatibility with Microsoft Exchange applications. New applications should use Active Directory Service Interfaces (ADSI) for accessing Active Directory.

See also: Active Directory; Active Directory Service Interfaces (ADSI); application programming interface (API)

Messenger service

A service that sends and receives messages sent by administrators or by the Alerter service.

See also: Alerter service; performance alert; service

metadata

Data about data. For example, the title, subject, author, and size of a file constitute the file's metadata.

metric

A number used to indicate the cost of a route in the Internet Protocol (IP) routing table that enables the selection of the best route among possible multiple routes to the same destination.

See also: Internet Protocol (IP); routing

MFT

See definition for: master file table (MFT)

MIB

See definition for: management information base (MIB)

Microcom Networking Protocol Five (MNP5)

A data-compression standard that allows modems to increase throughput by compressing data before transmission. Data can be compressed with a ratio of up to 2:1. MNP5 sometimes expands data that has already been compressed, resulting in poorer performance in those cases. If you have an MNP5 modem, do not turn on modem compression and software compression at the same time. To turn on MNP5 compression, you must also turn on MNP4 error control.

See also: Microcom Networking Protocol Four (MNP4)

Microcom Networking Protocol Four (MNP4)

An industry-standard communication protocol that allows modems to automatically retransmit corrupted data, assuring that only error-free data passes through the modem. MNP2 and MNP3 standards are included in MNP4.

See also: Microcom Networking Protocol Five (MNP5)

Microsoft Distributed Transaction Coordinator (MS DTC)

A transaction manager that coordinates transactions that span multiple resource managers, such as Message Queuing and Microsoft SQL Server. MS DTC is automatically installed when Message Queuing is installed.

See also: Message Queuing; transaction

Microsoft Management Console (MMC)

A framework for hosting administrative tools called snap-ins. A console might contain tools, folders or other containers, World Wide Web pages, and other administrative items. These items are displayed in the left pane of the console, called a console tree. A console has one or more windows that can provide views of the console tree. The main MMC window provides commands and tools for authoring consoles. The authoring features of MMC and the console tree itself might be hidden when a console is in User Mode.

See also: console tree; details pane; snap-in

Microsoft Point-to-Point Encryption (MPPE)

A 128-bit key or 40-bit key encryption algorithm using RSA RC4. MPPE provides for packet confidentiality between the remote access client and the remote access or tunnel server, and it is useful where Internet Protocol security (IPSec) is not available. MPPE 40-bit keys are used to satisfy current North American export restrictions. MPPE is compatible with Network Address Translation.

See also: remote access server; tunnel server

Microsoft Reserved (MSR) partition

A required partition on every GUID partition table (GPT) disk. System components can allocate portions of the MSR partition into new partitions for their own use. For example, when you convert a basic GPT disk to dynamic, the system allocates a portion of the MSR partition to be used as the Logical Disk Manager (LDM) metadata partition. The MSR partition varies in size based on the size of the GPT disk. For disks smaller than 16 GB, the MSR partition is 32 MB. For disks larger than 16 GB, the MSR partition is 128 MB. The MSR partition is not visible in Disk Management, and you cannot store data on the MSR partition or delete it.

See also: GUID partition table (GPT); partition

MIDI

See definition for: Musical Instrument Digital Interface (MIDI)

MIDI setup

The setup that specifies the type of Musical Instrument Digital Interface (MIDI) device you are using, the channel and patch settings needed to play MIDI files, and the port your device is using.

See also: Musical Instrument Digital Interface (MIDI)

minimize

To reduce a window to a button on the taskbar by clicking the Minimize button (at the right of the title bar), or by pressing ALT+SPACEBAR and then pressing N.

See also: maximize; title bar

minimum password length

The fewest characters a password can contain.

See also: password

minimum TTL

In DNS, a default Time to Live (TTL) value that is set in seconds and used with all resource records in a zone. This value is set in the start of authority (SOA) resource record for each zone. By default, the DNS server includes this value in query responses. It is used to inform recipients how long they can store and use resource records, which are provided in the query answer, before they must expire the stored records data. When TTL values are set for individual resource records, those values override the minimum TTL.

See also: DNS server; Domain Name System (DNS); resource record (RR); start-of-authority (SOA) resource record; Time to Live (TTL); zone

mirror

One of the two volumes that make up a mirrored volume. Each mirror of a mirrored volume resides on a different disk. If one mirror becomes unavailable (due to a disk failure, for example), Windows can use the remaining mirror to gain access to the volume's data.

See also: fault tolerance; mirrored volume; volume

mirrored volume

A fault-tolerant volume that duplicates data on two physical disks. A mirrored volume provides data redundancy by using two identical volumes, which are called mirrors, to duplicate the information contained on the volume. A mirror is always located on a different disk. If one of the physical disks fails, the data on the failed disk becomes unavailable, but the system continues to operate in the mirror on the remaining disk. You can create mirrored volumes only on dynamic disks on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems. You cannot extend mirrored volumes.

See also: dynamic disk; dynamic volume; fault tolerance; RAID-5 volume; volume

mixed mode

In a Windows 2000 domain, the default domain mode setting. Mixed mode enables Windows NT-based backup domain controllers to coexist with Windows 2000-based domain controllers. Mixed mode does not support universal groups or the nesting of groups. You can change the domain mode setting to native mode when all Windows NT-based domain controllers are removed from a domain.

In Windows Server 2003 domains, mixed mode is referred to as Windows 2000 mixed, and it is one of three domain functional levels available.

See also: Active Directory; backup domain controller (BDC); domain functionality; native mode; universal group

MMC

See definition for: Microsoft Management Console (MMC)

MNP4

See definition for: Microcom Networking Protocol Four (MNP4)

MNP5

See definition for: Microcom Networking Protocol Five (MNP5)

modem (modulator/demodulator)

A device that enables computer information to be transmitted and received over a telephone line. The transmitting modem translates digital computer data into analog signals that can be carried over a telephone line. The receiving modem translates the analog signals back to digital form.

See also: modem compression; null modem cable; port; Telephony API (TAPI); Waiting for Call

modem compression

A technique used to reduce the number of characters transmitted without losing data content. The transmitting modem compresses the data and the receiving computer or modem decompresses the data back to its original state.

See also: modem (modulator/demodulator)

modulation standards

Protocols that determine how modems convert digital data into analog signals that can be transmitted over telephone lines.

Initially, Bell created modulation standards used in the United States, and the CCITT created international recommendations. The ITU-T (formerly called the CCITT) now makes recommendations generally adopted by modem manufacturers both internationally and in the United States. The ITU-T V series recommendations (such as V.34 and V.90) define data communication over the telephone network. The suffixes -bis and -ter (for example, V.32bis) indicate later versions.

See also: International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T); modem (modulator/demodulator); protocol; V.34; V.90

mount

To place a removable tape or disc into a drive.

See also: dismount; library; mounted drive

mounted drive

A drive attached to an empty folder on an NTFS volume. Mounted drives function the same as any other drive, but are assigned a label or name instead of a drive letter. The mounted drive's name is resolved to a full file system path instead of just a drive letter. Members of the Administrators group can use Disk Management to create mounted drives or reassign drive letters.

See also: drive; mount; NTFS file system; volume

MPPE

See definition for: Microsoft Point-to-Point Encryption (MPPE)

MPR

See definition for: MultiProtocol Routing (MPR)

MS DTC

See definition for: Microsoft Distributed Transaction Coordinator (MS DTC)

MS-DOS (Microsoft Disk Operating System)

An operating system used on all personal computers and compatibles. As with other operating systems, it translates user keyboard input into operations the computer can perform. MS-DOS can be easily accessed by using the command prompt, while MS-DOS-based programs can be accessed through the use of shortcuts on the desktop.

See also: command prompt window; MS-DOS-based program

MS-DOS-based program

A program that is designed to run with MS-DOS and therefore may not be able to take full advantage of all Windows features.

See also: MS-DOS (Microsoft Disk Operating System); program information file (PIF)

MSMQ

The message queuing and routing system for Windows NT 4.0, Windows 95, and Windows 98. For Windows 2000, Windows XP, and the Windows Server 2003 family, this feature is called Message Queuing.

See also: Message Queuing

multibyte

A character set that may consist of both one-byte and two-byte characters. A multibyte-character string may contain a mixture of single-byte and double-byte characters. Windows Server 2003 DNS uses the Unicode Transformation Format 8 (UTF-8) encoding scheme described in RFC 2044 to interpret and transform multibyte characters into single-byte characters of 8-bit length.

See also: Domain Name System (DNS); UCS Transformation Format 8 (UTF-8)

Multicast Address Dynamic Client Allocation Protocol (MADCAP)

An extension to the DHCP protocol standard used to support dynamic assignment and configuration of IP multicast addresses on TCP/IP-based networks.

See also: Dynamic Host Configuration Protocol (DHCP); multicasting; Transmission Control Protocol/Internet Protocol (TCP/IP)

multicast address resolution service (MARS)

A service for resolving multicast IP addresses to the asynchronous transfer mode (ATM) addresses of the clients that have joined that multicast group. MARS can work in conjunction with the multicast server (MCS) and clients to distribute multicast data through point-to-multipoint connections.

See also: asynchronous transfer mode (ATM); IP address; multicast server (MCS); multicasting

multicast datagram

An Internet Protocol (IP) datagram sent to a select multicast group of hosts. Each datagram is sent from a single host source for transmission and delivery to multiple host destinations using the Class D IP address reserved for a specified multicast group.

See also: datagram; host; Internet Protocol (IP); multicasting

Multicast Listener Discovery (MLD)

A protocol used by Internet Protocol version 6 (IPv6) hosts to report their multicast group memberships to any immediately neighboring multicast routers.

See also: multicasting; protocol

multicast media access control (MAC) address

A type of media access control address used by multiple, networked computers to receive the same incoming network frames concurrently. Network Load Balancing uses multicast MAC addresses to efficiently distribute incoming network traffic to cluster hosts.

See also: media access control (MAC) address; multicasting; Network Load Balancing

multicast scope

A range of multicast group IP addresses in the Class D address range that are available to be leased or assigned to multicast DHCP clients by DHCP.

See also: address class; Dynamic Host Configuration Protocol (DHCP); IP address; lease; multicasting

multicast server (MCS)

A service that manages zero or more multicast groups and distributes multicast data sent to it by clients of those multicast groups through point-to-multipoint connections.

See also: multicasting; nonhubbed mode; service

multicasting

The process of sending a message simultaneously to more than one destination on a network.

See also: multicast server (MCS)

multihomed computer

A computer that has multiple network adapters or that has been configured with multiple IP addresses for a single network adapter.

See also: IP address; network adapter; virtual IP address

multilink dialing

The combination of two or more physical communications links' bandwidth into a single logical link to increase your remote access bandwidth and throughput by using remote access Multilink. Based on the Internet Engineering Task Force (IETF) standard RFC 1990, Multilink combines analog modem paths, Integrated Services Digital Network (ISDN) B-channels, and mixed analog and digital communications links on both your client and server computers. This increases your Internet and intranet access speed and decreases the amount of time you are connected to a remote computer.

See also: bandwidth; B-channel; Integrated Services Digital Network (ISDN)

multimaster replication

A replication model in which any domain controller accepts and replicates directory changes. This model differs from single-master replication models, in which one domain controller stores the single modifiable copy of the directory and other domain controllers store backup copies.

See also: domain controller; replication

multimedia streaming

Playing audio and video immediately as it is downloaded from a network, rather than storing it in a file first.

multiple boot

A computer configuration that runs two or more operating systems.

See also: dual boot; startup environment

MultiProtocol Routing (MPR)

A protocol that enables routing over Internet Protocol (IP) and Internetwork Packet Exchange (IPX) networks by connecting local area networks (LANs) or by connecting LANs to wide area networks (WANs).

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); local area network (LAN); wide area network (WAN)

Musical Instrument Digital Interface (MIDI)

A serial interface standard that allows for the connection of music synthesizers, musical instruments, and computers. The MIDI standard is based partly on hardware and partly on a description of the way in which music and sound are encoded and communicated between MIDI devices. The information transmitted between MIDI devices is in a form called a MIDI message, which encodes aspects of sound, such as pitch and volume, as 8-bit bytes of digital information.

MIDI devices can be used for creating, recording, and playing back music. Using MIDI, computers, synthesizers, and sequencers can communicate with each other, either keeping time or actually controlling the music created by other connected equipment.

See also: MIDI setup

My Documents

A folder that provides you with a convenient place to store documents, graphics, or other files you want to access quickly. When you save a file in a program such as WordPad or Paint, the file is automatically saved in My Documents, unless you choose a different folder.

See also: home folder

N

name

The identifier of your computer on the network.

name resolution

The process of having software translate between names that are easy for users to work with and numerical IP addresses, which are difficult for users but necessary for TCP/IP communications. Name resolution can be provided by software components such as DNS or WINS.

See also: Domain Name System (DNS); Transmission Control Protocol/Internet Protocol (TCP/IP); Windows Internet Name Service (WINS)

name resolution service

A service, such as that provided by WINS or DNS, that allows friendly names to be resolved to an address, or other specially defined resource data used to locate network resources of various types and purposes.

See also: Domain Name System (DNS); service; Windows Internet Name Service (WINS)

name server (NS) resource record

A resource record used in a zone to designate the DNS domain names for authoritative DNS servers for the zone.

See also: DNS server; Domain Name System (DNS); resource record (RR); zone

named pipe

A portion of memory that can be used by one process to pass information to another process, so that the output of one is the input of the other. The second process can be local (on the same computer as the first) or remote (on a networked computer).

See also: shared resource

namespace

A naming convention that defines a set of unique names for resources in a network. For DNS, a hierarchical naming structure that identifies each network resource and its place in the hierarchy of the namespace. For WINS, a flat naming structure that identifies each network resource using a single, unique name.

See also: Domain Name System (DNS); Windows Internet Name Service (WINS)

naming context

See definition for: directory partition

NAS

See definition for: network access server (NAS)

native mode

In Windows 2000 domains, the domain mode in which all domain controllers in a domain are running Windows 2000 and a domain administrator has switched the domain operation mode from mixed mode to native mode. Native mode supports universal groups and nesting of groups. In native mode, domain controllers running Windows NT 4.0 or earlier are not supported.

In Windows Server 2003 domains, native mode is referred to as Windows 2000 native, and it is one of three domain functional levels available.

See also: Active Directory; domain functionality; mixed mode; universal group

NCP

See definition for: NetWare Core Protocol

NDIS

See definition for: Network Driver Interface Specification (NDIS)

NDS

See definition for: Novell Directory Services (NDS)

negative caching

In DNS, client caching of failed responses to a query. Negative caching improves the response time for successive queries for the same name.

See also: cache; Domain Name System (DNS)

Net Logon service

A user-mode service that runs in the Windows security subsystem. The Net Logon service passes the user's credentials through a secure channel to the domain database and returns the domain security identifiers and user rights for the user. In addition, the Net Logon service performs a variety of other functions related to the user logon process, such as periodic password updates for computer accounts and domain controller discovery.

See also: user mode; user rights

NetBEUI

See definition for: NetBIOS Extended User Interface (NetBEUI)

NetBIOS

See definition for: network basic input/output system (NetBIOS)

NetBIOS Extended User Interface (NetBEUI)

A network protocol native to Microsoft Networking. It is usually used in small, department-size local area networks (LANs) of 1 to 200 clients. NetBEUI can use Token Ring source routing as its only method of routing. NetBEUI is the Microsoft implementation of the NetBIOS standard.

See also: Compression Control Protocol (CCP); local area network (LAN); network basic input/output system (NetBIOS); protocol; Token Ring

NetBIOS name

A 16-byte name of a process using network basic input/output system (NetBIOS). The NetBIOS name is a name that is recognized by WINS, which maps the name to an IP address.

See also: IP address; network basic input/output system (NetBIOS); Windows Internet Name Service (WINS)

Netdom

A tool that allows management of Windows domains and trust relationships from the command line.

See also: domain; trust relationship

netmask ordering

A method DNS uses to give ordering and preference to IP addresses on the same network when a requesting client queries for a host name that has multiple host address (A) type resource records. This is designed so that the client program will attempt to connect to a host using the closest (and fastest) IP address available.

See also: address (A) resource record; Domain Name System (DNS); host; IP address

NetWare Core Protocol

The file-sharing protocol that governs communications about resources (such as disk and printer), bindery, and Novell Directory Services (NDS) operations between server and client computers on a Novell NetWare network.

See also: bindery; Internetwork Packet Exchange (IPX); Novell Directory Services (NDS); protocol

network access server (NAS)

The device that accepts Point-to-Point Protocol (PPP) connections and places clients on the network that the NAS serves.

See also: Point-to-Point Protocol (PPP)

network adapter

A device that connects your computer to a network. Sometimes called an adapter card or network interface card.

See also: device

network adapter driver

A device driver that works directly with the network adapter, acting as an intermediary between the adapter and the protocol driver.

See also: device driver; network adapter

network address translation (NAT)

An Internet Protocol (IP) translation process that allows a network with private addresses to access information on the Internet.

See also: Internet Protocol (IP)

network administrator

A person responsible for planning, configuring, and managing the day-to-day operation of the network. Also called a system administrator.

See also: administrator

network basic input/output system (NetBIOS)

An application programming interface (API) that can be used by programs on a local area network (LAN). NetBIOS provides programs with a uniform set of commands for requesting the lower-level services required to manage names, conduct sessions, and send datagrams between nodes on a network.

See also: application programming interface (API); basic input/output system (BIOS); datagram; local area network (LAN); node; service

network bridge

A device that connects networks using the same communications protocols so that information can be passed from one network to the other. Also, a device that connects two local area networks (LANs), whether or not they use the same protocols. A network bridge operates at the ISO/OSI data-link layer.

See also: local area network (LAN); protocol

Network Connections

A component you can use to gain access to network resources and functionality, whether you are physically at the network location or in a remote location. By using the Network Connections folder you can create, configure, store, and monitor connections. Formerly called Network and Dial-up Connections or Dial-Up Networking.

Network Control Protocol

A protocol within the Point-to-Point Protocol (PPP) suite that negotiates the parameters of an individual local area network (LAN) protocol such as TCP/IP or Internetwork Packet Exchange (IPX).

See also: Internetwork Packet Exchange (IPX); local area network (LAN); Point-to-Point Protocol (PPP); Transmission Control Protocol/Internet Protocol (TCP/IP)

Network DDE service

A service that provides network transport and security for dynamic data exchange (DDE) conversations.

See also: dynamic data exchange (DDE); service

Network Driver Interface Specification (NDIS)

A Microsoft/3Com specification establishing a common shared interface for Microsoft operating systems to support protocol-independent transport of multiple network transport protocols (such as TCP/IP, NetBEUI, IPX/SPX, and AppleTalk). NDIS allows more than one transport protocol to be bound and to operate simultaneously over a single network adapter.

See also: Internetwork Packet Exchange (IPX); Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX); NetBIOS Extended User Interface (NetBEUI); Transmission Control Protocol/Internet Protocol (TCP/IP)

Network File System (NFS)

A service for distributed computing systems that provides a distributed file system, eliminating the need for keeping multiple copies of files on separate computers.

See also: service

network gateway

A device that connects networks using different communications protocols so that information can be passed from one network to the other. A network gateway both transfers information and converts it to a form that is compatible with the protocols being used by the receiving network.

See also: device; protocol

network ID

A number used to identify the systems that are located on the same physical network bounded by routers. The network ID should be unique to the internetwork.

See also: router

Network Information Service (NIS)

A service for distributed computing systems that provides a distributed database system for common configuration files.

See also: service

Network Load Balancing

A Windows network component that uses a distributed algorithm to load-balance Internet Protocol (IP) traffic across a number of hosts, helping to enhance the scalability and availability of mission-critical, IP-based services, such as Terminal Services, Web services, virtual private networking, and streaming media. It also provides high availability by detecting host failures and automatically redistributing traffic to the surviving hosts.

See also: availability; cluster; host; scalability

Network Load Balancing cluster

Up to 32 Web servers from which Network Load Balancing presents a single IP address to Web clients and among which Network Load Balancing distributes incoming Web requests.

See also: IP address; Network Load Balancing; Web server

network media

The type of physical wiring and lower-layer protocols used for transmitting and receiving packets, for example, Ethernet, Fiber Distributed Data Interface (FDDI), and Token Ring.

See also: packet; protocol; Token Ring

Network Name resource

The name of a device that exists on a network and is supported as a cluster resource by a Resource DLL provided with Windows.

See also: Resource DLL

Network News Transfer Protocol (NNTP)

A member of the TCP/IP suite of protocols used to distribute network news messages to NNTP servers and clients (newsreaders) on the Internet. NNTP is designed so that news articles are stored on a server in a central database, thus enabling a user to select specific items to read.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

network number

In the Macintosh environment, the routing address or range of addresses assigned to the physical network that AppleTalk Phase 2 routers use to direct information to the appropriate network. Also called network range and cable range.

See also: router

network partition

A state in which one or more of the nodes in a cluster cannot communicate with the other cluster nodes.

See also: cluster; node

network place

A folder on a Web server. You can view files and folders on Web servers just as you would view files and folders on network servers. However, when you save a file to a network place, the file is saved on a Web server, not on your computer's hard disk. You can create network places by using the Add Network Place Wizard, which is located in My Network Places. Network places are available only on Web servers that support Web Extender Client (WEC), FrontPage extensions, and Distributed Authoring and Versioning (DAV) protocols.

See also: Web server

Network Service account

A predefined local account that is used to start a service and provide the security context for that service. The name of the account is NT AUTHORITY\NetworkService. The Network Service account has limited access to the local computer and authenticated access (as the computer account) to network resources.

See also: access control list (ACL); Local Service account; Local System account; service

network-to-network interface (NNI)

An interface that defines how switches in a network communicate with each other.

network/bit-masked identifier

An IP address that includes a subnet bit-mask. Active Directory uses the subnet bit-mask to recognize sites and establish how replication of directory information will occur.

See also: Active Directory; IP address; replication; site; subnet

NFS

See definition for: Network File System (NFS)

NIS

See definition for: Network Information Service (NIS)

NNI

See definition for: network-to-network interface (NNI)

NNTP

See definition for: Network News Transfer Protocol (NNTP)

No Override

In Group Policy in the Windows Server 2003 family, to force the Group Policy object (GPO) links of the parent container to take precedence over the GPO links of the child containers. By default, the GPO links that are closest to the user or computer (links to the child container) have higher precedence than GPO links higher up (links to the parent container). Enforcement causes GPOs that are linked in parent containers to take precedence instead. In Group Policy Management console (GPMC), Enforce is used instead of No Override.

See also: block inheritance; Enforce; Group Policy; Group Policy Management console (GPMC); Group Policy object link; inheritance; precedence

node

For tree structures, a location on the tree that can have links to one or more items below it.

For local area networks (LANs), a device that is connected to the network and is capable of communicating with other network devices.

For server clusters, a computer system that is an active or inactive member of a cluster.

See also: local area network (LAN); server cluster

non-Windows

Operating systems that are not Windows-brand operating systems.

nonauthoritative restore

A restore operation performed on an Active Directory domain controller in which the objects in the restored directory are not treated as authoritative. The restored objects are updated with changes held on other domain controllers in the domain.

See also: Active Directory; authoritative restore

noncontainer object

An object that cannot logically contain other objects. For example, a file is a noncontainer object.

See also: container object; object

noncontiguous namespace

A namespace based on different DNS root domain names, such as that of multiple trees in the same forest.

See also: domain name; Domain Name System (DNS); forest; namespace

nonhubbed mode

A mode in which asynchronous transfer mode (ATM) Address Resolution Protocol/multicast address resolution service (ARP/MARS) does not forward multicast and broadcast traffic for multicast group clients. In this mode, the service returns a dynamic listing of ATM hosts currently registered for the multicast group address to requesting clients. Clients then use this list to initiate and establish their own point-to-multipoint virtual connections with each of the members in the multicast list.

See also: Address Resolution Protocol (ARP); asynchronous transfer mode (ATM); hubbed mode; multicast address resolution service (MARS); multicast server (MCS)

nonpaged memory

Memory that cannot be paged to disk. Paging is the moving of infrequently used parts of a program's working memory from random access memory (RAM) to another storage medium, usually the hard disk.

See also: paging file; random access memory (RAM)

nonpaged pool

Operating system memory that is never paged to disk. Paging is the moving of infrequently used parts of a program's working memory from RAM to another storage medium, usually the hard disk. In Task Manager, the amount of memory used by a process, in kilobytes.

See also: paging file; Task Manager

nonrepudiation

A basic security function of cryptography that ensures that a party in a communication cannot falsely deny that a part of the communication occurred. Without nonrepudiation, someone can communicate and then later deny the communication or claim that the communication occurred at a different time.

See also: cryptography

nontransitive trust

A trust relationship in a multiple-domain environment that is restricted to just two domains. For example, if domain A has a nontransitive trust with domain B, and domain B trusts domain C, then there is no trust relationship between domain A and domain C. Nontransitive trusts can be one-way or two-way.

See also: forest; nontransitive trust; one-way trust; trust relationship; two-way trust

normal backup

A backup that copies all selected files and marks each file as having been backed up (in other words, the archive attribute is cleared). With normal backups, you need only the most recent copy of the backup file or tape to restore all of the files. You usually perform a normal backup the first time you create a backup set.

See also: copy backup; daily backup; differential backup; incremental backup

notification area

The area on the taskbar to the right of the taskbar buttons. The notification area displays the time and can also contain shortcuts that provide quick access to programs, such as Volume Control and Power Options. Other shortcuts can appear temporarily, providing information about the status of activities. For example, the printer shortcut icon appears after a document has been sent to the printer and disappears when printing is complete.

See also: taskbar

notify list

A list maintained by the primary master for a zone of other DNS servers that should be notified when zone changes occur. The notify list is made up of IP addresses for DNS servers configured as secondary masters for the zone. When the listed servers are notified of a change to the zone, they will initiate a zone transfer with another DNS server and update the zone.

See also: DNS server; IP address; primary master; zone; zone transfer

Novell Directory Services (NDS)

On networks running Novell NetWare 4.x and higher, a distributed database that maintains information about every resource on the network and that provides access to these resources.

See also: resource

Nslookup

A command-line tool used to diagnose DNS infrastructure.

See also: Domain Name System (DNS)

NTFS file system

An advanced file system that provides performance, security, reliability, and advanced features that are not found in any version of file allocation table (FAT). For example, NTFS guarantees volume consistency by using standard transaction logging and recovery techniques. If a system fails, NTFS uses its log file and checkpoint information to restore the consistency of the file system. NTFS also provides advanced features, such as file and folder permissions, encryption, disk quotas, and compression.

See also: FAT32; file allocation table (FAT); file system

NTFS permissions

The settings that administrators apply to access control entries (ACEs) for managing access to files and folders under the NTFS file system. Take Ownership is an example of an NTFS permission.

See also: access control entry (ACE); access control list (ACL); NTFS file system; permission

NTGATEWAY

A group of NetWare servers. Accounts used to create a gateway must belong to this group.

See also: gateway

NTLM authentication protocol

A challenge/response authentication protocol. The NTLM authentication protocol is supported in Windows 2000, Windows XP, and the Windows Server 2003 family, but it is not the default. It was the default authentication protocol for earlier versions of Windows.

See also: authentication; protocol

null modem cable

Special cabling that eliminates the modem's need for asynchronous communications between two computers over short distances. A null modem cable emulates modem communication.

See also: modem (modulator/demodulator)

null password

See definition for: blank password

NWLink

See definition for: NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

The Microsoft implementation of the Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) protocol used on NetWare networks. NWLink allows connectivity between Windows-based computers and NetWare networks running IPX/SPX. NWLink also provides network basic input/output system (NetBIOS) functionality and the Routing Information Protocol (RIP).

See also: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX); network basic input/output system (NetBIOS); Routing Information Protocol over IPX (RIPX)

O

object

An entity, such as a file, folder, shared folder, printer, or Active Directory object, described by a distinct, named set of attributes. For example, the attributes of a File object include its name, location, and size; the attributes of an Active Directory User object might include the user's first name, last name, and e-mail address.

For OLE and ActiveX, an object can also be any piece of information that can be linked to, or embedded into, another object.

See also: Active Directory; attribute; child object; OLE; parent object

object access event category

In auditing, a group of events that are logged when an object, such as a file or folder, is accessed by means of an action for which auditing has been enabled. For example, object access events might be logged when a file is opened, modified, or deleted.

See also: auditing; event; object

object class

A distinct, named set of attributes that represents a specific type of entity stored in the directory, such as users, printers, or applications. The attributes include data describing the thing that is identified by the directory object. Attributes of a user might include the user's first name, last name, and e-mail address.

See also: attribute; directory; object

object identifier

A number that identifies an object class or attribute. Object identifiers (OIDs) are organized into an industry-wide global hierarchy. An object identifier is represented as a dotted decimal string, such as 1.2.3.4, with each dot representing a new branch in the hierarchy. National registration authorities issue root object identifiers to individuals or organizations, who manage the hierarchy below their root object identifier.

See also: attribute; object class

ODBC

See definition for: Open Database Connectivity (ODBC)

offline

A state that marks a component in a cluster as unavailable. A node in an offline state is either inactive or not running. Resources and groups also have an offline state.

See also: group; node; online; pending; resource

offline mode

For Message Queuing, a condition in which a computer that belongs to a domain is temporarily unable to communicate with a domain controller. This occurs when the computer itself is offline, all domain controllers in the site are offline, or when an attempt is made to access a remote computer and the remote computer is temporarily unable to query a domain controller for authentication.

See also: Message Queuing

OID

See definition for: object identifier

OLE

A way to transfer and share information between applications by pasting information created in one application into a document created in another application, such as a spreadsheet or word processing file.

See also: embedded object; linked object; package

on-disk catalog

Information stored on a local disk drive. The on-disk catalog contains a list of files and folders that have been backed up in a backup set.

See also: backup set; on-media catalog

on-media catalog

Information stored on backup storage media. The on-media catalog contains a list of files and folders that have been backed up in a backup set.

See also: backup set; on-disk catalog

one-way trust

A trust relationship between two domains in which only one of the two domains trusts the other domain. For example, domain A trusts domain B, and domain B does not trust domain A. One-way trusts are often used to enable authenticated access to resource domains.

See also: authentication; domain; trust relationship; two-way trust

online

A state that marks a component in a cluster as available. When a node is online, it is an active member of the cluster and can own and run groups as well as honor cluster database updates, contribute votes to the quorum algorithm, and maintain heartbeats. Resources and groups also have an online state.

See also: cluster; group; heartbeat; node; offline; pending; resource

Open Database Connectivity (ODBC)

An application programming interface (API) that enables database applications to access data from a variety of existing data sources.

See also: application programming interface (API)

Open Shortest Path First (OSPF)

A routing protocol used in medium-sized and large networks. This protocol is more complex than Routing Information Protocol (RIP), but it allows better control and is more efficient in propagation of routing information.

See also: protocol; routing; Routing Information Protocol (RIP)

Open Systems Interconnection (OSI) reference model

A networking model introduced by the International Organization for Standardization (ISO) to promote multi-vendor interoperability. OSI is a seven-layered conceptual model consisting of the application, presentation, session, transport, network, data-link, and physical layers.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

OpenType fonts

Outline fonts that are rendered from line and curve commands, and can be scaled and rotated. OpenType fonts are clear and readable in all sizes and on all output devices supported by Windows. OpenType is an extension of TrueType font technology.

See also: font; TrueType fonts

operations master

A domain controller that has been assigned one or more special roles in an Active Directory domain. The domain controllers assigned these roles perform operations that are single-master (not permitted to occur at different places on the network at the same time). Examples of these operations include resource identifier allocation, schema modification, PDC emulation, adding and removing domains to and from the forest, and tracking changes to security principals across all domains in a forest.

See also: Active Directory; domain controller; domain naming master; infrastructure master; PDC emulator master; schema master

operator

In mathematics and in programming and computer applications, a symbol or other character indicating an operation that acts on one or more elements. You can use the following four operators in standard calculations:

/ divide
* multiply
- subtract
+ add

For Indexing Service, a word or character that specifies a relationship in a query.

See also: Indexing Service

organizational unit

An Active Directory container object used within domains. An organizational unit is a logical container into which users, groups, computers, and other organizational units are placed. It can contain objects only from its parent domain. An organizational unit is the smallest scope to which a Group Policy object (GPO) can be linked, or over which administrative authority can be delegated.

See also: Active Directory; container object; Group Policy object (GPO); parent domain

original equipment manufacturer (OEM)

A company that typically purchases computer components from other manufacturers, uses the components to build a personal computer, preinstalls Windows onto that computer, and then sells the computer to the public.

orphan

A member of a mirrored volume or a RAID-5 volume that has failed due to a severe cause, such as a loss of power or a complete hard-disk head failure. When this happens, the fault-tolerant driver determines that it can no longer use the orphaned member and directs all new reads and writes to the remaining members of the fault-tolerant volume.

See also: fault tolerance; mirrored volume; RAID-5 volume

orphan file

A file that is stored inside My Briefcase and not linked to any file outside My Briefcase. When you update files, the orphan file is not synchronized with any other file.

OS/2

A protected-mode, virtual memory, multitasking operating system for personal computers based on the Intel 80286, 80386, i486, and Pentium processors. OS/2 can run most MS-DOS-based programs and can read all MS-DOS disks.

See also: MS-DOS-based program

OSChooser

The client-side wizard that walks a user through the installation of an operating system or provides access to maintenance and troubleshooting utilities.

See also: client

OSI

See definition for: Open Systems Interconnection (OSI) reference model

OSPF

See definition for: Open Shortest Path First (OSPF)

out-of-band connection

A connection between two computers that relies on a nonstandard network connection, such as a serial port connection, and nonstandard remote administration tools, such as Special Administration Console (SAC). An out-of-band connection is usually used only when a remote computer cannot access a network or is not in a functional state because of hardware or software failure.

See also: in-band connection; remote computer; serial port

owner

In a Windows environment, the person who controls how permissions are set on objects and can grant permissions to others.

In the Macintosh environment, an owner is the user responsible for setting permissions for a folder on a server. A Macintosh user who creates a folder on the server automatically becomes the owner of the folder, and can then transfer ownership to someone else. Each Macintosh-accessible volume on the server also has an owner.

See also: permission

owner category

In the Macintosh environment, the user category to which you assign permissions for the owner of a folder or a Macintosh volume.

See also: permission; volume

P

p-node

A network basic input/output system (NetBIOS) implementation that uses point-to-point communication with a WINS server to resolve names as IP addresses.

See also: IP address; network basic input/output system (NetBIOS); Windows Internet Name Service (WINS)

package

An icon that represents embedded or linked information. That information may consist of a complete file, such as a Paint bitmap, or part of a file, such as a spreadsheet cell. When you choose the package, the application used to create the object either plays the object (for example, a sound file) or opens and displays the object. If you change the original information, linked information is automatically updated. However, you must manually update embedded information.

See also: embedded object; linked object; OLE

packet

An Open Systems Interconnection (OSI) network layer transmission unit that consists of binary information representing both data and a header containing an identification number, source and destination addresses, and error-control data.

See also: Open Systems Interconnection (OSI) reference model

packet filtering

Prevents certain types of network packets from either being sent or received. This can be employed for security reasons (to prevent access from unauthorized users) or to improve performance by disallowing unnecessary packets from going over a slow connection.

See also: packet

packet header

In network protocol communications, a specially reserved field of a defined bit length that is attached to the front of a packet for carry and transfer of control information. When the packet arrives at its destination, the field is then detached and discarded as the packet is processed and disassembled in a corresponding reverse order for each protocol layer.

See also: packet

packet switching

A technology for breaking data into packets and then sending the packets over a network. Each packet has a header containing its source and destination, a sequence number to reassemble the information, a block of data content, and an error-checking code. The data packets may take different routes to their destination, where the original information is reassembled after the packets arrive. The international standard for packet switching networks is X.25.

See also: packet

PAD (packet assembler/disassembler)

A device that connects a non-X.25 device such as a modem to an X.25 packet switching network.

See also: packet

PAE

See definition for: Physical Address Extension (PAE)

page

In virtual memory systems, a unit of data storage that is brought into random access memory (RAM), typically from a hard drive, when a requested item of data is not already in RAM.

See also: virtual memory

page fault

The interrupt that occurs when software attempts to read from or write to a virtual memory location that is marked not present.

In Task Manager, page fault is the number of times data has to be retrieved from disk for a process because it was not found in memory. The page fault value accumulates from the time the process started.

See also: Page Faults Delta; Task Manager; virtual memory

Page Faults Delta

In Task Manager, the change in the number of page faults since the last update.

See also: page fault; Task Manager

page-description language (PDL)

A computer language that describes the arrangement of text and graphics on a printed page.

See also: PostScript; PostScript fonts; Printer Control Language (PCL); Printer Job Language (PJL)

paged pool

The system-allocated virtual memory that has been charged to a process and that can be paged. Paging is the moving of infrequently used parts of a program's working memory from random access memory (RAM) to another storage medium, usually the hard disk.

In Task Manager, the amount of system-allocated virtual memory, in kilobytes, used by a process.

See also: registry size limit (RSL); Task Manager; virtual memory

paging file

A hidden file or files on the hard disk that Windows uses to hold parts of programs and data files that do not fit in memory. The paging file and physical memory, or random access memory (RAM), comprise virtual memory. Windows moves data from the paging file to memory as needed and moves data from memory to the paging file to make room for new data. Also known as a swap file.

See also: Peak Memory Usage; registry size limit (RSL); virtual memory

PAP

See definition for: Password Authentication Protocol (PAP)

paper source

The location (such as Upper Paper Tray or Envelope Feeder) of the paper at the printer.

See also: printer

parallel port

The input/output connector for a parallel interface device. Printers are generally plugged into a parallel port.

See also: port; serial port

parent domain

For DNS and Active Directory, domains that are located in the namespace tree directly above other derivative domain names (child domains). For example, microsoft.com would be the parent domain for example.microsoft.com, a child domain.

See also: Active Directory; child domain; domain; Domain Name System (DNS)

parent object

An object in which another object resides. For example, a folder is a parent object in which a file, or child object, resides. An object can be both a parent and a child object. For example, a subfolder that contains files is both the child of the parent folder and the parent folder of the files.

See also: child object; object

parent-child trust

A trust that is automatically established when a new domain (the child domain) is added, or becomes subordinate, to an existing domain (the parent domain). Parent-child trusts are transitive and two-way.

See also: child domain; parent domain; transitive trust; two-way trust

parity

A calculated value that is used to reconstruct data after a failure. RAID-5 volumes stripe data and parity intermittently across a set of disks. When a disk fails, some server operating systems use the parity information together with the data on good disks to recreate the data on the failed disk.

See also: fault tolerance; RAID-5 volume; striped volume

parity bit

In asynchronous communications, an extra bit used in checking for errors in groups of data bits transferred within or between computer systems. In modem-to-modem communications, a parity bit is often used to check the accuracy with which each character is transmitted.

See also: parity

partition

A portion of a physical disk that functions as though it were a physically separate disk. After you create a partition, you must format it and assign it a drive letter before you can store data on it.

On basic disks, partitions are known as basic volumes, which include primary partitions and logical drives. On dynamic disks, partitions are known as dynamic volumes, which include simple, striped, spanned, mirrored, and RAID-5 volumes.

See also: basic disk; basic volume; drive letter; dynamic volume; extended partition; primary partition; system partition

partition boot sector

A portion of a hard disk partition that contains information about the disk's file system and a short machine language program that loads the Windows operating system.

See also: partition

passport authentication

A user authentication mechanism that uses standard Web technologies to enable single sign-on access to multiple Web resources.

See also: .NET Passport; authentication

password

A security measure used to restrict logon names to user accounts and access to computer systems and resources. A password is a string of characters that must be provided before a logon name or an access is authorized. A password can be made up of letters, numbers, and symbols, and it is case sensitive.

See also: maximum password age; minimum password length; user account

Password Authentication Protocol (PAP)

A simple, plaintext authentication scheme for authenticating Point-to-Point Protocol (PPP) connections. The user name and password are requested by the remote access server and returned by the remote access client in plaintext.

See also: authentication; password; plaintext; Point-to-Point Protocol (PPP); remote access server

password policy

A collection of policy settings that define the password requirements for a Group Policy object (GPO).

See also: Group Policy object (GPO); password

path

A sequence of directory (or folder) names that specifies the location of a directory, file, or folder within the Windows directory tree. Each directory name and file name within the path must be preceded by a backslash (\). For example, to specify the path of a file named Readme.doc located in the Windows directory on drive C, type C:\Windows\Readme.doc.

See also: directory

paused

A state that applies to a node in a cluster. The node is a fully active member in the cluster but cannot accept new resource groups (for example, a resource group cannot fail over or fail back to a paused node). You can administer and maintain a paused node.

See also: cluster; failback; failover; node; offline

PC Card

A removable device, approximately the size of a credit card, that can be plugged into a Personal Computer Memory Card International Association (PCMCIA) slot in a portable computer. PCMCIA devices can include modems, network cards, and hard disk drives.

See also: modem (modulator/demodulator)

PCL

See definition for: Printer Control Language (PCL)

PDC

See definition for: primary domain controller (PDC)

PDC emulator master

A domain controller that holds the PDC emulator operations master role in Active Directory. The PDC emulator services network clients that do not have Active Directory client software installed, and it replicates directory changes to any Windows NT backup domain controllers (BDCs) in the domain.

The PDC emulator handles password authentication requests involving passwords that have recently changed and not yet been replicated throughout the domain. At any time, the PDC emulator master role can be assigned to only one domain controller in each domain.

See also: Active Directory; backup domain controller (BDC); domain controller; operations master; primary domain controller (PDC)

PDL

See definition for: page-description language (PDL)

Peak Memory Usage

In Task Manager, the peak amount of physical memory resident in a process since it started.

See also: Task Manager

pending

A state that refers to a resource in a cluster when the resource is in the process of being brought online or taken offline.

See also: offline; online; resource

Per Device or Per User Licensing

A licensing mode that requires a separate device-based or user-based Client Access License (CAL) for each device or user that accesses a server running Windows Server 2003, regardless of the number of concurrent connections.

See also: client; device; Per Server Licensing

Per Server Licensing

A licensing mode that requires a separate device-based or user-based Client Access License (CAL) for each concurrent connection to a server running Windows Server 2003.

See also: client; device; Per Device or Per User Licensing

performance alert

A feature that detects when a predefined counter value rises above or falls below the configured threshold and notifies a user by means of the Messenger service.

See also: Messenger service

performance counter

In System Monitor, a data item that is associated with a performance object. For each counter selected, System Monitor presents a value corresponding to a particular aspect of the performance that is defined for the performance object.

See also: performance object

performance object

In System Monitor, a logical collection of counters that is associated with a resource or service that can be monitored.

See also: performance counter

performance object instance

In System Monitor, a term used to distinguish between multiple performance objects of the same type on a computer.

See also: performance object

perimeter network

An Internet Protocol (IP) network segment that contains resources, such as Web servers and virtual private network (VPN) servers, that are available to Internet users. Also known as screened subnet or demilitarized zone (DMZ).

See also: Internet Authentication Service (IAS); Internet Protocol (IP); virtual private network (VPN)

permanent virtual circuit (PVC)

A virtual circuit assigned to a preconfigured static route.

See also: static routes

permission

A rule associated with an object to regulate which users can gain access to the object and in what manner. Permissions are assigned or denied by the object's owner.

See also: object; privilege

personal identification number (PIN)

A secret identification code that is used to protect smart cards from misuse. The PIN is similar to a password and is known only to the owner of the card. The smart card can be used only by someone who possesses the smart card and knows the PIN.

See also: smart card

Physical Address Extension (PAE)

A feature of x86-based servers that allows computers running Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition, to support more than 4 gigabytes (GB) of physical memory. Physical Address Extension (PAE) allows up to 64 GB of physical memory to be used as regular 4-kilobyte (KB) pages and expands the number of bits that can be used by the kernel to address physical memory from 32 to 36.

See also: x86

Physical Disk resource

A disk on a cluster storage device. Physical disks are supported as cluster resources by a Resource DLL.

See also: Resource DLL

physical security

The protection of critical data repositories and paths through the use of physical barriers. Physical barriers range in effectiveness and complexity from locked doors to multilayer access control systems involving proof of identity and explicit access permissions.

See also: security

PID

See definition for: process identifier (PID)

PIF

See definition for: program information file (PIF)

ping

A utility that verifies connections to one or more remote hosts. The ping command uses Internet Control Message Protocol (ICMP) echo request and echo reply packets to determine whether a particular Internet Protocol (IP) system on a network is functional. Ping is useful for diagnosing IP network or router failures.

See also: host; Internet Control Message Protocol (ICMP); Internet Protocol (IP); packet

pixel

Short for picture element, one spot in a rectilinear grid of thousands of such spots that form an image produced on the screen by a computer or on paper by a printer. A pixel is the smallest element that display or print hardware and software can manipulate to create letters, numbers, or graphics. Also called a pel.

See also: screen resolution

PJL

See definition for: Printer Job Language (PJL)

PKCS #10

The Certification Request Syntax Standard, developed and maintained by RSA Data Security, Inc.

See also: certificate; Public Key Cryptography Standards (PKCS); Rivest-Shamir-Adleman (RSA) cryptographic algorithms

PKCS #12

Personal Information Exchange Syntax Standard, developed and maintained by RSA Data Security, Inc. This standard primarily provides a format for storing keys or a certificate in a file.

See also: certificate; Public Key Cryptography Standards (PKCS); Rivest-Shamir-Adleman (RSA) cryptographic algorithms

PKCS #7

The Cryptographic Message Syntax Standard. It is a general syntax, developed and maintained by RSA Data Security, Inc., for data to which cryptography may be applied, such as digital signatures and encryption. It also provides a syntax for disseminating certificates or certificate revocation lists.

See also: certificate; certificate revocation list (CRL); encryption; Public Key Cryptography Standards (PKCS)

PKI

See definition for: public key infrastructure (PKI)

plaintext

Data that is not encrypted. Sometimes also called cleartext.

See also: encryption

plotter font

A font created by a series of dots connected by lines. Plotter fonts can be scaled to any size and are most often printed on plotters. Some dot-matrix printers also support plotter fonts.

See also: font

Plug and Play

A set of specifications developed by Intel Corporation that enables a computer to detect and configure a device automatically and install the appropriate device drivers.

See also: universal serial bus (USB)

PNNI

See definition for: private or public network-to-network interface (PNNI)

point of presence (POP)

The local access point for a network provider. Each POP provides a telephone number that allows users to make a local call for access to online services.

point of termination station (POTS)

Basic dial telephone connections to the public switched network, without any added features or functions. Also called plain old telephone service.

Point-to-Point Protocol (PPP)

An industry standard suite of protocols for the use of point-to-point links to transport multiprotocol datagrams. PPP is documented in RFC 1661.

See also: Compression Control Protocol (CCP); remote access; Request for Comments (RFC); Transmission Control Protocol/Internet Protocol (TCP/IP); voluntary tunnel

Point-to-Point Tunneling Protocol (PPTP)

Networking technology that supports multiprotocol virtual private networks (VPNs), enabling remote users to access corporate networks securely across the Internet or other networks by dialing into an Internet service provider (ISP) or by connecting directly to the Internet. PPTP tunnels, or encapsulates, Internet Protocol (IP), Internetwork Packet Exchange (IPX), or NetBIOS Extended User Interface (NetBEUI) traffic inside IP packets. This means that users can remotely run applications that depend on particular network protocols.

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); NetBIOS Extended User Interface (NetBEUI); packet; tunnel; virtual private network (VPN)

pointer (PTR) resource record

A DNS resource record used in a reverse lookup zone to map an IP address to a DNS name.

See also: Domain Name System (DNS); in-addr.arpa domain; IP address; resource record (RR); reverse lookup; zone

poison reverse

A process that, used with split horizon, improves Routing Information Protocol (RIP) convergence over simple split horizon by advertising all network IDs. However, the network IDs learned in a given direction are advertised with a hop count of 16, indicating that the network is unavailable.

See also: hop count; Routing Information Protocol (RIP); split horizon

policy

The mechanism by which computer settings are configured automatically, as defined by the administrator. Depending on context, this can refer to Group Policy or Windows NT 4.0 System Policy.

See also: Group Policy; Group Policy object (GPO); System Policy

polling intervals

The frequency the Resource Monitor checks that the resource is available and operating. There are two levels of polling: Looks Alive and Is Alive. The server cluster requests a more thorough check of the resource's state at each Is Alive interval than it does at each Looks Alive interval; therefore, the Is Alive polling interval is typically longer than the Looks Alive polling interval. You can specify the two polling intervals and a time-out value for resources.

See also: resource; Resource Monitor

POP

See definition for: point of presence (POP)

POP3 (Post Office Protocol 3)

A popular protocol used for receiving e-mail messages. This protocol is often used by Internet service providers (ISPs). POP3 servers allow access to a single Inbox in contrast to Internet Message Access Protocol (IMAP) servers, which provide access to multiple server-side folders.

See also: Internet service provider (ISP); Simple Mail Transfer Protocol (SMTP)

port

A connection point on your computer where you can connect devices that pass data into and out of a computer. For example, a printer is typically connected to a parallel port (also called an LPT port), and a modem is typically connected to a serial port (also called a COM port).

See also: parallel port; serial port; universal serial bus (USB)

port based network access control

A form of network access control that uses the physical characteristics of a switched local area network (LAN) infrastructure to authenticate devices that are attached to a LAN port and to prevent access to that port if the authentication process fails. This form of network access control is used in 802.1X authentication.

See also: 802.1X authentication; access control; authentication; local area network (LAN); port

port ID

The method that Transmission Control Protocol (TCP) and User Datagram Protocol (UDP) use to specify which program running on the system is sending or receiving the data.

See also: User Datagram Protocol (UDP)

port rule

For Network Load Balancing, a set of configuration parameters that determine the filtering mode to be applied to a range of ports.

See also: filtering mode; Network Load Balancing; port

port scanning

A method that is used to identify services or programs that respond to service requests that are made over a network port.

See also: port; service

Portable Operating System Interface for UNIX (POSIX)

An Institute of Electrical and Electronics Engineers (IEEE) standard that defines a set of operating-system services. Programs that adhere to the POSIX standard can be easily ported from one system to another. POSIX was based on UNIX system services, but it was created in a way that allows it to be implemented by other operating systems.

See also: service

POSIX

See definition for: Portable Operating System Interface for UNIX (POSIX)

possible owner

A node in a cluster that can run a specific resource. By default, all nodes appear as possible owners, so the resource can run on any node. In most cases, it is appropriate to use this default setting. If you want the resource to be able to fail over, at least two nodes must be designated as possible owners.

See also: cluster; failover; node; resource

PostScript

A page-description language (PDL), developed by Adobe Systems for printing on laser printers. PostScript offers flexible font capability and high-quality graphics. It is the standard for desktop publishing because it is supported by imagesetters, the high-resolution printers used by printing services for commercial typesetting.

See also: page-description language (PDL); PostScript fonts; PostScript printer; Printer Control Language (PCL); Printer Job Language (PJL); service; Type 1 fonts

PostScript fonts

Fonts that are defined in terms of the PostScript page-description language (PDL) rules and are intended to be printed on a PostScript-compatible printer. When a document displayed in a screen font is sent to a PostScript printer, the printer uses the PostScript version if the font exists. If the font doesn't exist but a version is installed on the computer, that font is downloaded to the printer. If there is no PostScript font installed in either the printer or the computer, the bit-mapped (raster) font is translated into PostScript and the printer produces text using the bit-mapped font. PostScript fonts are distinguished from bit-mapped fonts by their smoothness, detail, and faithfulness to standards of quality established in the typographic industry.

See also: downloadable fonts; font; page-description language (PDL); PostScript; raster fonts

PostScript printer

A printer that uses the PostScript page-description language (PDL) to create text and graphics on the output medium, such as paper or overhead transparency. Examples of PostScript printers include the Apple LaserWriter, the NEC LC-890, and the QMS PS-810.

See also: page-description language (PDL); PostScript; virtual printer memory

POTS

See definition for: point of termination station (POTS)

power conditioning

A feature of an uninterruptible power supply (UPS) that removes spikes, surges, sags, and noise from the power supply.

See also: uninterruptible power supply (UPS)

Power Users group

A group whose members can manage accounts, resources, and applications that are installed on a workstation, stand-alone server, or member server. This group does not exist on domain controllers. Administrative tasks that can be performed by members of this group include creating local users and groups; modifying and deleting accounts that they have created; removing users from the Power Users, Users, and Guests groups; installing most applications; and creating and deleting file shares.

See also: domain controller; group; member server; stand-alone server

PPP

See definition for: Point-to-Point Protocol (PPP)

PPTP

See definition for: Point-to-Point Tunneling Protocol (PPTP)

precedence

In Group Policy, the application hierarchy, based on the order in which Group Policy objects (GPOs) are applied. The GPO that is applied last takes precedence over all other objects.

See also: Group Policy Management console (GPMC); Group Policy object (GPO); Group Policy object link; inheritance

predefined key

A key that represents one of the main divisions of the registry. Each predefined key is displayed in a separate Registry Editor window, with the key's name appearing in the window's title bar. For example, HKEY_CLASSES_ROOT is a predefined key.

See also: hive; key; registry

preferred owner

The node on which you prefer each group to run. For example, the static load balancing model performs best when groups are appropriately balanced between two nodes. When a node fails, the remaining node takes over the groups from the failed node, but performance is diminished. By setting those groups to fail back to their preferred server (the failed node), you automatically restore maximum performance when failback occurs. A group does not fail back if a preferred owner is not selected.

You will not always choose a preferred owner because it may not matter where the group resides; all that matters is that the group is still running on one of the two nodes. Or, the nodes may be equally capable of handling the load required to use some or all of the resources.

See also: failback; group; node; resource

preferred server

The NetWare server that you connect to by default when you log on to your computer. The preferred server validates your user credentials and is queried when you request information about resources available on the NetWare network.

See also: credentials; resource

preset-to callback

A form of security in which a remote access server verifies users by calling them back at numbers supplied by the network administrator at the time user privileges are granted. Only a network administrator can change a preset callback number. This ensures that no one can borrow a user's password and connect to the server from a location other than the user's normal one.

See also: callback number; remote access server

preshared key

An Internet Protocol security (IPSec) technology in which a shared, secret key is used for authentication in IPSec policy.

See also: authentication; Internet Protocol security (IPSec); IPSec policy; key

prestage

To create a computer account in Active Directory before an operating system has been installed on the computer that will use the account. Prestaging is a part of supporting Remote Installation Services (RIS) for the client computer, and it ensures smooth client installations because the newly installed client computer is immediately recognized as having an account in Active Directory. The computer account information must include the globally unique identifier (GUID), which RIS uses to identify the client computer. An administrator can also use prestaging to control which computers can be installed through RIS.

See also: Active Directory; computer account; globally unique identifier (GUID); Remote Installation Services (RIS)

Primary disk

The hard disk drive that contains the system and boot partitions used to start Windows.

See also: boot partition; system partition

primary domain controller (PDC)

In a Windows NT domain, a domain controller running Windows NT Server 4.0 or earlier that authenticates domain logon attempts and updates user, computer, and group accounts in a domain. The PDC contains the master read-write copy of the directory database for the domain. A domain has only one PDC.

In a Windows 2000 or Windows Server 2003 domain, the PDC emulator master supports compatibility with client computers that are not running Windows 2000 or Windows XP Professional.

See also: Active Directory; backup domain controller (BDC); mixed mode; PDC emulator master

primary group

The group with which a Macintosh user usually shares documents stored on a server. You specify a user's primary group in the user's account. When a user creates a folder on the server, the user's primary group is set by default as the folder's associated group.

See also: group

primary master

An authoritative DNS server for a zone that can be used as a point of update for the zone. Only primary masters have the ability to be updated directly to process zone updates, which include adding, removing, or modifying resource records that are stored as zone data. Primary masters are also used as the first sources for replicating the zone to other DNS servers.

See also: DNS server; replication; resource record (RR); zone

primary partition

A type of partition that you can create on basic disks. A primary partition is a portion of a physical disk that functions as though it were a physically separate disk. On basic master boot record (MBR) disks, you can create up to four primary partitions on a basic disk, or three primary partitions and an extended partition with multiple logical drives. On basic GUID partition table (GPT) disks, you can create up to 128 primary partitions. Also known as a volume.

See also: basic disk; extended partition; GUID partition table (GPT); logical drive; master boot record (MBR); partition; volume

primary zone

A copy of the zone that is administered locally.

See also: secondary zone; zone

principle of least privilege

The security guideline that a user should have the minimum privileges necessary to perform a specific task. This helps to ensure that, if a user is compromised, the impact is minimized by the limited privileges held by that user. In practice, a user runs within the security context of a normal user. When a task requires additional privileges, the user can use a tool such as Run as to start a specific process with those additional privileges or to log on as a user with the necessary privileges.

See also: privilege; security

print job

The source code that contains both the data to be printed and the commands for print. Print jobs are classified into data types based on what modifications, if any, the spooler must make to the job for it to print correctly.

See also: print spooler; Printer window; printing pool

print processor

The component that, working in conjunction with the printer driver, receives and alters print jobs, as necessary, according to their data type to ensure that the jobs print correctly.

See also: print job; printer driver

print server

A computer that is dedicated to managing the printers on a network. The print server can be any computer on the network.

See also: printer

Print Server for Macintosh

A service that enables Macintosh clients to send and spool documents to printers attached to a computer running Windows NT Server; Windows 2000 Server; or an operating system in the Windows Server 2003 family, excluding 64-bit editions, and that enables clients to send documents to printers anywhere on an AppleTalk network. Also known as MacPrint.

See also: service

print spooler

Software that accepts a document sent to a printer and then stores it on disk or in memory until the printer is ready for it.

See also: printer; spooling

Print Spooler resource

Printer queues providing access to a network printer connected to the network by an IP address rather than by an individual name. Print spoolers are supported as cluster resources by a Resource DLL.

See also: IP address; print spooler; Resource DLL

printer

A device that puts text or images on paper or other print media. Examples are laser printers or dot-matrix printers.

See also: logical printer; print spooler; printing pool

Printer Control Language (PCL)

The page-description language (PDL) developed by Hewlett-Packard for their laser and inkjet printers. Because of the widespread use of laser printers, this command language has become a standard in many printers.

See also: page-description language (PDL); PostScript; Printer Job Language (PJL)

printer driver

A program designed to allow other programs to work with a particular printer without concerning themselves with the specifics of the printer's hardware and internal language. By using printer drivers that handle the subtleties of each printer, programs can communicate properly with a variety of printers.

See also: device driver

printer fonts

Fonts residing in or intended for a printer. A printer font, usually located in the printer's read-only memory (ROM), can be internal, downloaded, or on a font cartridge.

See also: device fonts; downloadable fonts; font; font cartridge

Printer Job Language (PJL)

The printer command language developed by Hewlett Packard that provides printer control at the print-job level. Using PJL commands, you can change default printer settings such as number of copies to print. PJL commands also permit switching printer languages between print jobs without action by the user. If bi-directional communication is supported, a PJL-compatible printer can send information such as printer model and job status to the print server.

See also: page-description language (PDL); PostScript; Printer Control Language (PCL)

printer permissions

Permissions that specify the type of access that a user or group has to a printer. The printer permissions are Print, Manage Printers, and Manage Documents.

See also: permission

Printer window

A window that shows information about any pending print jobs for the printer. For each printer you have installed or to which you are connected, you can view information such as how many documents are waiting to be printed, who owns them, and how large they are. Also called the queue view.

See also: print job

Printers and Faxes

The folder in Control Panel that contains the Add Printer Wizard and icons for all the printers installed on your computer.

See also: printer

printing pool

Two or more identical printers that are connected to one print server and act as a single printer. In this case, when you print a document, the print job will be sent to the first available printer in the pool.

See also: print job; printer

private branch exchange (PBX)

An automatic telephone switching system that enables users within an organization to place calls to each other without going through the public telephone network. Users can also place calls to outside numbers.

private key

The secret half of a cryptographic key pair that is used with a public key algorithm. Private keys are typically used to decrypt a symmetric session key, digitally sign data, or decrypt data that has been encrypted with the corresponding public key.

See also: public key; public key encryption

private network

A cluster network that supports only node-to-node communication.

See also: cluster; node

private or public network-to-network interface (PNNI)

The ATM Forum standard that defines the interface between asynchronous transfer mode (ATM) switches in a private network or a public network.

See also: asynchronous transfer mode (ATM)

private queue

For Message Queuing, a queue that is not published in Active Directory and that can be accessed only by applications that have access to the full format name of the queue.

See also: Active Directory; internal private queue; Message Queuing; public queue

private volume

A Macintosh-accessible volume that is accessible by only one Macintosh user. For a volume to be a private volume, the permissions on its root directory must give the volume's owner all three permissions (Make Changes, See Files, and See Folders), while giving the primary group and everyone categories no permissions at all. When a private volume's owner uses the Chooser to view the volumes available on the server, the private volume is listed; however, no other users can see the private volume when viewing the volumes available on the server.

See also: Chooser; permission; volume

privilege

A user's right to perform a specific task, usually one that affects an entire computer system rather than a particular object. Privileges are assigned by administrators to individual users or groups of users as part of the security settings for the computer.

See also: object; permission; user rights

process

The virtual address space and the control information necessary for the execution of a program.

See also: socket

process identifier (PID)

A numerical identifier that uniquely distinguishes a process while it runs. Use Task Manager to view PIDs.

See also: process; Task Manager

program

A complete, self-contained set of computer instructions that you use to perform a specific task, such as word processing, accounting, or data management. Also called an application.

program information file (PIF)

A file that provides information to Windows about how best to run MS-DOS-based programs. When you start an MS-DOS-based program, Windows looks for a PIF to use with it. PIFs contain such items as the name of the file, a start-up directory, and multitasking options.

See also: MS-DOS-based program

property

A characteristic or parameter of a class of objects or devices. For example, properties of Microsoft Word files include Size, Created, and Characters.

See also: device; object; property cache; property value; tag

property cache

For Indexing Service, a file that stores values for document properties.

See also: document; Indexing Service; property

property value

A specific characteristic or parameter that defines a property. For example, property values of a specific Microsoft Word document could include Size = 10,000 bytes, Created = Jan 2, 1999, and Characters = 5,250.

See also: property

Protective MBR

The first sector of a GUID partition table (GPT) disk that is structured like the first sector of a master boot record (MBR) disk to prevent x86-based disk utilities from destroying GPT partitions. The Protective MBR contains one partition that reserves the entire space used on the disk by GPT partitions.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); master boot record (MBR); x86

protocol

A set of rules and conventions for sending information over a network. These rules govern the content, format, timing, sequencing, and error control of messages exchanged among network devices.

See also: Internet Protocol (IP); Transmission Control Protocol/Internet Protocol (TCP/IP)

protocol parser

A dynamic-link library (DLL) that identifies the protocols used to send a frame onto the network.

See also: dynamic-link library (DLL); frame; protocol

proxy server

A firewall component that manages Internet traffic to and from a local area network (LAN) and that can provide other features, such as document caching and access control. A proxy server can improve performance by supplying frequently requested data, such as a popular Web page, and it can filter and discard requests that the owner does not consider appropriate, such as requests for unauthorized access to proprietary files.

See also: firewall; local area network (LAN)

PSTN

See definition for: public switched telephone network (PSTN)

public key

The nonsecret half of a cryptographic key pair that is used with a public key algorithm. Public keys are typically used when encrypting a session key, verifying a digital signature, or encrypting data that can be decrypted with the corresponding private key.

See also: key; private key; Public Key Cryptography Standards (PKCS); public key encryption; recovery agent

public key cryptography

See definition for: public key encryption

Public Key Cryptography Standards (PKCS)

A family of standards for public key cryptography that includes RSA encryption, Diffie-Hellman key agreement, password-based encryption, extended-syntax, cryptographic message syntax, private key information syntax, and certificate request syntax, as well as selected attributes. Developed, owned, and maintained by RSA Data Security, Inc.

See also: certificate; public key cryptography

public key encryption

A method of encryption that uses two encryption keys that are mathematically related. One key is called the private key and is kept confidential. The other is called the public key and is freely given out to all potential correspondents. In a typical scenario, a sender uses the receiver's public key to encrypt a message. Only the receiver has the related private key to decrypt the message. The complexity of the relationship between the public key and the private key means that, provided the keys are long enough, it is computationally infeasible to determine one from the other. Also called asymmetric encryption.

See also: encryption; private key; public key; symmetric encryption

public key infrastructure (PKI)

The laws, policies, standards, and software that regulate or manipulate certificates and public and private keys. In practice, it is a system of digital certificates, certification authorities, and other registration authorities that verify and authenticate the validity of each party involved in an electronic transaction. Standards for PKI are still evolving, even though they are being widely implemented as a necessary element of electronic commerce.

See also: certificate; certification authority (CA); public key

public network

A cluster network that supports client-to-cluster communication (either with or without supporting node-to-node communication).

See also: cluster; node

public queue

For Message Queuing, a queue that is published in Active Directory and replicated throughout a Windows enterprise. Public queues can, therefore, be located by any computer running Message Queuing within the enterprise.

See also: Active Directory; Message Queuing; private queue; queue

public switched telephone network (PSTN)

Standard analog telephone lines, available worldwide.

pull partner

A WINS component that requests replication of updated WINS database entries from its push partner.

See also: push partner; replica; Windows Internet Name Service (WINS)

pulse dialing

A form of dialing that enters a phone number by means of pulse frequencies. The user typically hears a series of clicking sounds when dialing. Old-fashioned rotary dial phones use pulse dialing.

See also: touch-tone dialing

push partner

A WINS component that notifies its pull partner when updated WINS database entries are available for replication.

See also: pull partner; replica; Windows Internet Name Service (WINS)

PVC

See definition for: permanent virtual circuit (PVC)

Q

QoS

See definition for: Quality of Service (QoS)

qualified subordination

An extension of a standard certification authority (CA) that allows you to place certificate issuance constraints on subordinate CAs and to place usage constraints on the certificates that are issued by subordinate CAs.

See also: certificate; certification authority (CA); public key infrastructure (PKI)

Quality of Service (QoS)

A set of quality assurance standards and mechanisms for data transmission, implemented in this version of Windows.

query

For Indexing Service, a structured statement that specifies the documents you want to find. The simplest query is a single word.

See also: Indexing Service; tag; vector; wildcard character

queue

A list of programs or tasks waiting for execution. In Windows printing terminology, a queue refers to a group of documents waiting to be printed. In NetWare and OS/2 environments, queues are the primary software interface between the application and print device; users submit documents to a queue. With Windows, however, the printer is that interface; the document is sent to a printer, not a queue.

See also: printer; transactional message

queue quota

For Message Queuing, the storage size limit for messages in public queues. When a queue quota is reached, Message Queuing can no longer send messages to that queue until one or more messages are removed from the queue. Message Queuing enforces the computer quota before it enforces the queue quota on a computer.

See also: computer quota; Message Queuing; queue

queue type

For Message Queuing, a globally unique identifier (GUID) specified by the application that created the queue.

See also: globally unique identifier (GUID); Message Queuing; queue

quiet answer

A telephone-answering protocol in which incoming calls are answered with silence instead of a tone signal. Some telephone-switching systems use quiet answering. These switching systems expect the caller to provide another phone number, code, or extension after the quiet answer.

See also: protocol

quorum log

The log where the quorum resource stores data. This data is maintained by the clustering software. Also known as the recovery log or change log.

See also: quorum resource; server cluster

quorum resource

The quorum-capable resource selected to maintain the configuration data necessary for recovery of the cluster. This data contains details of all of the changes that have been applied to the cluster database. The quorum resource is generally accessible to other cluster resources so that any cluster node has access to the most recent database changes. By default there is only one quorum resource per cluster.

See also: node; server cluster

quorum traffic

In a majority node set server cluster, the replication traffic between nodes in a cluster. This replication traffic contains the cluster configuration data and ensures that the cluster quorum information is kept in sync across all nodes.

See also: cluster; majority node set server cluster; node; quorum resource; replication

quota limit

The amount of disk space available to a user.

See also: warning level

R

RA

See definition for: registration authority (RA)

RADIUS

See definition for: Remote Authentication Dial-In User Service (RADIUS)

RAID

See definition for: Redundant Array of Independent Disks (RAID)

RAID-5 volume

A fault-tolerant volume with data and parity striped intermittently across three or more physical disks. Parity is a calculated value that is used to reconstruct data after a failure. If a portion of a physical disk fails, Windows recreates the data that was on the failed portion from the remaining data and parity. You can create RAID-5 volumes only on dynamic disks on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems. You cannot mirror or extend RAID-5 volumes. In Windows NT 4.0, a RAID-5 volume was known as a striped set with parity.

See also: dynamic disk; dynamic volume; fault tolerance; parity; volume

RAM

See definition for: random access memory (RAM)

random access memory (RAM)

Memory that can be read from or written to by a computer or other devices. Information stored in RAM is lost when the computer is turned off.

See also: virtual memory

raster fonts

Fonts that are stored as bitmaps. Raster fonts are designed with a specific size and resolution for a specific printer and cannot be scaled or rotated. If a printer does not support raster fonts, it will not print them. The five raster fonts are Courier, MS Sans Serif, MS Serif, Small, and Symbol. Also called bit-mapped fonts.

See also: font; printer

raw socket

A socket that provides direct access to lower-level network protocols.

See also: socket

read-only memory (ROM)

A semiconductor circuit that contains information that cannot be modified.

Real-Time Transport Protocol (RTP)

An Internet protocol for transporting real-time traffic over multicast and unicast network services.

See also: protocol; unicast

realm

A set of security principles, in a non-Windows networked environment, that are subject to Kerberos authentication.

See also: Kerberos V5 authentication protocol

realm name

An identifying prefix or suffix appended to a user name to enable appropriate routing and authentication during a remote logon process.

See also: authentication; routing; user name

realm trust

A trust between non-Windows Kerberos V5 realms, such as a UNIX realm, and Active Directory domains. Realm trusts can be transitive, nontransitive, one-way, or two-way.

See also: Active Directory; domain; Kerberos V5 authentication protocol; nontransitive trust; one-way trust; realm; transitive trust; two-way trust

rebinding state

A state used by DHCP clients to extend and renew their address lease when the current lease is close to expiring. In this state, the client broadcasts to the network to locate any DHCP server that can either renew or replace its currently leased configuration. The rebinding state begins when 87.5 percent of the client's lease time has elapsed.

See also: Dynamic Host Configuration Protocol (DHCP); lease

reconciliation

The process of making the client lease information stored in the DHCP server database consistent with a duplicate copy of this same information stored in the Windows registry. Using the DHCP Microsoft Management Console (MMC), reconciliation helps restore or recover the contents of the DHCP server database file, Dhcp.mdb, located by default in the %Systemroot%\System32\Dhcp folder.

See also: Dynamic Host Configuration Protocol (DHCP); lease; Microsoft Management Console (MMC); systemroot

recoverable message

For Message Queuing, a message that can be recovered no matter which computer fails, but that uses more resources and is slower than an express message.

See also: express message; Message Queuing

recovery agent

A person who is issued a public key certificate for the purpose of recovering user data that is encrypted with Encrypting File System (EFS).

See also: certificate; Encrypting File System (EFS); public key

Recovery Console

A command-line interface that provides a limited set of administrative commands that are useful for repairing a computer.

See also: NTFS file system

recovery policy

A type of public key Group Policy object (GPO) used by Encrypting File System (EFS) that provides for one or more user accounts to be designated as recovery agents.

See also: Encrypting File System (EFS); Group Policy object (GPO); public key; recovery agent; user account

recursive query

A query made to a DNS server in which the requester asks the server to assume the full workload and responsibility for providing a complete answer to the query. The DNS server will then use separate iterative queries to other DNS servers on behalf of the requester to assist in completing an answer for the recursive query.

See also: DNS server; iterative query; recursive resolution

recursive resolution

One of the two process types (iterative and recursive) for DNS name resolution. In this process, a resolver (a DNS client) will request that a DNS server provide a complete answer to a query that does not include pointers to other DNS servers. When a client makes a query and requests that the server use recursive resolution to answer, it effectively shifts the workload of resolving the query from the client to the DNS server. If the DNS server supports and uses recursive resolution, it contacts other DNS servers as necessary (using iterative queries on behalf of the client) until it obtains a definitive answer to the query. This type of resolution allows the client resolver to be small and simple.

See also: DNS server; Domain Name System (DNS); iteration; iterative query; recursive query

Recycle Bin

The place in which Windows stores deleted files. You can retrieve files you deleted in error, or you can empty the Recycle Bin to create more disk space.

Redundant Array of Independent Disks (RAID)

A method used to standardize and categorize fault-tolerant disk systems. RAID levels provide various mixes of performance, reliability, and cost. Some servers provide three of the RAID levels: Level 0 (striping), Level 1 (mirroring), and Level 5 (RAID-5).

See also: fault tolerance; RAID-5 volume

referral

A list of targets, transparent to the user, that a client receives from Distributed File System (DFS) when the user is accessing a root or a link in the DFS namespace. The referral information is cached on the client for a time period specified in the DFS configuration.

See also: DFS namespace; Distributed File System (DFS); iteration

referral server

A server that responds to requests for service from remote installation clients. It refers clients to other remote installation servers where they can install Windows desktop operating systems. The referral server does not directly host client computers for installing the operating system.

refresh

To update displayed information with current data.

See also: refresh rate

refresh interval

An interval of time used by secondary masters of a zone to determine how often to check if their zone data needs to be refreshed. When the refresh interval expires, the secondary master checks with its source for the zone to see if its zone data is still current or if it needs to be updated using a zone transfer. This interval is set in the start-of-authority (SOA) resource record for each zone.

See also: start-of-authority (SOA) resource record; zone; zone transfer

refresh rate

The frequency with which the video screen is retraced to prevent the image from flickering. The entire image area of most monitors is refreshed approximately 60 times per second.

See also: refresh

region

Contiguous chunks of storage on a disk.

See also: disk

registered file type

File types that are tracked by the system registry and are recognized by the programs you have installed on your computer.

See also: file type; registry

registration authority (RA)

A computer that is configured for an administrator to request and retrieve issued certificates on behalf of other users. An RA does not require that a certification authority be installed on the same computer.

See also: certificate; certification authority (CA)

registry

A database repository for information about a computer's configuration. The registry contains information that Windows continually references during operation, such as:

  • Profiles for each user
  • The programs installed on the computer and the types of documents that each can create
  • Property settings for folders and program icons
  • What hardware exists on the system
  • Which ports are being used

The registry is organized hierarchically as a tree, and it is made up of keys and their subkeys, hives, and entries.

See also: entry; hive; key; registry size limit (RSL); subkey

registry boot

The default boot option used by most Windows DNS servers. When registry boot is used, DNS is started and initialized using DNS parameters and their values as they are stored in the Windows registry. You can use a Berkeley Internet Name Domain (BIND) boot file as an alternative to this method of boot configuration for DNS.

See also: BIND boot file; DNS server; Domain Name System (DNS)

registry size limit (RSL)

A universal maximum for the space that registry files (hives) can consume in the paged pool. This maximum prevents an application from filling the paged pool with registry data.

See also: hive; paged pool; registry

relative distinguished name

The part of the object name that identifies the object as unique from its siblings at its level in the naming hierarchy. For example, in the distinguished name CN=My Name,CN=Users,DC=Microsoft,DC=Com the relative distinguished name of the user object is My Name. The relative distinguished name of the user object's parent object is Users.

See also: distinguished name; object

relative ID (RID)

The part of a security ID (SID) that uniquely identifies an account or group within a domain.

See also: domain; forest; group; RID master; security ID (SID)

relative name

The partial DNS domain name configured in individual resource records to locate and qualify the record within a zone. The relative name is joined to the front of the parent domain (domain of origin) for each resource record to form a fully qualified domain name (FQDN) within the zone. In DNS Manager, the relative name will correspond to fields that use record-specific name properties, such as the Host computer name field used in an address (A) resource record.

See also: address (A) resource record; Domain Name System (DNS); fully qualified domain name (FQDN); resource record (RR); zone

remote access

Part of the integrated Routing and Remote Access service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple branch offices. Users can use Network Connections to dial in to remotely access their networks for services such as file and printer sharing, electronic mail, scheduling, and SQL database access.

See also: remote access server; response; Serial Line Internet Protocol (SLIP); service

remote access policy

A set of conditions and connection parameters that define the characteristics of the incoming connection and the set of constraints imposed on it. Remote access policy determines whether a specific connection attempt is authorized to be accepted.

remote access server

A Windows-based computer running the Routing and Remote Access service and configured to provide remote access.

See also: remote access; set-by-caller callback

Remote Access Service (RAS)

A Windows NT 4.0 service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple offices.

remote administration

The management of one computer by an administrator working at another computer that is connected to the first computer across a network.

See also: remotely administered server

Remote Authentication Dial-In User Service (RADIUS)

A security authentication protocol based on a client/server model and widely used by Internet service providers (ISPs). RADIUS is the most popular means of authenticating and authorizing dial-up and tunneled network users today. A RADIUS client is included in the Routing and Remote Access service that ships with the Windows Server 2003 family. A RADIUS server, named Internet Authentication Service (IAS), is included in Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition; and Windows Server 2003, Datacenter Edition.

See also: authentication; Internet Authentication Service (IAS); tunnel

remote computer

A computer that you can access only by using a communications line or a communications device, such as a network card or a modem.

See also: local computer

Remote Installation Services (RIS)

Software services that allow an administrator to set up new client computers remotely, without having to visit each client. The target clients must support remote booting.

See also: Single Instance Store (SIS)

remote procedure call (RPC)

A message-passing facility that allows a distributed application to call services that are available on various computers on a network. Used during remote administration of computers.

See also: service

Remote Storage

A data management service used to migrate infrequently accessed files from local storage to remote storage. Migrated files are recalled transparently when the user opens the file.

See also: local storage; service; validation

remotely administered server

A server that you can administer by using a different computer. You typically access this type of server by using a network connection. A remotely administered server can have a local keyboard, mouse, or video card and monitor. If it does not have these peripherals attached, it is also known as a headless server. Such servers are often housed in a physically secure location.

See also: physical security; remote administration; server

removable media

Storage media such as a tape or disk that can easily be removed for transport, backup, or offsite storage.

Removable Storage

A service used for managing removable media (such as tapes and discs) and storage devices (libraries). Removable Storage allows applications to access and share the same media resources.

See also: library; service

rendering intent

In color management, the approach used to map the colors specified in an image file to the color gamut of your monitor or printer. The color gamut is the range of color that a device can produce.

See also: color gamut

rendezvous

Client service referral behavior performed using a DNS query to resolve domain names to locate host computers that are service providers for well-known TCP/IP-based network services. Rendezvous for clients uses queries for resource record types such as mail exchanger (MX) or service (SRV) records.

See also: Domain Name System (DNS); resource record (RR); service

reparse points

NTFS file system objects that have a definable attribute containing user-controlled data and that are used to extend functionality in the input/output (I/O) subsystem.

See also: attribute; NTFS file system; object

replica

In Active Directory replication, one instance of a logical Active Directory partition that is synchronized by means of replication between domain controllers that hold copies of the same directory partition. Replica can also refer to an instance of an object or attribute in a distributed directory.

In the File Replication service (FRS), a computer that has been included in the configuration of a specific replica set.

See also: Active Directory; File Replication service (FRS); replica set; replication topology

replica set

One or more shared folders that participates in replication.

See also: replication; shared folder

replication

The process of copying updated data from a data store or file system on a source computer to a matching data store or file system on one or more destination computers to synchronize the data.

In Active Directory, replication synchronizes schema, configuration, application, and domain directory partitions between domain controllers.

In Distributed File System (DFS), replication synchronizes files and folders between DFS roots and root targets.

See also: Active Directory; DFS root; directory partition; Distributed File System (DFS); File Replication service (FRS); multimaster replication; replica; replication policy; topology

replication latency

In Active Directory replication, the delay between the time an update is applied to a given replica of a directory partition and the time it is applied to some other replica of the same directory partition. A server receives changes no sooner than either it is notified of a change from its neighbor in the same site or its periodic replication timer expires. Sometimes referred to as propagation delay.

See also: Active Directory replication; directory partition; replica

replication partner

A domain controller that acts as a replication source for a given domain controller. The Knowledge Consistency Checker (KCC) determines which servers are best suited to replicate with each other, and it generates the list of domain controllers that are candidates for replication partners from the list of domain controllers in the site on the basis of connectivity, history of successful replication, and matching of full and partial replicas. A domain controller has some number of direct replication partners with which it replicates for a given directory partition. The other domain controllers in the site replicate transitively with this domain controller.

See also: directory partition; domain controller; Knowledge Consistency Checker (KCC); site

replication policy

Rules that define how and when replication is performed.

See also: replication

replication topology

In Active Directory replication, the set of physical connections that domain controllers use to replicate directory updates among domain controllers within sites and between sites.

In the File Replication service (FRS), the interconnections between replica set members. These interconnections determine the path that data takes as it replicates to all replica set members.

See also: Active Directory; Distributed File System (DFS); domain controller; File Replication service (FRS); replica; replica set; replication

report message

For Message Queuing, a message that contains status information and is sent to report queues on the source computer. Examples include test messages and route tracking messages.

See also: Message Queuing; report queue

report queue

For Message Queuing, a queue on the source computer that contains report messages. Report queues can be used when sending test messages and tracking message routes.

See also: Message Queuing; report message

Request for Comments (RFC)

An official document of the Internet Engineering Task Force (IETF) that specifies the details for protocols included in the TCP/IP family.

See also: Internet Engineering Task Force (IETF); protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

reservation

A specific IP address within a scope permanently reserved for leased use to a specific DHCP client. Client reservations are made in the DHCP database using DHCP Manager and based on a unique client device identifier for each reserved entry.

See also: Dynamic Host Configuration Protocol (DHCP); IP address; lease; scope

resolver

DNS client programs used to look up DNS name information. Resolvers can be either a small stub (a limited set of programming routines that provide basic query functionality) or larger programs that provide additional lookup DNS client functions, such as caching.

See also: caching; caching resolver; Domain Name System (DNS)

resource

Generally, any part of a computer system or network, such as a disk drive, printer, or memory, that can be allotted to a running program or a process.

For Device Manager, any of four system components that control how the devices on a computer work. These four system resources are interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses.

For server clusters, a physical or logical entity that is capable of being managed by a cluster, brought online and taken offline, and moved between nodes. A resource can be owned only by a single node at any point in time.

See also: direct memory access (DMA); input/output (I/O) port; interrupt request (IRQ) lines; memory address; node; offline; online; server cluster

resource allocation

The process of distributing a computer system's facilities to different components of a job in order to perform the job.

Resource DLL

A dynamic-link library (DLL) containing an implementation of the Resource application programming interface (API) for a specific type of resource. The Resource DLL is loaded into the address space of its Resource Monitor.

See also: application programming interface (API); dynamic-link library (DLL)

resource fork

One of two forks (resource fork and data fork) that make up each Macintosh file. The resource fork holds Macintosh operating system resources, such as code, menu, font, and icon definitions. Resource forks have no relevance to personal computers, so the resource forks of files on the server are never accessed by personal computer clients.

See also: data fork

resource group

In a server cluster, a defined collection of resources. Resources that are dependent on each other are typically placed within the same resource group.

See also: node; resource; server cluster

Resource Monitor

A cluster software component that facilitates communication between a node's server cluster and one or more of its resources.

See also: node; resource; server cluster

resource record (RR)

A standard DNS database structure containing information used to process DNS queries. For example, an address (A) resource record contains an IP address corresponding to a host name. Most of the basic resource record types are defined in RFC 1035, but additional RR types have been defined in other RFCs and approved for use with DNS.

See also: Domain Name System (DNS); Request for Comments (RFC); retry interval; zone

resource record set (RRset)

A collection of more than one resource record returned in a query response by a DNS server. RRsets are used in responses where more than one record is part of the answer.

See also: DNS server; resource record (RR)

resource types

Classes of resources, such as print spooler, physical disk, and file share, organized by the server cluster. Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition, provide Resource DLL files for the most common types of resources. Using the application programming interface (API) provided in the Microsoft Platform Software Development Kit (SDK), other vendors can add support for other resource types.

See also: print spooler; Resource DLL; server cluster; storage-class resource

response

In Windows remote access, strings expected from the device, which can contain macros.

See also: remote access; string

response message

For Message Queuing, a message sent by a receiving application to the response queue specified by a sending application. Any available queue can be specified as a response queue.

See also: Message Queuing; queue; response queue

response queue

For Message Queuing, a queue that is created by the sending application and used by the receiving application to reply to messages. For example, an application might send a response message to a response queue every time the application receives a message.

See also: Message Queuing; queue; response message

restricted token

An access token with restricted access to securable objects or performing privileged tasks.

See also: access token; object; privilege; security ID (SID)

Resultant Set of Policy (RSoP)

A feature that simplifies Group Policy implementation and troubleshooting. RSoP uses Windows Management Instrumentation (WMI) to determine how policy settings are applied to users and computers. RSoP has two modes: logging mode and planning mode. Logging mode determines the resultant effect of policy settings that have been applied to an existing user and computer based on a site, domain, and organizational unit. Planning mode simulates the resultant effect of policy settings that are applied to a user and computer.

See also: Group Policy; Group Policy Management console (GPMC); Microsoft Management Console (MMC); Windows Management Instrumentation (WMI)

retry interval

The time, in seconds after the refresh interval expires, used by secondary masters of a zone to determine how often to try and retry contacting its source for zone data to see if its replicated zone data needs to be refreshed. This interval is set in the start-of-authority (SOA) resource record for each zone.

See also: refresh interval; replication; start-of-authority (SOA) resource record; zone

reverse lookup

A DNS query for an IP address.

See also: Domain Name System (DNS); IP address

reversible encryption

A mechanism that stores an encrypted password in such a way that the original password can be unencrypted and retrieved. Some applications require the unencrypted password so that they can perform certain tasks.

See also: encrypted password

RFC

See definition for: Request for Comments (RFC)

RGB color space

Multidimensional color space consisting of the red, green, and blue intensities that make up a given color. This system is typically used in scanners, digital cameras, computer monitors, and computer printers.

See also: color management; color space

RID

See definition for: relative ID (RID)

RID master

A domain controller that holds the RID operations master role in Active Directory. The RID master is assigned to allocate unique sequences of relative IDs to each domain controller in its domain. As the domain controllers use the IDs allocated, they contact the RID master and are allocated additional sequences as needed. At any time, the RID master role can be assigned to only one domain controller in each domain.

See also: Active Directory; domain controller; operations master; relative ID (RID); security ID (SID); security principal

RIP

See definition for: Routing Information Protocol (RIP)

RIPX

See definition for: Routing Information Protocol over IPX (RIPX)

RIS

See definition for: Remote Installation Services (RIS)

Rivest-Shamir-Adleman (RSA) cryptographic algorithms

A widely used set of public key algorithms that were published by RSA Data Security, Inc. The RSA cryptographic algorithms are supported by the Microsoft Base Cryptographic Service Provider and the Microsoft Enhanced Cryptographic Service Provider.

See also: cryptographic service provider (CSP); public key cryptography

roaming user profile

A server-based user profile that is downloaded to the local computer when a user logs on and that is updated both locally and on the server when the user logs off. A roaming user profile is available from the server when logging on to a workstation or server computer. When logging on, the user can use the local user profile if it is more current than the copy on the server.

See also: local user profile; mandatory user profile; user profile

role-based administration

A management technique that is characterized by the use of collections of settings that are based on an object’s role within an organization. Role-based administration can be used to manage users, computers, and other file system and directory service objects.

See also: access control entry (ACE); authorization; object

rolling upgrade

In a cluster, the process of systematically upgrading cluster nodes one node at a time. During the upgrade, the remaining cluster nodes continue to provide service.

See also: cluster; node

ROM

See definition for: read-only memory (ROM)

root

The highest or uppermost level in a hierarchically organized set of information. The root is the point from which further subsets are branched in a logical sequence that moves from a broad or general focus to narrower perspectives.

See also: DFS root; root certificate; root certification authority; root hints; root servers; root target

root certificate

A self-signed certification authority certificate. It is called a root certificate because it is the certificate for the root authority. The root authority must sign its own certificate because by definition there is no higher certifying authority in the certification hierarchy.

See also: certificate; certification authority (CA); certification hierarchy; root certification authority

root certification authority

The most trusted certification authority (CA), which is at the top of a certification hierarchy. The root CA has a self-signed certificate. Also called the root authority.

See also: certification authority (CA); certification hierarchy; root

root directory

The top-level directory (or folder) on a computer, partition or volume, or Macintosh-accessible volume.

See also: Macintosh-accessible volume; partition; volume

root domain

The beginning of the DNS namespace. In Active Directory, the initial domain in an Active Directory tree. Also, the initial domain of a forest.

See also: Active Directory; domain; Domain Name System (DNS); forest; namespace

root hints

DNS data stored on a DNS server that identifies the authoritative DNS servers for the root zone of the DNS namespace. The root hints are stored in the file Cache.dns, located in the systemroot\System32\Dns folder.

See also: DNS server; Domain Name System (DNS); root servers; systemroot

root servers

DNS servers that are authoritative for the root of the namespace.

See also: authoritative; DNS server; root

root target

The mapping destination of a DFS root, which corresponds to a shared folder on a server.

See also: DFS root; target

round robin

A simple mechanism used by DNS servers to share and distribute loads for network resources. Round robin is used to rotate the order of resource records (RRs) returned in a response to a query when multiple RRs of the same type exist for a queried DNS domain name.

See also: DNS server; resource record (RR)

Routemon utility

A scripting utility for the Routing and Remote Access service that is a command-line alternative to the router administration user interface available through the Routing and Remote Access Manager.

router

Hardware that helps local area networks (LANs) and wide area networks (WANs) achieve interoperability and connectivity and that can link LANs that have different network topologies (such as Ethernet and Token Ring). Routers match packet headers to a LAN segment and choose the best path for the packet, optimizing network performance.

See also: local area network (LAN); packet header; routing; Routing Information Protocol over IPX (RIPX); static routes; Token Ring; wide area network (WAN)

routing

The process of forwarding a packet through an internetwork from a source host to a destination host.

See also: host; packet

Routing Information Protocol (RIP)

An industry standard, distance vector routing protocol used in small- to medium-sized Internet Protocol (IP) and Internetwork Packet Exchange (IPX) internetworks.

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); protocol

Routing Information Protocol over IPX (RIPX)

A protocol used by routers to exchange information between routers on an Internetwork Packet Exchange (IPX) network and by hosts to determine the best router to use when forwarding IPX traffic to a remote IPX network.

See also: host; Internetwork Packet Exchange (IPX); NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink); protocol; router

routing link

For Message Queuing, a communications link established between Windows sites for routing messages. Specially configured Message Queuing servers with routing services enabled are used to create a routing link between sites.

See also: Message Queuing; routing services; routing-link cost; site

routing protocol

Any of several protocols that enable the exchange of routing table information between routers. Typically, medium- to large-sized TCP/IP internetworks implement routing protocols to simplify the administration of routing tables.

See also: router; routing

routing services

For Message Queuing, a service on a Message Queuing server that provides message routing services. If so configured, this feature can be used on a Message Queuing server to:

  • Enable computers that use different network protocols to communicate
  • Reduce the number of sessions by acting as a gateway for all incoming or outgoing messages for independent clients
  • Route messages between sites over a routing link

See also: gateway; independent client; Message Queuing; Message Queuing server; routing link; service; session concentration; site

routing-link cost

For Message Queuing, a number used to determine the route messages can take between two sites. This number represents the relative monetary cost of communication over a link. A routing link has a default routing-link cost of 1 and should not be changed unless you have multiple routing links between two sites and you want to enforce message routing over a specific routing link.

See also: Message Queuing; routing link; site

RPC

See definition for: remote procedure call (RPC)

RR

See definition for: resource record (RR)

RRset

See definition for: resource record set (RRset)

RS-232-C standard

An accepted industry standard for serial communication connections. Adopted by the Electric Industries Association, this Recommended Standard (RS) defines the specific lines and signal characteristics used by serial communications controllers to standardize the transmission of serial data between devices. The letter C signifies the third in a series.

See also: device

RSA

See definition for: Rivest-Shamir-Adleman (RSA) cryptographic algorithms

RSL

See definition for: registry size limit (RSL)

RSoP

See definition for: Resultant Set of Policy (RSoP)

RTP

See definition for: Real-Time Transport Protocol (RTP)

Run as

A feature that provides users with a secondary logon capability. By using Run as, users can run applications or commands in a different security context without having to log off. Run as prompts the user for different credentials before running the application or command.

See also: secondary logon; security context

runaway recall limit

In Remote Storage, the setting that prohibits a user or an application from recalling files from Remote Storage more than the specified number of times in succession with less than 10 seconds between each recall. Otherwise, applications such as those for virus checking, data backup, indexing, and searching typically read all files on your computer and can cause excessive file recalls and slow performance.

See also: Remote Storage

S

S/MIME

See definition for: Secure/Multipurpose Internet Mail Extensions (S/MIME)

SA

See definition for: security association (SA)

SACL

See definition for: system access control list (SACL)

Safe Mode

A method of starting Windows using basic files and drivers only, without networking. Safe Mode is available by pressing the F8 key when prompted during startup. This allows you to start your computer when a problem prevents it from starting normally.

See also: Safe Mode with Command Prompt; Safe Mode with Networking

Safe Mode with Command Prompt

A method of starting Windows using basic files and drivers only, without networking, and with only a command prompt displayed. This mode is available by pressing the F8 key when prompted during startup. This allows you to start your computer when a problem prevents it from starting normally.

See also: Safe Mode; Safe Mode with Networking

Safe Mode with Networking

A method of starting Windows using only basic files, drivers, and networking. This mode is available by pressing the F8 key when prompted during startup. This allows you to start your computer when a problem prevents it from starting normally.

See also: Safe Mode; Safe Mode with Command Prompt

SAM

See definition for: Security Accounts Manager (SAM)

SAM account name

A domain-unique security principal name in Windows NT 4.0 and earlier.

See also: Security Accounts Manager (SAM); security principal name

SAN

See definition for: system area network (SAN)

SAP

See definition for: Service Advertising Protocol (SAP)

saturation

In color management, the purity of a color's hue, moving from gray to the pure color.

See also: hue

SBM

See definition for: subnet bandwidth management (SBM)

scalability

A measure of how well a computer, service, or application can grow to meet increasing performance demands. For server clusters, the ability to incrementally add one or more systems to an existing cluster when the overall load of the cluster exceeds its capabilities.

See also: server cluster

scavenging

The process of cleaning and removing extinct or outdated names data from the WINS database.

See also: Windows Internet Name Service (WINS)

Schannel

See definition for: secure channel (Schannel)

schema

The set of definitions for the universe of objects that can be stored in a directory. For each object class, the schema defines which attributes an instance of the class must have, which additional attributes it can have, and which other object classes can be its parent object class.

See also: attribute; directory partition; object; object class; parent object

schema master

A domain controller that holds the schema operations master role in Active Directory. The schema master performs write operations to the directory schema and replicates updates to all other domain controllers in the forest. At any time, the schema master role can be assigned to only one domain controller in the forest.

See also: Active Directory; domain controller; operations master; schema

scope

A range of IP addresses that are available to be leased or assigned to DHCP clients by the DHCP service.

See also: Dynamic Host Configuration Protocol (DHCP); IP address; lease

scope of influence

In a domain environment, a site, domain, or organizational unit; in a workgroup environment, the local disk.

See also: domain; organizational unit; site

scope of management (SOM)

In Group Policy, any Active Directory container to which you can link a Group Policy object (GPO). These containers can be sites, domains, or organizational units.

See also: Active Directory; Group Policy; Group Policy object (GPO)

screen font

A typeface designed for display on a computer monitor screen. A screen font often has an accompanying PostScript font for printing to PostScript-compatible printers.

See also: font; PostScript

screen resolution

The setting that determines the amount of information that appears on your screen, measured in pixels. Low resolution, such as 640 x 480, makes items on the screen appear large, although the screen area is small. High resolution, such as 1024 x 768, makes the overall screen area large, although individual items appear small.

See also: pixel

screen saver

A moving picture or pattern that appears on your screen when you have not used the mouse or keyboard for a specified period of time.

SCSI

See definition for: small computer system interface (SCSI)

SDP

See definition for: Session Description Protocol (SDP)

second-level domain

A DNS domain name that is rooted hierarchically at the second tier of the domain namespace, directly beneath the top-level domain names. Top-level domain names include .com and .org. When DNS is used on the Internet, second-level domains are names that are registered and delegated to individual organizations and businesses.

See also: domain name; Domain Name System (DNS); parent domain; top-level domains

secondary cluster

A specific virtual IP address assigned to a Network Load Balancing cluster (the "primary cluster"). The secondary cluster's virtual IP address is different than the primary cluster's virtual IP address. Secondary clusters allow you to configure an independent set of port rules for each virtual IP address in your Network Load Balancing (primary) cluster. Also known as a virtual cluster.

See also: cluster; Network Load Balancing; virtual IP address

secondary logon

The practice of logging on by using one security context and then, within the initial logon session, authenticating and using a second account. In Windows 2000, Windows XP Professional, and the Windows Server 2003 family, secondary logon is enabled by the RunAs.exe program and service.

See also: authentication

secondary zone

A read-only copy of a DNS zone that is transferred from an authoritative DNS server to another DNS server to provide redundancy.

See also: authoritative; DNS server; DNS zone; Domain Name System (DNS); primary zone; zone

sector

A 512-byte unit of physical storage on a hard disk. Windows file systems allocate storage in clusters, where a cluster is one or more contiguous sectors.

See also: cluster; file system

secure channel (Schannel)

A Security Support Provider (SSP) that implements the Secure Sockets Layer (SSL) and Transport Layer Security (TLS) Internet standard authentication protocols.

See also: authentication protocol; Secure Sockets Layer (SSL); Transport Layer Security (TLS)

secure dynamic update

The process in which a DNS client submits a dynamic update request to a DNS server and the DNS server performs the update only if the client is authenticated.

See also: authentication; DNS client; DNS server; dynamic update

Secure Hash Algorithm (SHA-1)

An algorithm that generates a 160-bit hash value from an arbitrary amount of input data. SHA-1 is used with the Digital Signature Algorithm (DSA) in the Digital Signature Standard (DSS), among other places.

See also: Digital Signature Standard (DSS); hash algorithm

Secure Hypertext Transfer Protocol

A protocol that provides a secure Hypertext Transfer Protocol (HTTP) connection.

See also: Hypertext Transfer Protocol (HTTP); protocol

Secure Sockets Layer (SSL)

A proposed open standard for establishing a secure communications channel to prevent the interception of critical information, such as credit card numbers. Primarily, it enables secure electronic financial transactions on the World Wide Web, although it is designed to work on other Internet services as well.

See also: internet

secure zone

A DNS zone that is stored in Active Directory and to which access control list (ACL) security features are applied.

See also: access control list (ACL); Active Directory; DNS zone; Domain Name System (DNS)

Secure/Multipurpose Internet Mail Extensions (S/MIME)

An extension of MIME that supports secure mail. It enables message originators to digitally sign e-mail messages to provide proof of message origin and data integrity. It also enables messages to be transmitted in encrypted format to provide confidential communications.

See also: public key encryption

security

On a network, protection of a computer system and its data from harm or loss, implemented especially so that only authorized users can gain access to shared files.

See also: authorization

Security Accounts Manager (SAM)

A Windows service used during the logon process. SAM maintains user account information, including groups to which a user belongs.

See also: group; service; user account

security association (SA)

A combination of identifiers, which together define Internet Protocol security (IPSec) that protects communication between sender and receiver. An SA is identified by the combination of a Security Parameters Index (SPI), destination IP address, and security protocol (Authentication Header (AH) or Encapsulating Security Payload (ESP)). An SA must be negotiated before secured data can be sent.

See also: Authentication Header (AH); Encapsulating Security Payload (ESP); Internet Protocol security (IPSec); IP address; Security Parameters Index (SPI)

security context

The security attributes or rules that are currently in effect. For example, the rules that govern what a user can do to a protected object are determined by security information in the user's access token and in the object's security descriptor. Together, the access token and the security descriptor form a security context for the user's actions on the object.

See also: access token; object; security descriptor

security descriptor

A data structure that contains security information associated with a protected object. Security descriptors include information about who owns the object, who can access it and in what way, and what types of access are audited.

See also: discretionary access control list (DACL); group; object; permission; system access control list (SACL)

security event

An event that is logged in the security log in Event Viewer. All events that are logged in the security log are auditing events, and they can be divided into the following event categories: account logon, account management, directory service access, logon, object access, policy change, privilege use, process tracking, or system.

See also: auditing; event; Event Viewer; security log

security filtering

A method of applying the settings of a Group Policy object (GPO) based on security principals.

See also: Group Policy object (GPO); security principal

security group

A group that can be listed in discretionary access control lists (DACLs) used to define permissions on resources and objects. A security group can also be used as an e-mail entity. Sending an e-mail message to the group sends the message to all the members of the group.

See also: discretionary access control list (DACL); group

security host

An authentication device, supplemental to standard Windows and remote access server security, that verifies whether a caller from a remote client is authorized to connect to the remote access server.

See also: authentication; remote access; remote access server

security ID (SID)

A data structure of variable length that identifies user, group, and computer accounts. Every account on a network is issued a unique SID when the account is first created. Internal processes in Windows refer to an account's SID rather than the account's user or group name.

See also: group account; user account; user name

security log

An event log containing information on security events that are specified in the audit policy.

See also: audit policy; event

Security Parameters Index (SPI)

A unique, identifying value in the security association (SA) used to distinguish among multiple SAs existing at the receiving computer.

See also: security association (SA)

security principal

An account holder that is automatically assigned a security identifier (SID) to control access to resources. A security principal can be a user, group, service, or computer.

See also: group; resource; security ID (SID); service

security principal name

A name that uniquely identifies a user, group, or computer within a single domain. This name is not guaranteed to be unique across domains.

See also: domain; group; security principal

security template

A physical file representation of a security configuration that can be applied to a local computer or imported to a Group Policy object (GPO) in Active Directory. When you import a security template to a GPO, Group Policy processes the template and makes the corresponding changes to the members of that GPO, which can be users or computers.

See also: Active Directory; Group Policy; Group Policy object (GPO)

See Files

The Macintosh-style privilege that allows you to see any files in the folders for which you have this privilege. When Services for Macintosh translates Macintosh-style privileges into Windows permissions, you are granted Read permission for any folders for which you have the See Files and See Folders privileges.

See also: See Folders

See Folders

The Macintosh-style privilege that allows you to see folders for which you have this privilege but not any files those folders might contain. When Services for Macintosh translates Macintosh-style privileges into Windows permissions, you are granted Read permission for any folders for which you have the See Files and See Folders privileges.

See also: See Files

seed router

A router that initializes and broadcasts network numbers and zones about one or more physical AppleTalk networks. Servers that are running the AppleTalk protocol can function as seed routers. You can also use hardware routers from other companies as seed routers.

See also: router; zone

Serial Line Internet Protocol (SLIP)

An older industry standard that is part of Windows remote access client to ensure interoperability with other remote access software.

See also: remote access

serial port

An interface on the computer that allows asynchronous transmission of data characters one bit at a time. Also called a communication port or COM port.

See also: communication port; port

server

In general, a computer that provides shared resources to network users.

See also: client; shared resource

server application

Application software running on a cluster node, regardless of whether it does service registration.

See also: node

server cluster

A group of computers, known as nodes, working together as a single system to ensure that mission-critical applications and resources remain available to clients. A server cluster presents the appearance of a single server to a client.

See also: cluster; node

Server Message Block (SMB)

A file-sharing protocol designed to allow networked computers to transparently access files that reside on remote systems over a variety of networks. The SMB protocol defines a series of commands that pass information between computers. SMB uses four message types: session control, file, printer, and message.

See also: protocol

Server Operators group

A group whose members can manage all domain controllers in a single domain. This group does not exist on workstations, stand-alone servers, or member servers. Administrative tasks that can be performed by members of this group include logging on locally, creating and deleting network shared resources, starting and stopping services, backing up and restoring files, formatting the hard disk of the computer, and shutting down the computer.

See also: domain; domain controller; group; member server; service; stand-alone server

server zone

The AppleTalk zone on which a server appears. On a Phase 2 network, a server appears in the default zone of the server's default network.

See also: server; zone

Server-Gated Cryptography (SGC)

An extension of Secure Sockets Layer (SSL) that enables organizations, such as financial institutions, that have export versions of Internet Information Services (IIS) to use strong encryption (for example, 128-bit encryption).

See also: cryptography; Internet Information Services (IIS); Secure Sockets Layer (SSL)

service

A program, routine, or process that performs a specific system function to support other programs, particularly at a low (close to the hardware) level. When services are provided over a network, they can be published in Active Directory, facilitating service-centric administration and usage. Some examples of services are the Security Accounts Manager service, File Replication service, and Routing and Remote Access service.

See also: File Replication service (FRS); Security Accounts Manager (SAM)

service (SRV) resource record

A DNS resource record used to identify computers that host specific services, specified in RFC 2782. SRV resource records are used to locate domain controllers for Active Directory.

See also: Active Directory; domain controller; Domain Name System (DNS); Request for Comments (RFC); resource record (RR)

Service Advertising Protocol (SAP)

A NetWare protocol used to identify the services and addresses of servers attached to the network. When a server starts, it uses the protocol to advertise its service. When the same server goes offline, it uses the protocol to announce that it is no longer available. NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) uses SAP to locate NetWare servers and services.

See also: NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink); protocol

Service Pack

A software upgrade to an existing software distribution that contains updated files consisting of patches and hot fixes.

Service Principal Name (SPN)

A way of referring to a service principal. The SPN structures generally follow Internet Engineering Task Force (IETF) naming conventions, and they often include the name of the computer on which the service is running. SPNs may be used to request Kerberos tickets, and they are required for mutual authentication.

See also: authentication; Internet Engineering Task Force (IETF); service; ticket

Service Profile Identifier (SPID)

An 8-digit to 14-digit number that identifies the services that you order for each B-channel. For example, when you order Primary Rate ISDN, you obtain two phone numbers and two SPIDs from your Integrated Services Digital Network (ISDN) provider. Typical ISDN adapters cannot operate without configuring SPIDs.

See also: B-channel; Integrated Services Digital Network (ISDN); service

Service Provider Interface

Calling conventions that back-end services use to make themselves accessible to front-end applications.

See also: service

service ticket

A ticket issued by the Kerberos V5 ticket-granting service (TGS) that allows a user to authenticate to a specific service in the domain.

See also: Kerberos V5 authentication protocol; ticket; ticket-granting service (TGS)

service-centric

A service model that does not require that a specific computer be used to complete a task. In a service-centric environment, users need to know only what service they want to use. They do not need to know what computer that service resides on to use it successfully.

See also: machine-centric; service

session

A logical connection created between two hosts to exchange data. Typically, sessions use sequencing and acknowledgments to send data reliably.

In the context of load balancing TCP/IP traffic, a set of client requests directed to a server. These requests can be invoked with multiple, possibly concurrent, TCP connections. The server program sometimes maintains state information between requests. To preserve access to the server state, Network Load Balancing needs to direct all requests within a session to the same cluster host when load balancing.

See also: client request; host; load balancing; Network Load Balancing; server; Transmission Control Protocol/Internet Protocol (TCP/IP)

session concentration

For Message Queuing, a feature that typically reduces network bandwidth within a site and the number of sessions between sites. Specially configured Message Queuing servers with routing services provide session concentration.

See also: bandwidth; Message Queuing; Message Queuing server; routing services; session; site

Session Description Protocol (SDP)

A protocol that Telephony API (TAPI) uses to advertise Internet Protocol (IP) multicast conferences. This protocol describes multimedia sessions for the purposes of session announcement, session invitation, and other forms of session initiation. SDP descriptors are stored in Active Directory. SDP is described in RFC 2327 of the Internet Engineering Task Force (IETF).

See also: Active Directory; Internet Engineering Task Force (IETF); protocol; Request for Comments (RFC); Telephony API (TAPI)

session key

In Internet Protocol security (IPSec), a value that is used in combination with an algorithm to encrypt or decrypt data that is transferred between computers. A session key is created for every pair of computers to provide enhanced security on computers that have multiple simultaneous active sessions.

See also: algorithm; encryption; Internet Protocol security (IPSec); key; session

set-by-caller callback

In Network Connections, a form of callback in which the user supplies the telephone number that the remote access server uses for callback. This setting spares the user any long-distance telephone charges.

See also: Network Connections; remote access server

Setup

The program that installs Windows. Also known as unattended installation, Winnt32.exe, and Winnt.exe.

SGC

See definition for: Server-Gated Cryptography (SGC)

SHA-1

See definition for: Secure Hash Algorithm (SHA-1)

share

To make resources, such as folders and printers, available to others.

See also: resource; shared folder

shared folder

A folder on another computer that has been made available for other people to use on the network.

See also: share

shared folder permissions

Permissions that restrict a shared resource's availability over the network to only certain users.

See also: permission; shared resource

shared printer

A printer that receives input from more than one computer. For example, a printer attached to another computer on the network can be shared so that it is available for you to use. Also called a network printer.

See also: printer; share

shared resource

Any device, data, or program that is used by more than one program or one other device. For Windows, shared resource refers to any resource that is made available to network users, such as folders, files, printers, and named pipes. Shared resource can also refer to a resource on a server that is available to network users.

See also: device; named pipe; resource; server; share

shortcut

A link to any item accessible on your computer or on a network, such as a program, file, folder, disk drive, Web page, printer, or another computer. You can put shortcuts in various areas, such as on the desktop, on the Start menu, or in specific folders.

See also: desktop

shortcut trust

A trust that is manually created between two domains in the same forest. The purpose of a shortcut trust is to optimize the interdomain authentication process by shortening the trust path. Shortcut trusts are transitive and can be one-way or two-way.

See also: Active Directory; domain; forest; one-way trust; trust path; trust relationship; two-way trust

SID

See definition for: security ID (SID)

signaling protocol

A protocol that uses signaling to request, route, accept, and tear down virtual circuits.

See also: protocol

signed driver

A driver that meets the criteria of the Windows Logo Program. For performance and stability, Microsoft strongly recommends that you use only signed drivers for new or updated drivers.

See also: unsigned driver; Windows Logo Program

Simple Mail Transfer Protocol (SMTP)

A member of the TCP/IP suite of protocols that governs the exchange of electronic mail between message transfer agents.

See also: protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Simple Network Management Protocol (SNMP)

A network protocol used to manage TCP/IP networks. In Windows, the SNMP service is used to provide status information about a host on a TCP/IP network.

See also: agent; protocol; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

Simple Object Access Protocol (SOAP)

An XML/HTTP-based protocol for platform-independent access to objects and services on the Web. SOAP defines a message format in XML that travels over the Internet using Hypertext Transfer Protocol (HTTP). By using existing Web protocols (HTTP) and languages (XML), SOAP runs over the existing Internet infrastructure without being tied to any operating system, language, or object model.

See also: Extensible Markup Language (XML); Hypertext Transfer Protocol (HTTP); object; service

Simple TCP/IP Services

Four TCP/IP services: Character Generator, Daytime Discard, Echo, and Quote of the Day.

See also: service; Transmission Control Protocol/Internet Protocol (TCP/IP)

simple volume

A dynamic volume made up of disk space from a single dynamic disk. A simple volume can consist of a single region on a disk or multiple regions of the same disk that are linked together. If the simple volume is not a system volume or boot volume, you can extend it within the same disk or onto additional disks. If you extend a simple volume across multiple disks, it becomes a spanned volume. You can create simple volumes only on dynamic disks. Simple volumes are not fault tolerant, but you can mirror them to create mirrored volumes on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; spanned volume; volume

single affinity

Specifies that Network Load Balancing should direct multiple requests from the same client IP address to the same cluster host. This is the default setting for affinity.

See also: affinity; Class C affinity; Network Load Balancing

Single Instance Store (SIS)

A component that saves disk space on the server by maintaining a single physical copy of all identical files found. If SIS finds a duplicate file on the server, it copies the original file into the SIS store and leaves a link where the original resided. This technology is used only with Remote Installation Services.

See also: Remote Installation Services (RIS)

single node server cluster

A cluster configuration that has one node and that can be configured with or without external cluster storage devices. For a single node cluster without an external cluster storage device, the local disk is configured as the cluster storage device. There are advantages and limitations for each cluster configuration (single node server cluster, single quorum device server cluster, and majority node set server cluster).

See also: cluster; cluster storage; majority node set server cluster; node; single quorum device server cluster

single quorum device server cluster

A cluster configuration that has two or more nodes and that is configured so that every node is attached to one or more cluster storage device. The cluster configuration data is stored on a single cluster storage device. There are advantages and limitations for each cluster configuration (single node server cluster, single quorum device server cluster, and majority node set server cluster).

See also: cluster; cluster storage; majority node set server cluster; node; single node server cluster

single sign-on

A process that enables a user with a domain account to log on to a network once, using a password or smart card, and to gain access to any computer in the domain.

See also: domain; smart card

SIS

See definition for: Single Instance Store (SIS)

site

One or more well-connected (highly reliable and fast) TCP/IP subnets. A site allows administrators to configure Active Directory access and replication topology to take advantage of the physical network.

See also: Active Directory; replication topology; subnet; Transmission Control Protocol/Internet Protocol (TCP/IP)

site link

An Active Directory object that represents a set of sites that can communicate at uniform cost through some intersite transport. For Internet Protocol (IP) transport, a typical site link connects just two sites and corresponds to an actual wide area network (WAN) link. An IP site link connecting more than two sites might correspond to an asynchronous transfer mode (ATM) backbone connecting more than two clusters of buildings on a large campus or several offices in a large metropolitan area connected via leased lines and IP routers.

See also: Active Directory; asynchronous transfer mode (ATM); Internet Protocol (IP); site; site link bridge; wide area network (WAN)

site link bridge

An Active Directory object that represents a set of site links, all of whose sites can communicate via some transport. Typically, a site link bridge corresponds to a router (or a set of routers) in an Internet Protocol (IP) network. By default, the Knowledge Consistency Checker (KCC) may form a route through any and all site links in a transitive manner. If this behavior is turned off, each site link represents its own distinct and isolated network. Sets of site links that can be treated as a single route are expressed through a site link bridge. Each bridge represents an isolated communication environment for network traffic.

See also: Active Directory; Internet Protocol (IP); Knowledge Consistency Checker (KCC); site; site link

sleep mode

An energy-saving mode in which the Windows operating system shuts down all unnecessary components, such as the display screen and the disk drive. The computer returns to its former operating status when it is awakened.

See also: wake-on-LAN

SLIP

See definition for: Serial Line Internet Protocol (SLIP)

small computer system interface (SCSI)

A standard high-speed parallel interface defined by the American National Standards Institute (ANSI). A SCSI interface is used for connecting microcomputers to peripheral devices, such as hard disks and printers, and to other computers and local area networks (LANs).

See also: device; local area network (LAN)

smart card

A credit card–sized device that is used with an access code to enable certificate-based authentication and single sign-on to the enterprise. Smart cards securely store certificates, public and private keys, passwords, and other types of personal information. A smart card reader attached to the computer reads the smart card.

See also: authentication; single sign-on; smart card reader

smart card reader

A device that is installed in computers to enable the use of smart cards for enhanced security features.

See also: smart card

SMS

See definition for: Systems Management Server (SMS)

SMTP

See definition for: Simple Mail Transfer Protocol (SMTP)

snap-in

A type of tool that you can add to a console supported by Microsoft Management Console (MMC). A stand-alone snap-in can be added by itself; an extension snap-in can be added only to extend the function of another snap-in.

See also: Microsoft Management Console (MMC)

sniffer

An application or device that can read, monitor, and capture network data exchanges and read network packets. If the packets are not encrypted, a sniffer provides a full view of the data inside the packet.

See also: device; packet

SNMP

See definition for: Simple Network Management Protocol (SNMP)

socket

An identifier for a particular service on a particular node on a network. The socket consists of a node address and a port number, which identifies the service. For example, port 80 on an Internet node indicates a Web server. There are two kinds of sockets: streams (bidirectional) and datagrams.

See also: datagram; node; port; process; raw socket

software decoder

A type of digital video disc (DVD) decoder that allows a DVD drive to display movies on your computer screen. A software decoder uses only software to display movies.

See also: DVD decoder; DVD drive; hardware decoder

software restriction policies

A collection of policy settings that define what software can run on a computer, based on the default security level for a Group Policy object (GPO). Exceptions to that default security level can then be defined by certificate rules, hash rules, path rules, registry path rules, and Internet zone rules.

See also: default security level; Group Policy; Group Policy object (GPO); software restriction policies rule

software restriction policies rule

A rule that creates an exception to the default security level that is defined by software restriction policies.

The following types of rules can be created: certificate rules, which recognize software that is digitally signed by an Authenticode software publisher certificate; hash rules, which recognize specific software based on a hash of the software; path rules, which recognize software based on the location in which the software is stored; registry path rules, which recognize software based on the location of the software as it is stored in the registry; and Internet zone rules, which recognize software based on the zone of the Internet from which the software is downloaded.

See also: default security level; hash; path; registry; software restriction policies

SOM

See definition for: scope of management (SOM)

source document

The document where a linked or embedded object was originally created.

See also: embedded object; linked object

source journaling

For Message Queuing, the process of storing a copy of an outgoing message. Source journaling is configured on a message basis, and it is set by the sending application. When source journaling is enabled, a copy of the message is put in the source journal of the source computer when the message arrives at the destination (target) queue.

See also: journal; Message Queuing; target journaling

spanned volume

A dynamic volume consisting of disk space on more than one physical disk. You can increase the size of a spanned volume by extending it onto additional dynamic disks. You can create spanned volumes only on dynamic disks. Spanned volumes are not fault tolerant and cannot be mirrored.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; simple volume; volume

sparse file

A file that is handled in a way that requires much less disk space than would otherwise be needed. Sparse support allows an application to create very large files without committing disk space for those regions of the file that contain only zeros. For example, you can use sparse support to work with a 42-GB file in which you need to write data only to the first 64 KB (the rest of the file is zeroed).

special permissions

On NTFS volumes, a custom set of permissions. You can customize permissions on files and directories by selecting the individual components of the standard sets of permissions.

See also: NTFS file system; permission; volume

SPID

See definition for: Service Profile Identifier (SPID)

split horizon

A route-advertising algorithm that prevents the advertising of routes in the same direction in which they were learned. Split horizon helps prevent routing loops.

See also: poison reverse; routing

splitting

A Briefcase command that separates the copy of the file inside Briefcase from the copy outside Briefcase.

spooling

A process on a server in which print documents are stored on a disk until a printer is ready to process them. A spooler accepts each document from each client, stores it, then sends it to a printer when the printer is ready.

See also: print spooler

SQL

See definition for: structured query language (SQL)

SSL

See definition for: Secure Sockets Layer (SSL)

stand-alone certification authority

A certification authority (CA) that is not integrated with Active Directory.

See also: Active Directory; certification authority (CA)

stand-alone root

A DFS namespace, the configuration information for which is stored locally on the host server. The path to access the root or a link starts with the host server name. A stand-alone root has only one root target. There is no root-level fault tolerance. Therefore, when the root target is unavailable, the entire DFS namespace is inaccessible.

See also: DFS namespace; root target

stand-alone server

A server that runs Windows 2000 or Windows Server 2003, but does not participate in a domain. A stand-alone server has only its own database of users, and it processes logon requests by itself. A stand-alone server does not share account information with other computers and cannot provide access to domain accounts, but it can participate in a workgroup.

See also: domain; member server; workgroup

start-of-authority (SOA) resource record

A record that indicates the starting point or original point of authority for information stored in a zone. The SOA resource record (RR) is the first RR created when adding a new zone. It also contains several parameters used by other computers that use DNS to determine how long they will use information for the zone and how often updates are required.

See also: authoritative; Domain Name System (DNS); resource record (RR); zone

Startrom.com

A program used by Remote Installation Services (RIS) that is the first file downloaded to the client using Trivial File Transfer Protocol (TFTP). Startrom.com is a small program that displays the Press F12 for Network Service Boot prompt. If F12 is pressed within three seconds, the Client Installation Wizard (OSChooser) is downloaded to begin the remote installation process.

See also: Remote Installation Services (RIS); Trivial File Transfer Protocol (TFTP)

startup environment

In dual-boot or multiple-boot systems, the configuration settings that specify which system to start and how each system should be started.

See also: dual boot; multiple boot

stateless

As related to servers, not involving the update of a server-side database based on a client request. As related to the handling of files, the content of the file is not modified or noticed. For Web servers, a stateless client request, which members of a Network Load Balancing cluster can process, is one that returns a static Web page to the client.

See also: Network Load Balancing cluster

static dialog box

A scripted dialog box between the client computer and an intermediary device. This kind of dialog box requires no response from the user.

See also: client

static load balancing

The process of manually moving a group between nodes to balance the load across the nodes.

See also: group; node

static routes

Routes in a routing table that are permanent until changed by a network administrator or by an automatically scheduled auto-static update.

See also: router; routing

status area

See definition for: notification area

status bar

A line of information related to the current program. The status bar is usually located at the bottom of a window. Not all windows have a status bar.

Stop error

A serious error that affects the operating system and that could place data at risk. The operating system generates an obvious message, a screen with the Stop error, rather than continuing on and possibly corrupting data. Also called a fatal system error.

See also: Stop screen

Stop screen

A blue character-mode screen that appears when Windows encounters a condition that compromises safe system operation and the system stops. Commonly referred to as a blue screen or bug check.

See also: Stop error

storage-class resource

A required dependency for many resource types. Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition, provide one storage-class resource: Physical Disk. However, your vendor or reseller might supply other storage-class resource types.

See also: dependency; resource types

strict RFC checking

For DNS, a form of domain name checking that examines characters used in DNS names for compliance with DNS naming requirements and valid character usage as specified in RFC 1123, Requirements for Internet Hosts - Applications and Support. For strict RFC compliance, DNS domain names will use name labels made up only of valid uppercase and lowercase letters, number characters, and hyphens (A through Z, a through z, 0 through 9, -), separated by periods.

See also: domain name; Domain Name System (DNS); label; loose name checking; Request for Comments (RFC)

string

A group of characters or character bytes handled as a single entity. Computer programs use strings to store and transmit data and commands. Most programming languages consider strings (such as 2674:gstmn) as distinct from numeric values (such as 470924).

See also: transmitting station ID (TSID) string

striped volume

A dynamic volume that stores data in stripes on two or more physical disks. Data in a striped volume is allocated alternately and evenly (in stripes) across the disks. Striped volumes offer the best performance of all the volumes that are available in Windows, but they do not provide fault tolerance. If a disk in a striped volume fails, the data in the entire volume is lost. You can create striped volumes only on dynamic disks. Striped volumes cannot be mirrored or extended.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; volume

strong password

A password that provides an effective defense against unauthorized access to a resource. A strong password is at least six characters long, does not contain all or part of the users account name, and contains at least three of the four following categories of characters: uppercase characters, lowercase characters, base 10 digits, and symbols found on the keyboard (such as !, @, #).

See also: password; password policy; weak password

structured query language (SQL)

A widely accepted standard database sublanguage used in querying, updating, and managing relational databases.

stub area

An Open Shortest Path First (OSPF) area that does not advertise individual external networks. A stub area blocks external routes and therefore reduces the amount of memory required on the internal routers located in the stub area. To keep the topology database size small, routing to all external networks in a stub area is done through a default route (destination 0.0.0.0 with the subnet mask of 0.0.0.0). In OSPF, any destination that you cannot reach through an intra-area or inter-area router is reachable through the default route.

See also: Open Shortest Path First (OSPF); routing

stub zone

A copy of a zone that contains only the resource records required to identify the authoritative DNS servers for that zone. A DNS server that hosts a parent zone and a stub zone for one of the parent zone's delegated child zones can receive updates from the authoritative DNS servers for the child zone.

See also: authoritative; DNS server; resource record (RR); zone

subdomain

A DNS domain located directly beneath another domain name (the parent domain) in the namespace tree. For example, example.microsoft.com would be a subdomain of the domain microsoft.com. Also called child domain.

See also: child domain; domain; Domain Name System (DNS); parent domain

subject

In public key cryptography, an entity that requests or holds a certificate. A subject can be a user, a computer, or any other device capable of requesting or using a certificate.

See also: certificate; public key cryptography

subkey

An element of the registry that contains entries or other subkeys. A tier of the registry that is immediately below a key or a subtree (if the subtree has no keys).

See also: descendent key; entry; key; registry; subtree

subnet

A subdivision of an Internet Protocol (IP) network. Each subnet has its own unique subnetted network ID.

See also: Internet Protocol (IP)

subnet bandwidth management (SBM)

An Internet Engineering Task Force (IETF) standard that enables administrative control at the subnet level.

See also: Internet Engineering Task Force (IETF)

subtree

Any node within a tree, along with any selection of connected descendant nodes.

The highest level of the registry (for example, HKEY_LOCAL_MACHINE).

See also: key; node; registry; subkey

superscope

An administrative grouping feature that supports a DHCP server's ability to use more than scope for each physical interface and subnet. Superscopes are useful under the following conditions: If more DHCP clients must be added to a network than were originally planned, if an Internet Protocol (IP) network is renumbered, or if two or more DHCP servers are configured to provide scope redundancy and fault-tolerant design DHCP service for a single subnet. Each superscope can contain one or more member scopes (also known as child scopes).

See also: DHCP client; DHCP server; fault tolerance; scope; subnet

SVC

See definition for: switched virtual circuit (SVC)

switch type

The type of interface to which your Integrated Services Digital Network (ISDN) device is being attached. Also called switch.

See also: B-channel; D-channel; Integrated Services Digital Network (ISDN)

switched virtual circuit (SVC)

A connection established dynamically between devices on an asynchronous transfer mode (ATM) network through the use of signaling.

See also: asynchronous transfer mode (ATM)

switching hub

A central network device (multiport hub) that forwards packets to specific ports rather than, as in conventional hubs, broadcasting every packet to every port. In this way, the connections between ports deliver the full bandwidth available.

See also: hub; packet; port

symmetric encryption

An encryption algorithm that requires the same secret key to be used for both encryption and decryption. Because of its speed, symmetric encryption is typically used when a message sender needs to encrypt large amounts of data. Also called secret key encryption.

See also: public key encryption

symmetric key

A single key that is used with symmetric encryption algorithms for both encryption and decryption.

See also: encryption; key; symmetric encryption

synchronous

Each application or command runs in the order listed, and each item must finish before the next command is run.

syntax

The order in which a command must be typed, and the elements that follow the command.

See also: command prompt window

Syskey

A tool used to configure the startup key, a random, 128-bit, symmetric cryptographic key created at system startup and used to encrypt all of the user's symmetric cryptographic keys.

See also: encryption; symmetric key

system access control list (SACL)

The part of an object's security descriptor that specifies which events are to be audited per user or group. Examples of auditing events are file access, logon attempts, and system shutdowns.

See also: auditing; discretionary access control list (DACL); event; object; security descriptor

system area network (SAN)

A network configuration, usually on a separate Internet Protocol (IP) subnet, that gives data a direct path to system hardware.

See also: Internet Protocol (IP); subnet

system default profile

The user profile that is loaded when Windows is running and no user is logged on. When the Begin Logon dialog box is visible, the system default profile is loaded.

See also: user profile

system disk

A disk that contains the MS-DOS system files necessary to start MS-DOS.

See also: MS-DOS (Microsoft Disk Operating System)

system files

Files used by Windows to load, configure, and run the operating system. Generally, system files must never be deleted or moved.

System menu

A menu that contains commands you can use to manipulate a window or close a program. You click the program icon at the left of the title bar to open the System menu.

system partition

The partition that contains the hardware-specific files needed to load Windows (for example, Ntldr, Osloader, Boot.ini, Ntdetect.com). The system partition can be, but does not have to be, the same as the boot partition.

See also: boot partition; partition

System Policy

A Windows NT 4.0-style policy based on registry settings made using Poledit.exe, the System Policy Editor.

See also: policy; registry

System State

In Backup, a collection of system-specific data maintained by the operating system that must be backed up as a unit. It is not a backup of the entire system. The System State data includes the registry, COM+ Class Registration database, system files, boot files, and files under Windows File Protection. For servers, the System State data also includes the Certificate Services database (if the server is a certificate server). If the server is a domain controller, the System State data also includes the Active Directory database and the SYSVOL directory. If the server is a node in a cluster, it includes the Cluster database information. The IIS Metabase is included if Internet Information Services (IIS) is installed.

See also: Active Directory; cluster; domain controller; Internet Information Services (IIS); node; registry; SYSVOL

system variables

Storage locations for data that are defined by the operating system and that are the same regardless of who is logged on at the computer. (Users who are also members of the Administrators group can add new variables or change the values.)

See also: Administrators group

system volume

The volume that contains the hardware-specific files that are needed to load Windows on x86-based computers with a basic input/output system (BIOS). The system volume can be, but does not have to be, the same volume as the boot volume.

See also: basic input/output system (BIOS); boot volume; volume; x86

systemroot

The path and folder name where the Windows system files are located. Typically, this is C:\Windows, although you can designate a different drive or folder when you install Windows. You can use the value %systemroot% to replace the actual location of the folder that contains the Windows system files. To identify your systemroot folder, click Start, click Run, type %systemroot%, and then click OK.

Systems Management Server (SMS)

A Microsoft product that includes inventory collection, software deployment, and diagnostic tools. SMS automates the task of upgrading software, allows remote problem solving, provides asset management information, and monitors software usage, computers, and networks.

SYSVOL

A shared directory that stores the server copy of the domain's public files, which are replicated among all domain controllers in the domain.

See also: directory; domain; domain controller

T

T.120

The International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T) standard for multipoint data conferencing. T.120 provides the protocols for establishing and managing data flow, connections, and conferences. Support for T.120 enables data transfer from conferencing applications, such as file transfer and application sharing, to operate in conjunction with H.323 connections.

See also: H.323; International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T)

tag

For Indexing Service, one or more terms that identify an element in a query, such as weight, phrase, property, or regular expression. For example, the tag {prop name=created} specifies the Created property in a query.

See also: property; query

TAPI

See definition for: Telephony API (TAPI)

TAPI server security file

A file that stores information about the telephony devices for each installed telephony service provider, including the addresses that are assigned to each device and the users who are authorized to use each device.

See also: Telephony API (TAPI)

target

The mapping destination of a DFS root or link, which corresponds to a physical folder that has been shared on the network.

See also: DFS link; DFS root

target journaling

For Message Queuing, the process of storing copies of incoming messages. Target journaling is configured on a queue basis. When target journaling is enabled, a copy of each incoming message is placed in the target journal when the message is retrieved (read) from the destination queue.

See also: journal; Message Queuing; source journaling

Task Manager

A tool that provides information about programs and processes running on the computer. Using Task Manager, you can end or run programs, end processes, and display a dynamic overview of your computer's performance.

See also: process; program

taskbar

The bar that contains the Start button and appears by default at the bottom of the desktop. You can click the taskbar buttons to switch between programs. You can also hide the taskbar, move it to the sides or top of the desktop, and customize it in other ways.

See also: desktop; notification area; taskbar button

taskbar button

A button that appears on the taskbar and corresponds to a running application.

See also: taskbar

taskpad

A details pane view that displays shortcuts to commands that are available for the selected snap-in in the console tree. Users can run a command by clicking a task.

See also: console tree; details pane; snap-in

TCP/IP

See definition for: Transmission Control Protocol/Internet Protocol (TCP/IP)

TDI

See definition for: Transport Driver Interface (TDI)

teaming network adapters

A configuration method that provides fault tolerance by grouping network adapters on multiple ports to a single physical network segment. For example, if connections through one port fail (due to failure of the adapter, cable, switch port, or switch), another port is activated automatically. Teaming network adapters work transparently to the operating system and other devices on the network.

See also: device; fault tolerance; network adapter; port

Telephony API (TAPI)

An application programming interface (API) used by communications programs to work with telephony and network services. Communications programs like HyperTerminal and Phone Dialer use TAPI to dial, answer, and route telephone calls on conventional telephony devices, including PBXs, modems, and fax machines. TAPI 3.0 also provides Internet Protocol (IP) telephony support, which Phone Dialer and other programs use to transmit, route, and control real-time audio and video signals over IP-based networks such as the Internet.

See also: application programming interface (API); Internet Protocol (IP); modem (modulator/demodulator); service

telephony switch

A computer or electromechanical device that controls the routing and operation of a signal path.

Telnet

A protocol that enables an Internet user to log on to and enter commands on a remote computer linked to the Internet, as if the user were using a text-based terminal directly attached to that computer. Telnet is part of the TCP/IP suite of protocols. The term telnet also refers to the software (client or server component) that implements this protocol.

See also: protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

temporary address

An Internet Protocol version 6 (IPv6) address that uses an interface identifier that changes over time and that is not derived from a hardware property, such as a media access control (MAC) address. A temporary address makes it difficult to track the identity of a computer on the Internet across sessions.

See also: Internet Protocol (IP); media access control (MAC) address

Terminal Services

The underlying technology that enables Remote Desktop, Remote Assistance, and Terminal Server.

See also: Terminal Services Licensing

Terminal Services Licensing

Software that provides the ability to register and track licenses for Terminal Services clients.

See also: Terminal Services

terminate-and-stay-resident (TSR) program

A program running under MS-DOS that remains loaded in memory even when it is not running, so that it can be quickly invoked for a specific task performed while any other application is operating.

See also: MS-DOS (Microsoft Disk Operating System)

test queue

For Message Queuing, a queue that stores sent test messages.

See also: Message Queuing; queue

text box

In a dialog box, a box in which you type information needed to carry out a command. The text box may be blank or may contain text when the dialog box opens.

text mode

The portion of Setup that uses a text-based interface.

See also: GUI mode; Setup

TFTP

See definition for: Trivial File Transfer Protocol (TFTP)

TGS

See definition for: ticket-granting service (TGS)

TGT

See definition for: ticket-granting ticket (TGT)

Thread Count

In Task Manager, the number of threads running in a process.

See also: process; Task Manager

thumbnail

A miniature version of an image that is often used for quick browsing through multiple images.

ticket

A set of identification data for a security principal, issued by a domain controller for purposes of user authentication. Two forms of tickets in Windows are ticket-granting tickets (TGTs) and service tickets.

See also: authentication; domain controller; service ticket; ticket-granting ticket (TGT)

ticket-granting service (TGS)

A Kerberos V5 service provided by the Kerberos V5 Key Distribution Center (KDC) service that issues service tickets that allow users to authenticate to services in a domain.

See also: Kerberos V5 authentication protocol; Key Distribution Center (KDC); service ticket; ticket-granting ticket (TGT)

ticket-granting ticket (TGT)

A credential issued to a user by the Kerberos Key Distribution Center (KDC) when the user logs on. The user must present the TGT to the KDC when requesting session tickets for services. Because a TGT is normally valid for the life of the user's logon session, it is sometimes called a user ticket.

See also: Kerberos V5 authentication protocol; Key Distribution Center (KDC); ticket-granting service (TGS)

time server

A computer that periodically synchronizes the time on all computers within a network. This ensures that the time used by network services and local functions remains accurate.

See also: server

time slice

A brief period of time during which a particular task is given control of the microprocessor in a time-sharing multitasking environment. A computer's processor is allocated to an application, usually measured in milliseconds. Also called quantum.

time stamp

A certification specifying that a particular message existed at a specific time and date. In a digital context, trusted third parties generate a trusted time stamp for a particular message by having a time stamping service append a time value to a message and then digitally signing the result.

See also: digital signature; service

Time to Live (TTL)

A timer value included in packets sent over TCP/IP-based networks that tells the recipients how long to hold or use the packet or any of its included data before expiring and discarding the packet or data. For DNS, TTL values are used in resource records within a zone to determine how long requesting clients should cache and use this information when it appears in a query response answered by a DNS server for the zone.

See also: DNS server; Domain Name System (DNS); packet; resource record (RR); Transmission Control Protocol/Internet Protocol (TCP/IP); zone

time-out error

A condition where an expected character is not received in time. When this condition occurs, the software assumes that the data has been lost and requests that it be resent.

title bar

The horizontal bar at the top of a window that contains the name of the window. On many windows, the title bar also contains the program icon, the Maximize, Minimize, and Close buttons, and the optional ? button for context-sensitive Help. To display a menu with commands such as Restore and Move, right-click the title bar.

See also: maximize; minimize

TLS

See definition for: Transport Layer Security (TLS)

token

Any nonreducible textual element in data that is being parsed. For example, the use in a program of a variable name, a reserved word, or an operator. Storing tokens as short codes shortens program files and speeds execution.

For networking, a unique structured data object or message that circulates continuously among the nodes of a token ring and describes the current state of the network. Before any node can send a message on the network, it must first wait to control the token.

See also: Token Ring

Token Ring

The Institute of Electrical and Electronics Engineers (IEEE) 802.5 standard that uses a token-passing technique for media access control (MAC). Token Ring supports media of both shielded and unshielded twisted pair wiring for data rates of 4 megabits per second (Mbps) and 16 megabits per second.

See also: client; token

tombstone

In Active Directory, an object that is removed from the directory but not yet deleted.

See also: Active Directory; directory; object

tombstone lifetime

The length of time that an object lives as a tombstone in the directory before being collected as garbage.

See also: directory; object; tombstone

top-level domains

Domain names that are rooted hierarchically at the first tier of the domain namespace directly beneath the root (.) of the DNS namespace. On the Internet, top-level domain names such as .com and .org are used to classify and assign second-level domain names (such as microsoft.com) to individual organizations and businesses according to their organizational purpose.

See also: domain; domain name; Domain Name System (DNS); domain namespace; root; second-level domain

topological database

An overview of networks and how they relate to routers. Routers in the same area have the same topological database.

See also: router

topology

The physical layout of computers, cables, switches, routers, and other components of a network. Topology also refers to the underlying network architecture, such as Ethernet or Token Ring.

In Active Directory replication, the set of connections that domain controllers use to replicate information among themselves.

See also: Active Directory replication; domain controller

touch-tone dialing

A form of dialing that uses multiple-tone signaling. The user hears a series of tones (beeps) when dialing. Push-button telephones usually use touch-tone dialing.

See also: pulse dialing

trace log

A type of log generated when the user selects a trace data provider using the Performance tool. Trace logs differ from counter-data logs in that they measure data continuously rather than taking periodic samples.

transaction

For Message Queuing, the pairing of two or more actions that are performed together as a single action; the action succeeds or fails as a whole. Using Microsoft Distributed Transaction Coordinator (MS DTC) ensures that either both actions succeed or neither is executed.

See also: Message Queuing; Microsoft Distributed Transaction Coordinator (MS DTC); transactional dead-letter queue; transactional message

transactional dead-letter queue

For Message Queuing, a queue that stores transactional messages that cannot reach their destination queue. Transactional dead-letter queues store failed messages on the computer on which the message expired. Messages in these queues are written to disk and are therefore recoverable.

See also: dead-letter queue; Message Queuing; queue; transaction

transactional message

For Message Queuing, a message that can be sent and received only from within a transaction. This type of message returns to its prior state when a transaction is terminated abruptly. A transactional message is removed from a queue only when the transaction is committed; otherwise, it remains in the queue and can be subsequently read during another transaction.

See also: Message Queuing; queue; transaction

transitive trust

A trust relationship that flows throughout a set of domains, such as a domain tree, and forms a relationship between a domain and all domains that trust that domain. For example, if domain A has a transitive trust with domain B, and domain B trusts domain C, then domain A trusts domain C. Transitive trusts can be one-way or two-way, and they are required for Kerberos-based authentication and Active Directory replication.

See also: Active Directory; Active Directory replication; domain tree; Kerberos V5 authentication protocol; nontransitive trust; one-way trust; trust relationship; two-way trust

Transmission Control Protocol/Internet Protocol (TCP/IP)

A set of networking protocols widely used on the Internet that provides communications across interconnected networks of computers with diverse hardware architectures and various operating systems. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic.

See also: Internet Protocol (IP); protocol

transmitting station ID (TSID) string

A string that specifies the transmitter subscriber ID sent by the fax machine when sending a fax to a receiving machine. This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the called subscriber ID.

See also: called subscriber ID (CSID) string; string

Transport Driver Interface (TDI)

A common set of routines for network layer components that communicate with the session layer of the Open Systems Interconnection (OSI) model. These routines allow software components above and below the transport layer to be mixed and matched without reprogramming.

See also: Open Systems Interconnection (OSI) reference model

Transport Layer Security (TLS)

A standard protocol that is used to provide secure Web communications on the Internet or intranets. It enables clients to authenticate servers or, optionally, servers to authenticate clients. It also provides a secure channel by encrypting communications. TLS is the latest and a more secure version of the SSL protocol.

See also: authentication; protocol; Secure Sockets Layer (SSL)

transport provider

The driver and support files that provide transport services in a networking environment.

trap

In Simple Network Management Protocol (SNMP), a message sent by an agent to a management system indicating that an event has occurred on the host running the agent.

See also: agent; event; host; Simple Network Management Protocol (SNMP)

tree root trust

A trust that is automatically established when you add a new domain tree (the tree root domain) to an Active Directory forest (the forest root domain). Tree root trusts are transitive and two-way.

See also: Active Directory; domain tree; forest; root domain; transitive trust; trust relationship; two-way trust

tree view

A hierarchical representation of the folders, files, disk drives, and other resources connected to a computer or network. For example, Windows Explorer uses a tree view to display the resources that are attached to a computer or a network.

See also: resource

triggered update

A type of Routing Information Protocol (RIP) announcement that occurs when network topology changes. With triggered updates, the update announcing network topology changes is sent almost immediately rather than waiting for the next periodic announcement. Triggered updates improve the convergence time (the time it takes for a router to update its routing tables) of RIP internetworks, but at the cost of additional broadcast traffic while the triggered updates are propagated.

See also: routing; Routing Information Protocol (RIP)

Triple DES (3DES)

An implementation of Data Encryption Standard (DES) encryption that employs three iterations of cryptographic operations on each segment of data. Each iteration uses a 56-bit key for encryption, which yields 168-bit encryption for the data. Although 3DES is slower than DES because of the additional cryptographic calculations, its protection is far stronger than DES.

See also: cryptography; Data Encryption Standard (DES); encryption

Trivial File Transfer Protocol (TFTP)

A protocol used to download the initial files needed to begin the installation process.

See also: protocol

Trojan horse

A program that masquerades as another common program in an attempt to receive information. An example of a Trojan horse is a program that behaves like a system logon to retrieve user names and password information that the writers of the Trojan horse can later use to break into the system.

See also: virus

TrueType fonts

Fonts that are scalable and sometimes generated as bitmaps or soft fonts, depending on the capabilities of your printer. TrueType fonts are device-independent fonts that are stored as outlines. They can be sized to any height, and they can be printed exactly as they appear on the screen.

See also: font

trust path

A series of trust relationships that authentication requests must follow between domains. Domain controllers determine the trust path for all authentication requests between a domain controller in the trusting domain and a domain controller in the trusted domain.

See also: authentication; domain; domain controller; trust relationship

trust relationship

A logical relationship established between domains to allow pass-through authentication, in which a trusting domain honors the logon authentications of a trusted domain. User accounts and global groups defined in a trusted domain can be given rights and permissions in a trusting domain, even though the user accounts or groups don't exist in the trusting domain's directory.

See also: authentication; domain; global group; group; permission; user account

trusted domain object (TDO)

An object that represents one direction of a trust relationship. When trust relationships are established, unique TDOs are created and stored in the domain. For example, when a two-way trust is established, two TDOs are created.

See also: domain; object; trust relationship; two-way trust

TTL

See definition for: Time to Live (TTL)

TTY

A communications device that consists of a keyboard and a printer. Each keystroke on the sending machine generates a character code that is sent to the receiving machine, which prints the character. TTY is usually associated with a video display that is treated like a teletypewriter or that emulates one.

tunnel

A logical connection over which data is encapsulated. Typically, both encapsulation and encryption are performed, and the tunnel is a private, secure link between a remote user or host and a private network.

See also: encryption; host; tunnel server; voluntary tunnel

tunnel server

A server or router that terminates tunnels and forwards traffic to the hosts on the target network.

See also: host; router; server; tunnel

tunneling protocol

A communication standard used to manage tunnels and encapsulate private data. Data that is tunneled must also be encrypted to be a virtual private network (VPN) connection. Two commonly used tunneling protocols are the Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP).

See also: Layer Two Tunneling Protocol (L2TP); Point-to-Point Tunneling Protocol (PPTP); virtual private network (VPN)

two-way trust

A trust relationship between two domains in which both domains trust each other. For example, domain A trusts domain B, and domain B trusts domain A. All parent-child trusts are two-way.

See also: domain; one-way trust; parent-child trust; trust relationship

Type 1 fonts

Scalable fonts designed to work with PostScript devices.

See also: font; PostScript

U

UAM

See definition for: user authentication module (UAM)

UBR

See definition for: unspecified bit rate (UBR)

UCS

See definition for: Universal Character Set (UCS)

UCS Transformation Format 8 (UTF-8)

A character set for protocols evolving beyond the use of ASCII. The UTF-8 protocol provides for support of extended ASCII characters and translation of UCS-2, an international 16-bit Unicode character set. UTF-8 enables a far greater range of names than can be achieved using ASCII or extended ASCII encoding for character data.

See also: American Standard Code for Information Interchange (ASCII); Unicode; Universal Character Set (UCS)

UDDI

See definition for: Universal Description, Discovery, and Integration (UDDI)

UDP

See definition for: User Datagram Protocol (UDP)

UDP socket

A socket that transmits datagrams over the User Datagram Protocol (UDP).

See also: datagram; socket; User Datagram Protocol (UDP)

unallocated space

Available disk space that is not allocated to any volume. The type of volume that you can create on unallocated space depends on the disk type. On basic disks, you can use unallocated space to create primary or extended partitions. On dynamic disks, you can use unallocated space to create dynamic volumes.

See also: basic disk; dynamic disk; extended partition; logical drive; object; partition; primary partition; volume

unattended Setup

An automated, hands-free method of installing Windows. During installation, unattended Setup uses an answer file to supply data to Setup instead of requiring that an administrator or end user interactively provide the answers.

See also: Setup

UNC

See definition for: Universal Naming Convention (UNC)

UNC (Universal Naming Convention) name

The full name of a resource on a network. It conforms to the \\servername\sharename syntax, where servername is the name of the server and sharename is the name of the shared resource. UNC names of directories or files can also include the directory path under the share name, with the following syntax:

\\servername\sharename\directory\filename

See also: resource

UNI

See definition for: user-to-network interface (UNI)

unicast

An address that identifies a specific, globally unique host.

See also: host

Unicode

A character encoding standard developed by the Unicode Consortium that represents almost all of the written languages of the world. The Unicode character repertoire has multiple representation forms, including UTF-8, UTF-8, and UTF-32. Most Windows interfaces use the UTF-16 form.

See also: American Standard Code for Information Interchange (ASCII); UCS Transformation Format 8 (UTF-8); Universal Character Set (UCS)

uninstall

When referring to software, the act of removing program files and folders from your hard disk and removing related data from your registry so the software is no longer available.

When referring to a device, the act of removing the corresponding device drivers from your hard disk and physically removing the device from your computer.

See also: device; device driver; install

uninterruptible power supply (UPS)

A device that connects a computer and a power source to ensure that electrical flow is not interrupted. UPS devices use batteries to keep the computer running for a period of time after a power failure. UPS devices usually provide protection against power surges and brownouts as well.

Universal Asynchronous Receiver/Transmitter (UART)

An integrated circuit (silicon chip) that is commonly used in microcomputers to provide asynchronous communication. The UART provides parallel-to-serial conversion of data to be transmitted and serial-to-parallel conversion of data received.

See also: asynchronous communication

Universal Character Set (UCS)

An international standard character set reference that is part of the Unicode standard. The most widely held existing version of the UCS standard is UCS-2, which specifies 16-bit character values currently accepted and recognized for use to encode most of the world's languages.

See also: American Standard Code for Information Interchange (ASCII); UCS Transformation Format 8 (UTF-8); Unicode

Universal Description, Discovery, and Integration (UDDI)

An industry specification for publishing and locating information about Web services. UDDI defines a standards-based way to store and retrieve information about Web services, Web service providers, binding information, and technical interface definitions—all classified using a set of standard or custom classification schemes.

See also: binding; service

universal group

A security or distribution group that can contain users, groups, and computers from any domain in its forest as members.

Universal security groups can be granted rights and permissions on resources in any domain in the forest.

See also: distribution group; domain; forest; security group

Universal Naming Convention (UNC)

A convention for naming files and other resources beginning with two backslashes (\), indicating that the resource exists on a network computer. UNC names conform to the \\servername\sharename syntax, where servername is the server's name and sharename is the name of the shared resource. The UNC name of a directory or file can also include the directory path after the share name, by using the following syntax: \\servername\sharename\directory\filename.

universal serial bus (USB)

An external bus that supports Plug and Play installation. Using USB, you can connect and disconnect devices without shutting down or restarting your computer. You can use a single USB port to connect up to 127 peripheral devices, including speakers, telephones, CD-ROM drives, joysticks, tape drives, keyboards, scanners, and cameras. A USB port is usually located on the back of your computer near the serial port or parallel port.

See also: bus; Plug and Play; port

unsigned driver

A driver that is not supported and that is not certified to work with a particular version of Windows.

See also: signed driver; Windows Logo Program

unspecified bit rate (UBR)

An asynchronous transfer mode (ATM) service type that does not include any service guarantees.

See also: asynchronous transfer mode (ATM)

upcasing

The method of case-insensitive handling for network basic input/output system (NetBIOS) names. Upcasing is used by Windows to convert any lowercase letters entered in NetBIOS names to equivalent uppercase letters. For example, the name host1 is case-converted to HOST1.

See also: downcasing; network basic input/output system (NetBIOS)

upgrade

When referring to software, to update existing program files, folders, and registry entries to a more recent version. Upgrading, unlike performing a new installation, leaves existing settings and files in place.

See also: install; registry

UPN

See definition for: user principal name (UPN)

UPS

See definition for: uninterruptible power supply (UPS)

UPS service

A service that manages an uninterruptible power supply (UPS) connected to a computer.

See also: service; uninterruptible power supply (UPS)

USB

See definition for: universal serial bus (USB)

user account

In Active Directory, an object that consists of all the information that defines a domain user, which includes user name, password, and groups in which the user account has membership. User accounts can be stored in either Active Directory or on your local computer.

For computers running Windows XP Professional and member servers running Windows Server 2003, use Local Users and Groups to manage local user accounts. For domain controllers running Windows Server 2003, use Active Directory Users and Computers to manage domain user accounts.

See also: Active Directory; group; member server; object; password; user name

user authentication module (UAM)

A software component that prompts clients for their user names and passwords.

See also: password; user name

user class

An administrative feature that allows DHCP clients to be grouped logically according to a shared or common need. For example, a user class can be defined and used to allow similar DHCP leased configuration for all client computers in a specific building or site location.

See also: DHCP client; Dynamic Host Configuration Protocol (DHCP); lease

User Datagram Protocol (UDP)

A Transmission Control Protocol (TCP) complement that offers a connectionless datagram service that guarantees neither delivery nor correct sequencing of delivered packets (much like Internet Protocol (IP)).

See also: datagram; Internet Protocol (IP); packet; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

user mode

The processing mode in which applications run.

user name

A unique name identifying a user account to Windows. An account's user name must be unique among the other group names and user names within its own domain or workgroup.

See also: domain; user account; workgroup

USER object

An object from Window Manager, which includes windows, menus, cursors, icons, hooks, accelerators, monitors, keyboard layouts, and other internal objects. In Task Manager, the number of USER objects currently being used by a process.

See also: Task Manager

user password

The password stored in each user's account. Each user generally has a unique user password and must type that password when logging on or accessing a server.

See also: password; user account

user principal name (UPN)

A user account name (sometimes referred to as the user logon name) and a domain name identifying the domain in which the user account is located. This is the standard usage for logging on to a Windows domain. The format is as follows: someone@example.com (as for an e-mail address).

See also: domain; domain name; user principal name (UPN) suffix

user principal name (UPN) suffix

The part of the user principal name (UPN) to the right of the @ character. The default UPN suffix for a user account is the DNS domain name of the domain that contains the user account. Alternative UPN suffixes may be added to simplify administration and user logon processes by providing a single UPN suffix for all users. The UPN suffix is only used within the Active Directory forest, and it is not required to be a valid DNS domain name.

See also: Active Directory; domain; domain name; Domain Name System (DNS); forest; user account; user principal name (UPN)

user profile

A file that contains configuration information for a specific user, such as desktop settings, persistent network connections, and application settings. Each user's preferences are saved to a user profile that Windows uses to configure the desktop each time a user logs on.

See also: desktop

user rights

Tasks that a user is permitted to perform on a computer system or domain. There are two types of user rights: privileges and logon rights. An example of a privilege is the right to shut down the system. An example of a logon right is the right to log on to a computer locally. Both types are assigned by administrators to individual users or groups as part of the security settings for the computer.

See also: domain; group; logon rights; privilege

user rights policy

Security settings that manage the assignment of rights to groups and user accounts.

See also: group; user account; user rights

user-to-network interface (UNI)

The interface between asynchronous transfer mode (ATM) users or end stations and an ATM switch or network. The UNI is defined in the ATM Forum UNI documents.

See also: asynchronous transfer mode (ATM)

UTF-8

See definition for: UCS Transformation Format 8 (UTF-8)

V

V.34

A data transmission standard that provides for up to 33,600 bits per second (bps) communications over telephone lines. It defines a full-duplex (two-way) modulation technique and includes error-correcting and negotiation.

See also: bits per second (bps); full-duplex; modulation standards; V.90

V.90

A data transmission standard that provides for up to 56,000 bits per second (bps) communications over telephone lines. The transmission speed from the client-side modem is 33,600 bps, the same as for V.34. The transmission speed from the host-side modem, such as an Internet service provider (ISP) or corporate network, is up to 56,000 bps, with an average speed of 40,000 to 50,000 bps. When the host-side modem does not support this standard, the alternative is V.34.

See also: bits per second (bps); client; host; Internet service provider (ISP); modem (modulator/demodulator); modulation standards; V.34

validation

The process of comparing files on local volumes with their associated data in secondary storage by Remote Storage. Volumes that are validated ensure that the correct data is recalled from remote storage when a user attempts to open the file from a local volume.

See also: Remote Storage; volume

variable

In programming, a named storage location capable of containing a certain type of data that can be modified during program execution.

System environment variables are defined by the operating systems in the Windows Server 2003 family, and they are the same no matter who is logged on to the computer. Administrator group members can add new variables or change the values, however.

User environment variables can be different for each user of a particular computer. They include any environment variables you want to define or variables defined by your applications, such as the path where application files are located.

See also: environment variable

variable bit rate (VBR)

An asynchronous transfer mode (ATM) service type that guarantees service based on average and peak traffic rates. VBR is used for traffic that requires little or no cell loss. It transmits data in spurts, or bursts, rather than in a continuous stream.

See also: asynchronous transfer mode (ATM); service

VBR

See definition for: variable bit rate (VBR)

VCI

See definition for: virtual channel identifier (VCI)

VDM

See definition for: virtual DOS machine (VDM)

vector

For Indexing Service, an ordered series of words or numbers used in a query. For example, a single document can have (Scott Cooper; Don Hall; Amy Egert) as a vector of coauthors.

See also: Indexing Service; query

vector font

A font rendered from a mathematical model, in which each character is defined as a set of lines drawn between points. Vector fonts can be cleanly scaled to any size or aspect ratio.

See also: font; plotter font

vendor class

An administrative feature that allows DHCP clients to be identified and leased according to their vendor and hardware configuration type. For example, assigning a vendor class of HP to a printer vendor such as Hewlett-Packard would allow all Hewlett-Packard printers to be managed as a single unit so they could all obtain a similar DHCP leased configuration.

See also: DHCP client; Dynamic Host Configuration Protocol (DHCP); lease

video adapter

An expansion board that plugs into a personal computer to give it display capabilities. A computer's display capabilities depend on both the logical circuitry (provided in the video adapter) and the monitor. Each adapter offers several different video modes. The two basic categories of video modes are text and graphics. Within the text and graphics modes, some monitors also offer a choice of resolutions. At lower resolutions a monitor can display more colors.

Modern adapters contain memory, so that the computer's random access memory (RAM) is not used for storing displays. In addition, most adapters have their own graphics coprocessor for performing graphics calculations. These adapters are often called graphics accelerators.

See also: graphics mode

virtual address

In a virtual memory system, the address the application uses to reference memory. The kernel and the memory management unit (MMU) translate this address into a physical address before the memory is actually read or written.

See also: virtual memory

virtual channel identifier (VCI)

A section of the asynchronous transfer mode (ATM) cell header that contains the virtual channel address over which the cell is to be routed.

See also: asynchronous transfer mode (ATM)

virtual cluster

A Network Load Balancing cluster that you create by assigning specific port rules to specific virtual IP addresses. With virtual clusters, you can use different port rules for different Web sites or applications hosted on the cluster, provided each Web site or application has a different virtual IP address.

See also: Network Load Balancing; Network Load Balancing cluster; port rule; virtual IP address

virtual container

A container that allows any Lightweight Directory Access Protocol (LDAP)-compliant directory to be accessed through Active Directory.

See also: Active Directory; directory; Lightweight Directory Access Protocol (LDAP)

virtual DOS machine (VDM)

A protected environment subsystem that emulates MS-DOS and 16-bit Windows within 32-bit versions of the Windows Server 2003 family. A VDM is created whenever a user starts an MS-DOS program in 32-bit versions of the Windows Server 2003 family.

Note that 64-bit versions of the Windows Server 2003 family cannot run MS-DOS and 16-bit Windows programs.

See also: MS-DOS (Microsoft Disk Operating System)

virtual IP address

An IP address that is shared among the hosts of a Network Load Balancing cluster. A Network Load Balancing cluster might also use multiple virtual IP addresses, for example, in a cluster of multihomed Web servers.

See also: host; IP address; multihomed computer; Network Load Balancing cluster

virtual link

A logical link between a backbone area border router and an area border router that is not connected to the backbone.

See also: area border router (ABR); backbone router

virtual local area network (VLAN)

A logical grouping of hosts on one or more local area networks (LANs) that allows communication to occur between hosts as if they were on the same physical LAN.

See also: host; local area network (LAN)

virtual memory

Temporary storage used by a computer to run programs that need more memory than it has. For example, programs could have access to 4 gigabytes (GB) of virtual memory on a computer's hard drive, even if the computer has only 32 megabytes (MB) of random access memory (RAM). The program data that does not currently fit in the computer's memory is saved into paging files.

See also: paging file; random access memory (RAM); Virtual Memory Size; virtual printer memory

Virtual Memory Size

In Task Manager, the amount of virtual memory, or address space, committed to a process.

See also: Task Manager; virtual memory

virtual network

A logical network that exists inside Novell NetWare and NetWare-compatible servers and routers but that is not associated with a physical adapter. The virtual network appears to a user as a separate network. On a computer running Windows 2000 Server or on an operating system in the Windows Server 2003 family, programs advertise their location on a virtual network, not a physical network. The internal network number identifies a virtual network inside a computer.

See also: external network number; internal network number

virtual path identifier (VPI)

A section of the asynchronous transfer mode (ATM) cell header that contains the virtual path address over which the cell is to be routed.

See also: asynchronous transfer mode (ATM)

virtual printer memory

In a PostScript printer, a part of memory that stores font information. The memory in PostScript printers is divided into two areas: banded memory and virtual memory. The banded memory contains graphics and page-layout information needed to print your documents. The virtual memory contains any font information that is sent to your printer either when you print a document or when you download fonts.

See also: PostScript printer; virtual memory

virtual private network (VPN)

The extension of a private network that encompasses encapsulated, encrypted, and authenticated links across shared or public networks. VPN connections can provide remote access and routed connections to private networks over the Internet.

See also: authentication; encryption; remote access; routing; tunnel

virtual server

In a server cluster, a collection of services that appear to clients as a physical Windows-based server but are not associated with a specific server. A virtual server is typically a resource group that contains all of the resources needed to run a particular application and that can be failed over like any other resource group. All virtual servers must include a Network Name resource and an IP Address resource.

See also: failover; IP Address resource; Network Name resource; resource; server cluster

virus

A program that attempts to spread from computer to computer and either cause damage (by erasing or corrupting data) or annoy users (by printing messages or altering what is displayed on the screen).

See also: Trojan horse

VLAN

See definition for: virtual local area network (VLAN)

VoIP (Voice over Internet Protocol)

A method for sending voice over a local area network (LAN), a wide area network (WAN), or the Internet using TCP/IP packets.

See also: local area network (LAN); Transmission Control Protocol/Internet Protocol (TCP/IP); wide area network (WAN)

volume

An area of storage on a hard disk. A volume is formatted by using a file system, such as file allocation table (FAT) or NTFS, and has a drive letter assigned to it. You can view the contents of a volume by clicking its icon in Windows Explorer or in My Computer. A single hard disk can have multiple volumes, and volumes can also span multiple disks.

See also: disk; drive letter; file allocation table (FAT); NTFS file system; simple volume; spanned volume

volume password

An optional, case-sensitive password you can assign to a Macintosh-accessible volume when you configure the volume. To access the volume, a user must type the volume password.

See also: password; volume

volume set

A volume that consists of disk space on one or more physical disks. A volume set is created by using basic disks and is supported only in Windows NT 4.0 or earlier. Volume sets were replaced by spanned volumes, which use dynamic disks.

See also: basic disk; dynamic disk; partition; spanned volume; volume

volume shadow copy

A volume that represents a duplicate of the original volume taken at the time the copy began.

See also: crash consistency; differential data; volume

voluntary tunnel

A tunnel that is initiated by the client. A voluntary tunnel tunnels Point-to-Point Protocol (PPP) over Internet Protocol (IP) from the client to the tunnel server, and then the data is forwarded to the target host by the tunnel server.

See also: client; host; Internet Protocol (IP); Point-to-Point Protocol (PPP); tunnel; tunnel server

VPI

See definition for: virtual path identifier (VPI)

VPN

See definition for: virtual private network (VPN)

VPN server

A computer that accepts virtual private network (VPN) connections from VPN clients. A VPN server can provide a remote access VPN connection or a router-to-router VPN connection.

See also: client; router; server; virtual private network (VPN)

W

Waiting for Call

A telephony signal that Network Connections has put the modem in Listen mode and is waiting for incoming calls.

See also: modem (modulator/demodulator); Network Connections

wake-on-LAN

A power management feature that allows a device to bring the operating system out of standby or sleep mode if there is network activity.

See also: sleep mode

WAN

See definition for: wide area network (WAN)

warning level

The point at which users are nearing their quota limit.

See also: quota limit

weak password

A password that does not provide an effective defense against unauthorized access to a resource. A weak password can be less than six characters long, contain all or part of a users account name, or contain less than three of the four following categories of characters: uppercase characters, lowercase characters, base 10 digits, and symbols found on the keyboard (such as !, @, #).

See also: password; password policy; strong password

Web Distributed Authoring and Versioning (WebDAV)

An application protocol related to Hypertext Transfer Protocol (HTTP) 1.1 that allows clients to transparently publish and manage resources on the World Wide Web.

See also: Hypertext Transfer Protocol (HTTP); protocol

Web server

A computer that is maintained by a system administrator or Internet service provider (ISP) and that responds to requests from a user's browser.

See also: Internet service provider (ISP)

WebDAV

See definition for: Web Distributed Authoring and Versioning (WebDAV)

well-connected

Sufficient connectivity to make your network and Active Directory useful to clients on your network. The precise meaning of well-connected is determined by your particular needs.

See also: Active Directory; client

well-known services

Services that are so pervasive in the computer industry that standard bindings are universally recognized. These services often maintain a machine-centric status and are frequently legacy services such as those developed for use in TCP/IP networks, for example, Telnet and File Transfer Protocol (FTP). Well-known services can published in Active Directory, but because their bindings are widely known, the information is superfluous.

See also: Active Directory; binding; File Transfer Protocol (FTP); machine-centric; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

wide area network (WAN)

A communications network connecting geographically separated computers, printers, and other devices. A WAN enables any connected device to interact with any other on the network.

See also: device; local area network (LAN)

wildcard character

A keyboard character that can be used to represent one or many characters when conducting a query. The question mark (?) represents a single character, and the asterisk (*) represents one or more characters.

wildcarding

In DNS, the supported use of wildcard characters such as the asterisk (*) in domain names for DNS queries that resolve to multiple names. When wildcarding is used, DNS servers must support resolving name queries that use wildcard characters, and resolvers must be able to parse multiple records from any resource record sets (RRsets) issued in wildcard query responses.

See also: DNS server; domain name; Domain Name System (DNS); resource record set (RRset); wildcard character

Windows Catalog

A Web site that lists hardware and software that is designed for use with Windows XP, Windows 2000 Server products, and products in the Windows Server 2003 family. You can use this site to help you decide whether to purchase a particular device or program, to help you evaluate whether a particular computer would support an upgraded operating system, or for similar decisions about hardware and software.

See also: device; Hardware Compatibility List (HCL)

Windows Clustering

A feature of Windows Server 2003, Enterprise Edition, and Windows Server 2003, Datacenter Edition, that provides the complementary clustering technologies, Network Load Balancing clusters, and server clusters.

See also: cluster; Network Load Balancing cluster; server cluster

Windows Hardware Quality Labs (WHQL)

Provides compatibility testing services to test hardware and drivers for Windows operating systems.

Windows Internet Name Service (WINS)

A software service that dynamically maps IP addresses to computer names (network basic input/output system (NetBIOS) names). This enables users to access resources by name instead of requiring them to use IP addresses that are difficult to recognize and remember.

See also: IP address; network basic input/output system (NetBIOS); resource; service; WINS proxy; WINS resource

Windows Logo Program

A certification program to help customers identify systems, hardware, and software that meet a baseline definition of platform features and quality goals and ensure a good user experience of Windows.

See also: signed driver; unsigned driver

Windows Management Instrumentation (WMI)

A management infrastructure in Windows that supports monitoring and controlling system resources through a common set of interfaces and provides a logically organized, consistent model of Windows operation, configuration, and status.

See also: resource

Windows Management Instrumentation filter

A query that is based on Windows Management Instrumentation (WMI) and used to filter the effect of a Group Policy object (GPO). WMI filters are written in WMI Query Language (WQL) and are evaluated on the target computer or user. If the filter evaluates to true, then the GPO is applied. Otherwise, the GPO is not applied. WMI filters are useful for exception management.

See also: Group Policy Management console (GPMC); Group Policy object (GPO); Group Policy object link

Windows Media Services

Software that provides multimedia support, allowing you to deliver content using Advanced Streaming Format over an internet or the Internet.

See also: multimedia streaming

Windows Open Services Architecture (WOSA)

A common set of interfaces that connect front-end applications with back-end services.

See also: service

Windows Support Tools

Tools that administrators, developers, or support personnel can use to diagnose and troubleshoot operating system configuration problems. Although Windows Support Tools are included on the operating system CD, they are not guaranteed or supported by Microsoft, and they must be installed separately from the operating system.

WINS

See definition for: Windows Internet Name Service (WINS)

WINS proxy

A computer that listens to name query broadcasts and responds for those names not on the local subnet. The proxy communicates with a WINS server to resolve names and then caches them for a specific time period.

See also: subnet; Windows Internet Name Service (WINS)

WINS resource

A resource type that provides Windows Internet Name Service (WINS) from a cluster.

See also: cluster; resource types; Windows Internet Name Service (WINS)

Winsock

Windows Sockets. An application programming interface (API) standard for software that provides a TCP/IP interface under Windows.

See also: application programming interface (API); Transmission Control Protocol/Internet Protocol (TCP/IP)

wireless communication

Communication between a computer and another computer or device without wires. The form of wireless communication provided as part of the Windows operating system uses infrared (IR) light to transmit files. Radio frequencies, as used by cellular and cordless telephones, are another form of wireless communication.

See also: infrared (IR); infrared device; infrared port

WMI

See definition for: Windows Management Instrumentation (WMI)

WMI filter

See definition for: Windows Management Instrumentation filter

workgroup

A simple grouping of computers, intended only to help users find such things as printers and shared folders within that group. Workgroups in Windows do not offer the centralized user accounts and authentication offered by domains.

See also: authentication; domain; user account

working set

For a process, the amount of physical memory assigned to the process by the operating system.

See also: process

World Wide Web

A system for exploring the Internet by using hyperlinks. When you use a Web browser, the Web appears as a collection of text, pictures, sounds, and digital movies.

See also: internet

WOSA

See definition for: Windows Open Services Architecture (WOSA)

X

X.500

A set of standards defining a distributed directory service, developed by the International Standards Organization (ISO).

See also: directory service

X.509 v3 certificate

Version 3 of the International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T) recommendation X.509 for certificate syntax and format. This is the standard certificate format used by Windows certificate-based processes.

An X.509 certificate includes the public key and information about the person or entity to whom the certificate is issued, information about the certificate, plus optional information about the certification authority (CA) issuing the certificate.

See also: certificate; certification authority (CA); International Telecommunication Union - Telecommunication [Standardization Sector] (ITU-T); public key

x86

Refers to microprocessors that have or emulate the 32-bit Intel processor architecture.

XML

See definition for: Extensible Markup Language (XML)

XOR (exclusive OR)

A Boolean operation that yields true if and only if one of its operands is true and the other is false. For some server operating systems, the exclusive OR is a Boolean operation in which the RAID-5 volume form of fault tolerance maintains an XOR of the total data to provide data redundancy. This is used to reconstruct missing data on a failed disk or sector from the remaining disks in the RAID-5 volume.

See also: fault tolerance; RAID-5 volume

Y

There are no glossary terms that begin with this letter.

Z

zone

In the Macintosh environment, a logical grouping that simplifies browsing the network for resources, such as servers and printers.

In a DNS database, a manageable unit of the DNS database that is administered by a DNS server. A zone stores the domain names and data of the domain with a corresponding name, except for domain names stored in delegated subdomains.

See also: DNS server; domain; Domain Name System (DNS); partition; resource

zone list

In the Macintosh environment, a list that includes all of the zones associated with a particular network. A zone list is not to be confused with a DNS zone.

See also: DNS zone; Domain Name System (DNS); zone

zone transfer

The synchronization of authoritative DNS data between DNS servers. A DNS server configured with a secondary zone periodically queries the master DNS servers to synchronize its zone data.

See also: authoritative; DNS server; primary zone; secondary zone; zone


Compile Date

 Compile Date: 2003-01-04